summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-11-14 13:39:35 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-11-14 15:16:52 +0100
commit3949e215965c0b9e4d0cf88336e5f4638bfde267 (patch)
tree21212d7b50db34c5f2e94b4a7a0fdb0b81b56e25 /kde-frameworks/purpose
parentkde-frameworks/plasma: 5.100.0 version bump (diff)
downloadgentoo-3949e215965c0b9e4d0cf88336e5f4638bfde267.tar.gz
gentoo-3949e215965c0b9e4d0cf88336e5f4638bfde267.tar.bz2
gentoo-3949e215965c0b9e4d0cf88336e5f4638bfde267.zip
kde-frameworks/purpose: 5.100.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/purpose')
-rw-r--r--kde-frameworks/purpose/Manifest1
-rw-r--r--kde-frameworks/purpose/purpose-5.100.0.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/kde-frameworks/purpose/Manifest b/kde-frameworks/purpose/Manifest
index df23c82e482b..c1fd0812685f 100644
--- a/kde-frameworks/purpose/Manifest
+++ b/kde-frameworks/purpose/Manifest
@@ -1,2 +1,3 @@
+DIST purpose-5.100.0.tar.xz 176608 BLAKE2B ed08a98397fd19569029f94edc1f88f31119f18d2c3bbacf2dbd3913e74d8742051333d87d4854387257b7360f97a0fc252c5ce10df9a7ca96c1259ee177bed7 SHA512 f0b6af4c40842dff9471746cc12b7f9195a239d4448faea79a506575ab701801bea7e62a82877718caa4b68b04edcb47ccca02234b629d12c981f5871e70d595
DIST purpose-5.96.0.tar.xz 172284 BLAKE2B 3a272ea568d862ed4c300a45dbf6c3d5eee6b9dd1a6b8bc1f9c08535375ae9bac1233514ca8b6bafc20febce4b42efd773fe8415dfd7156222cbe3302d33d7c2 SHA512 80ede3300842db1a1e2553525c47f0d8d5d8611c6fd5509b2e864f1832b468326c38f70fd1a9588260660c4aff6ac7264d8dade55a5c255a9b46cb4aff2445b7
DIST purpose-5.99.0.tar.xz 174964 BLAKE2B 18c0b9b51e3f7496f01b7404ad3a733aaae0cfed4781f188df0f66554db7320bfdd4fe2ce00ef7c91c21923ef9543e90b2e37f600e2fa2fa1462845e1348cfde SHA512 0f5070c6de1c6c7280c2cbc4c8848375bd689df6fcdf6f1eed0bd8c8abb695f6e5c926bbe21099c8d99bf562dfe96df6af269907e5fb9b01b0f2c5f5fabe54dd
diff --git a/kde-frameworks/purpose/purpose-5.100.0.ebuild b/kde-frameworks/purpose/purpose-5.100.0.ebuild
new file mode 100644
index 000000000000..977f6624605a
--- /dev/null
+++ b/kde-frameworks/purpose/purpose-5.100.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+ECM_TEST="forceoptional"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.5
+inherit ecm frameworks.kde.org optfeature xdg-utils
+
+DESCRIPTION="Library for providing abstractions to get the developer's purposes fulfilled"
+LICENSE="LGPL-2.1+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="bluetooth +kaccounts"
+
+# requires running environment
+RESTRICT="test"
+
+DEPEND="
+ >=dev-qt/qtdeclarative-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kcoreaddons-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kio-${PVCUT}*:5
+ =kde-frameworks/kirigami-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+ =kde-frameworks/prison-${PVCUT}*:5
+ kaccounts? (
+ >=kde-apps/kaccounts-integration-19.04.3:5
+ net-libs/accounts-qt
+ )
+"
+RDEPEND="${DEPEND}
+ >=dev-qt/qtquickcontrols-${QTMIN}:5
+ >=dev-qt/qtquickcontrols2-${QTMIN}:5
+ >=kde-frameworks/kdeclarative-${PVCUT}:5
+ bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:5 )
+ kaccounts? ( net-libs/accounts-qml )
+"
+
+src_prepare() {
+ ecm_src_prepare
+
+ use bluetooth ||
+ cmake_run_in src/plugins cmake_comment_add_subdirectory bluetooth
+}
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package kaccounts KAccounts)
+ )
+
+ ecm_src_configure
+}
+
+pkg_postinst() {
+ if [[ -z "${REPLACING_VERSIONS}" ]]; then
+ optfeature "Send through KDE Connect" kde-misc/kdeconnect
+ fi
+ ecm_pkg_postinst
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}