summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-06-12 21:35:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-06-12 21:41:10 +0200
commit8ce72acb451224087339da99e1fcf937a3ce306a (patch)
tree2f80e122f068010aad7494dbfe12ef76f2e441a1 /kde-frameworks/kwayland/kwayland-5.95.0.ebuild
parentkde-frameworks/kquickcharts: 5.95.0 version bump (diff)
downloadgentoo-8ce72acb451224087339da99e1fcf937a3ce306a.tar.gz
gentoo-8ce72acb451224087339da99e1fcf937a3ce306a.tar.bz2
gentoo-8ce72acb451224087339da99e1fcf937a3ce306a.zip
kde-frameworks/kwayland: 5.95.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/kwayland/kwayland-5.95.0.ebuild')
-rw-r--r--kde-frameworks/kwayland/kwayland-5.95.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/kde-frameworks/kwayland/kwayland-5.95.0.ebuild b/kde-frameworks/kwayland/kwayland-5.95.0.ebuild
new file mode 100644
index 000000000000..8d11ec295b6c
--- /dev/null
+++ b/kde-frameworks/kwayland/kwayland-5.95.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_TEST="true"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.3
+inherit ecm kde.org
+
+DESCRIPTION="Qt-style client and server library wrapper for Wayland libraries"
+HOMEPAGE="https://invent.kde.org/frameworks/kwayland"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# All failing, I guess we need a virtual wayland server
+RESTRICT="test"
+
+# slot op: includes qpa/qplatformnativeinterface.h
+RDEPEND="
+ >=dev-libs/wayland-1.15.0
+ >=dev-qt/qtconcurrent-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5=[egl]
+ >=dev-qt/qtwayland-${QTMIN}:5
+ media-libs/libglvnd
+"
+DEPEND="${RDEPEND}
+ >=dev-libs/plasma-wayland-protocols-1.7.0
+ >=dev-libs/wayland-protocols-1.15
+ sys-kernel/linux-headers
+"
+BDEPEND="
+ >=dev-qt/qtwaylandscanner-${QTMIN}:5
+ >=dev-util/wayland-scanner-1.19.0
+"