summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-08-09 13:10:33 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-08-09 15:11:58 +0200
commitf7404232a601955754fc4191f150d16c732aa60d (patch)
treeaf0e7407ba8a0ea26197e47f5ae6cd8286ab7580 /kde-frameworks/frameworkintegration
parentkde-frameworks/kconfig: running tests requires qml support (diff)
downloadgentoo-f7404232a601955754fc4191f150d16c732aa60d.tar.gz
gentoo-f7404232a601955754fc4191f150d16c732aa60d.tar.bz2
gentoo-f7404232a601955754fc4191f150d16c732aa60d.zip
kde-frameworks/frameworkintegration: 6.5.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-6.5.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 318cad97710a..51173fa025d0 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,2 +1,3 @@
DIST frameworkintegration-5.116.0.tar.xz 1760428 BLAKE2B 2b9aa2b6776549b333f858eceaa8086adb4e43f67298b1be858e90f6e230027ab1c99693590aa504b70f91dfa725a10872fbda1a104213e8bc9f5d95781ae83b SHA512 425fd38f87b2bba96f68afb8bc8108f9da6011106e33f32b2d91b97b8330d54d0bdc26bec8ecf50c32471d8f8e85af5f6d8b3feee0815225f5dd2075c41c8a83
DIST frameworkintegration-6.4.0.tar.xz 54844 BLAKE2B 04a0b197dcb774dbbfe4233082c83a7a65a2063c7c331c0c8d3fbaf37d8986607a5b7802de795556071a1880c1d0ac159e7c817287f281e2aad92a5c3ea4ac1a SHA512 f2fa96d370f6162ed1724b136f3da4401945595fa5caefcf1a715afbd98fbbe64d16b00c5dd2a9151eead1696a478eb6a76e199b267ca46e23e2126a9177d5ec
+DIST frameworkintegration-6.5.0.tar.xz 54480 BLAKE2B cda42086b1e62df9c168b2c90e0a01ae2135496a5ad87c1f81c3ece8be2e54e7fc366abbd302d4351172eb6ae580232c6b21b00a47f55d2e6cba305c9dbdd1f6 SHA512 aaab79c87748923d2759ea2899a292b7b00e89ae433b0ed926863d2af952bff81a86ac180432e90b93a8fca96089bf23edf249b68e8e6e545b375cdf13158f0d
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-6.5.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-6.5.0.ebuild
new file mode 100644
index 000000000000..501c4beb6662
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-6.5.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.6.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ =kde-frameworks/kcolorscheme-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kiconthemes-${PVCUT}*:6
+ =kde-frameworks/knewstuff-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:6
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt6=ON
+ )
+
+ ecm_src_configure
+}