summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2023-08-16 10:47:10 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2023-08-18 10:25:08 +0200
commit8df486f69d06e8b7b013a46cc013f2d23b58ebf6 (patch)
tree473b8e357774ba738f49056d865a9c79a20f8047 /kde-frameworks/frameworkintegration
parentdev-util/strace: update LICENSE (diff)
downloadgentoo-8df486f69d06e8b7b013a46cc013f2d23b58ebf6.tar.gz
gentoo-8df486f69d06e8b7b013a46cc013f2d23b58ebf6.tar.bz2
gentoo-8df486f69d06e8b7b013a46cc013f2d23b58ebf6.zip
kde-frameworks/frameworkintegration: 5.109.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-5.109.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index b611bd4f228a..2accd530e752 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1 +1,2 @@
DIST frameworkintegration-5.108.0.tar.xz 1759976 BLAKE2B 6b9b5b672b2a28e15ecfe9f088b357176e9dff059636b18ef8a121937f242969a37c95637d732177486fe2143bc9cd26f93ef9ca2d7dbaac995622914fdf62c2 SHA512 ea67b11edcffb546ec1cc41da03ac921738d6879ee0ecd652e27aacf6dd8af0d37da5bd29e2f3a43e41295abcec53d0b2679d56e937e99675cf0451d91db865e
+DIST frameworkintegration-5.109.0.tar.xz 1760448 BLAKE2B b895c0ed2c3f7785f85a24732bdf1425121b62aa2e7964e64c1c81e70b54da4609fed99716f230b8af57ae3250f0a0307dddf228d1ac76830cf56266c01c2902 SHA512 dff114cd4b1a12156883d0490e8764a4df490d4a9959d7907eeaf20c8f2c5e14f92f0aa2f475213ed2471c4640a72d9b52c07b64df3429109b39ef5e9455ef14
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-5.109.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-5.109.0.ebuild
new file mode 100644
index 000000000000..8fbe55cdc28b
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-5.109.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=5.15.9
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ =kde-frameworks/kconfig-${PVCUT}*:5
+ =kde-frameworks/kconfigwidgets-${PVCUT}*:5
+ =kde-frameworks/ki18n-${PVCUT}*:5
+ =kde-frameworks/kiconthemes-${PVCUT}*:5
+ =kde-frameworks/knewstuff-${PVCUT}*:5
+ =kde-frameworks/knotifications-${PVCUT}*:5
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:5
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:5
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt5=ON
+ )
+
+ ecm_src_configure
+}