summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-11-08 15:23:58 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2024-11-08 15:37:57 +0100
commit48c8bb9e3d54f8f4f0f4db52a98e3531181b8794 (patch)
tree4f1745cdceb63007f927bf044b907a9f46326b74 /kde-frameworks/frameworkintegration
parentnet-proxy/haproxy: Bump to 2.6.20 (diff)
downloadgentoo-48c8bb9e3d54f8f4f0f4db52a98e3531181b8794.tar.gz
gentoo-48c8bb9e3d54f8f4f0f4db52a98e3531181b8794.tar.bz2
gentoo-48c8bb9e3d54f8f4f0f4db52a98e3531181b8794.zip
kde-frameworks/frameworkintegration: 6.8.0 version bump
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-frameworks/frameworkintegration')
-rw-r--r--kde-frameworks/frameworkintegration/Manifest1
-rw-r--r--kde-frameworks/frameworkintegration/frameworkintegration-6.8.0.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/kde-frameworks/frameworkintegration/Manifest b/kde-frameworks/frameworkintegration/Manifest
index 6194d2b9656f..0ce4ec924d9a 100644
--- a/kde-frameworks/frameworkintegration/Manifest
+++ b/kde-frameworks/frameworkintegration/Manifest
@@ -1,3 +1,4 @@
DIST frameworkintegration-5.116.0.tar.xz 1760428 BLAKE2B 2b9aa2b6776549b333f858eceaa8086adb4e43f67298b1be858e90f6e230027ab1c99693590aa504b70f91dfa725a10872fbda1a104213e8bc9f5d95781ae83b SHA512 425fd38f87b2bba96f68afb8bc8108f9da6011106e33f32b2d91b97b8330d54d0bdc26bec8ecf50c32471d8f8e85af5f6d8b3feee0815225f5dd2075c41c8a83
DIST frameworkintegration-6.6.0.tar.xz 54608 BLAKE2B e3ced36528e26307526053fdbf9e996bbd48c0ba5a1dda1b6565653b2736e6dc87a1296f7ab7eec9be2acca651d13c80ac90e7975a0283746c74cd33b911f71f SHA512 f7ba0e12e89ef47d9b6657c9a2fffa9e2edbd69de9ce894a5ba146eafb842faf6a9adabe3cfd1f8b6a2136a48ff2dcb838ba677659dfaf610d219836bb809f05
DIST frameworkintegration-6.7.0.tar.xz 54628 BLAKE2B 0f28685881ef26071b3905794d5d0017876becd7100220b02cc38123efc94c10e688fb320366ac1939417015315416d7146476885c5cc262ef114b07537e9ca4 SHA512 f3fb48a2a60fc54b09424b38dbd265826b16444ab36c7bff3ecab438164490aab60c6d1bb86491f8780c8e9a12829191ad5653cc6398f0a7e4bbe28e49de6910
+DIST frameworkintegration-6.8.0.tar.xz 54620 BLAKE2B 69cdadcd7fd04bee52f411a4038d8ae4efd830dbaa694fddb58e13357a24d76f62ec82096290fd4ae5d0b14839680ac2080769f682b34f4e0323fd5a52a6c923 SHA512 9854aa954fd7aa2e8ea285a1c4a62779564e47d2c176da9ecb1703c54fe2f4f9bde6f90c6bd0fb9a91f2082ccbd8f374aaec2548a8ec2b9758b3f5feb47bf13f
diff --git a/kde-frameworks/frameworkintegration/frameworkintegration-6.8.0.ebuild b/kde-frameworks/frameworkintegration/frameworkintegration-6.8.0.ebuild
new file mode 100644
index 000000000000..2972df88a25c
--- /dev/null
+++ b/kde-frameworks/frameworkintegration/frameworkintegration-6.8.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+ECM_QTHELP="false"
+PVCUT=$(ver_cut 1-2)
+QTMIN=6.7.2
+inherit ecm frameworks.kde.org
+
+DESCRIPTION="Framework for integrating Qt applications with KDE Plasma workspaces"
+
+LICENSE="LGPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE=""
+
+# requires running Plasma environment
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ =kde-frameworks/kcolorscheme-${PVCUT}*:6
+ =kde-frameworks/kconfig-${PVCUT}*:6
+ =kde-frameworks/ki18n-${PVCUT}*:6
+ =kde-frameworks/kiconthemes-${PVCUT}*:6
+ =kde-frameworks/knewstuff-${PVCUT}*:6
+ =kde-frameworks/knotifications-${PVCUT}*:6
+ =kde-frameworks/kwidgetsaddons-${PVCUT}*:6
+"
+DEPEND="${RDEPEND}
+ =kde-frameworks/kpackage-${PVCUT}*:6
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMAKE_DISABLE_FIND_PACKAGE_AppStreamQt=ON
+ -DCMAKE_DISABLE_FIND_PACKAGE_packagekitqt6=ON
+ )
+
+ ecm_src_configure
+}