summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-base/smokeqt
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-base/smokeqt')
-rw-r--r--kde-base/smokeqt/Manifest1
-rw-r--r--kde-base/smokeqt/metadata.xml16
-rw-r--r--kde-base/smokeqt/smokeqt-4.14.3-r1.ebuild56
3 files changed, 73 insertions, 0 deletions
diff --git a/kde-base/smokeqt/Manifest b/kde-base/smokeqt/Manifest
new file mode 100644
index 000000000000..eefa4d5dd298
--- /dev/null
+++ b/kde-base/smokeqt/Manifest
@@ -0,0 +1 @@
+DIST smokeqt-4.14.3.tar.xz 30684 SHA256 2939d6377ee22e64d28be7c7705ebda088a7f65efb2246d4114c41bb4276b909 SHA512 cc2beb66d683d0d90e4315fbc1e83170a0f7996c13e864f4e76fb8f18158387cf65c2b822d1f8fd8ba91658d8a6b97701e93fa120a52daf29b80943d9748912a WHIRLPOOL d7cd8349c9c2a5cc38f4e99eb5b91c54068dcfe5e45a103005f73dec6511aae29d37cb95c658687b437d0b0c68389eb09b3b5d655271427d1d5c78826ccb40c6
diff --git a/kde-base/smokeqt/metadata.xml b/kde-base/smokeqt/metadata.xml
new file mode 100644
index 000000000000..baa5ca8f8308
--- /dev/null
+++ b/kde-base/smokeqt/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+<use>
+ <flag name="declarative">Compile bindings for <pkg>dev-qt/qtdeclarative</pkg>.</flag>
+ <flag name="multimedia">Compile bindings for <pkg>dev-qt/qtmultimedia</pkg>.</flag>
+ <flag name="phonon">Compile bindings for Phonon.</flag>
+ <flag name="qimageblitz">Compile bindings for <pkg>media-libs/qimageblitz</pkg>.</flag>
+ <flag name="qscintilla">Compile bindings for <pkg>x11-libs/qscintilla</pkg>.</flag>
+ <flag name="qthelp">Compile bindings for QtHelp from <pkg>dev-qt/qthelp</pkg>.</flag>
+ <flag name="qwt">Compile bindings for <pkg>x11-libs/qwt</pkg>.</flag>
+ <flag name="webkit">Compile bindings for <pkg>dev-qt/qtwebkit</pkg>.</flag>
+ <flag name="xmlpatterns">Compile bindings for <pkg>dev-qt/qtxmlpatterns</pkg>.</flag>
+</use>
+</pkgmetadata>
diff --git a/kde-base/smokeqt/smokeqt-4.14.3-r1.ebuild b/kde-base/smokeqt/smokeqt-4.14.3-r1.ebuild
new file mode 100644
index 000000000000..69de18c7d28a
--- /dev/null
+++ b/kde-base/smokeqt/smokeqt-4.14.3-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DECLARATIVE_REQUIRED="optional"
+MULTIMEDIA_REQUIRED="optional"
+QTHELP_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+KDE_REQUIRED="never"
+
+inherit kde4-base
+
+DESCRIPTION="Scripting Meta Object Kompiler Engine - Qt bindings"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug +phonon qimageblitz qscintilla qwt webkit xmlpatterns"
+HOMEPAGE="http://techbase.kde.org/Development/Languages/Smoke"
+
+# Maybe make more of Qt optional?
+DEPEND="
+ $(add_kdebase_dep smokegen)
+ dev-qt/designer:4
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtscript:4
+ dev-qt/qtsql:4
+ dev-qt/qtsvg:4
+ dev-qt/qttest:4
+ phonon? ( media-libs/phonon[qt4] )
+ qimageblitz? ( >=media-libs/qimageblitz-0.0.4 )
+ qscintilla? ( x11-libs/qscintilla:= )
+ qwt? ( x11-libs/qwt:5[svg] )
+ webkit? ( dev-qt/qtwebkit:4 )
+ xmlpatterns? ( dev-qt/qtxmlpatterns:4 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DDISABLE_Qt3Support=ON
+ -DWITH_QT3_SUPPORT=OFF
+ $(cmake-utils_use_disable declarative QtDeclarative)
+ $(cmake-utils_use_disable multimedia QtMultimedia)
+ $(cmake-utils_use_disable opengl QtOpenGL)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with qimageblitz QImageBlitz)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_disable qthelp QtHelp)
+ $(cmake-utils_use_with qwt Qwt5)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ $(cmake-utils_use_disable xmlpatterns QtXmlPatterns)
+ )
+ kde4-base_src_configure
+}