summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason A. Donenfeld <zx2c4@gentoo.org>2020-12-17 18:15:54 +0100
committerJason A. Donenfeld <zx2c4@gentoo.org>2020-12-17 23:00:26 +0100
commit23227fd8a2cfd663d0e5d9aa4f107e64a47941ad (patch)
tree7710618e9723c3d4c9763ccfc171ca29a66c6f9e /kde-apps
parentnet-analyzer/netdata: Cleanup old versions (diff)
downloadgentoo-23227fd8a2cfd663d0e5d9aa4f107e64a47941ad.tar.gz
gentoo-23227fd8a2cfd663d0e5d9aa4f107e64a47941ad.tar.bz2
gentoo-23227fd8a2cfd663d0e5d9aa4f107e64a47941ad.zip
kde-apps/konsole: revbump to fix bold breakage
Upstream has a regression in the handling of bold/bright colors in Konsole, detailed here: https://bugs.kde.org/show_bug.cgi?id=430311 https://invent.kde.org/utilities/konsole/-/merge_requests/299 Before 20.12 colors looked like this: https://invent.kde.org/utilities/konsole/uploads/3d18886419733f6e0c6bec0041aef5f8/image.png With 20.12 colors look like this: https://invent.kde.org/utilities/konsole/uploads/e5eaa8503d9888befdc3213ca5bc6aab/image.png This follows the bug's suggestion of reverting a particular commit until upstream has a proper fix. Acked-by: Andreas K. Hüttel <dilfridge@gentoo.org> Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Jason A. Donenfeld <zx2c4@gentoo.org>
Diffstat (limited to 'kde-apps')
-rw-r--r--kde-apps/konsole/files/konsole-20.12.0-revert-bold-breakage.patch33
-rw-r--r--kde-apps/konsole/konsole-20.12.0-r1.ebuild72
2 files changed, 105 insertions, 0 deletions
diff --git a/kde-apps/konsole/files/konsole-20.12.0-revert-bold-breakage.patch b/kde-apps/konsole/files/konsole-20.12.0-revert-bold-breakage.patch
new file mode 100644
index 000000000000..8e79793601e7
--- /dev/null
+++ b/kde-apps/konsole/files/konsole-20.12.0-revert-bold-breakage.patch
@@ -0,0 +1,33 @@
+From 08a51bbdd70c0c850f44a660a7efbe4c394b8ee3 Mon Sep 17 00:00:00 2001
+From: "Jason A. Donenfeld" <Jason@zx2c4.com>
+Date: Thu, 17 Dec 2020 17:21:44 +0100
+Subject: [PATCH] Revert "Fix bold character color paint"
+
+This reverts commit 270d6ea3247bb41a51535129e4b1c8eef51cf316.
+---
+ src/Screen.cpp | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/src/Screen.cpp b/src/Screen.cpp
+index 8e7eee51..c8f477ce 100644
+--- a/src/Screen.cpp
++++ b/src/Screen.cpp
+@@ -474,8 +474,14 @@ void Screen::updateEffectiveRendition()
+ _effectiveBackground = _currentBackground;
+ }
+
+- if ((_currentRendition & RE_BOLD) == 0 && (_currentRendition & RE_FAINT) != 0) {
++ if ((_currentRendition & RE_BOLD) != 0) {
++ if ((_currentRendition & RE_FAINT) == 0) {
++ _effectiveForeground.setIntensive();
++ }
++ } else {
++ if ((_currentRendition & RE_FAINT) != 0) {
+ _effectiveForeground.setFaint();
++ }
+ }
+ }
+
+--
+2.29.2
+
diff --git a/kde-apps/konsole/konsole-20.12.0-r1.ebuild b/kde-apps/konsole/konsole-20.12.0-r1.ebuild
new file mode 100644
index 000000000000..ddcce96264fd
--- /dev/null
+++ b/kde-apps/konsole/konsole-20.12.0-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ECM_HANDBOOK="optional"
+ECM_TEST="true"
+KFMIN=5.75.0
+QTMIN=5.15.1
+VIRTUALX_REQUIRED="test"
+inherit ecm kde.org
+
+DESCRIPTION="KDE's terminal emulator"
+HOMEPAGE="https://apps.kde.org/en/konsole https://konsole.kde.org"
+
+LICENSE="GPL-2" # TODO: CHECK
+SLOT="5"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+IUSE="X"
+
+DEPEND="
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtnetwork-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=dev-qt/qtxml-${QTMIN}:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcompletion-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/kcrash-${KFMIN}:5
+ >=kde-frameworks/kdbusaddons-${KFMIN}:5
+ >=kde-frameworks/kguiaddons-${KFMIN}:5
+ >=kde-frameworks/kjobwidgets-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kinit-${KFMIN}:5
+ >=kde-frameworks/kiconthemes-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/knewstuff-${KFMIN}:5
+ >=kde-frameworks/knotifications-${KFMIN}:5
+ >=kde-frameworks/knotifyconfig-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kpty-${KFMIN}:5
+ >=kde-frameworks/kservice-${KFMIN}:5
+ >=kde-frameworks/ktextwidgets-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kwindowsystem-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+ X? ( x11-libs/libX11 )
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}"-revert-bold-breakage.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake_use_find_package X X11)
+ )
+
+ ecm_src_configure
+}
+
+src_test() {
+ # drkonqi process interferes. bug 702690
+ local myctestargs=(
+ -E "(DBusTest)"
+ )
+
+ ecm_src_test
+}