summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /kde-apps/print-manager
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'kde-apps/print-manager')
-rw-r--r--kde-apps/print-manager/Manifest1
-rw-r--r--kde-apps/print-manager/metadata.xml5
-rw-r--r--kde-apps/print-manager/print-manager-4.14.3.ebuild38
3 files changed, 44 insertions, 0 deletions
diff --git a/kde-apps/print-manager/Manifest b/kde-apps/print-manager/Manifest
new file mode 100644
index 000000000000..e1338d90c692
--- /dev/null
+++ b/kde-apps/print-manager/Manifest
@@ -0,0 +1 @@
+DIST print-manager-4.14.3.tar.xz 92484 SHA256 081736f273c7f13806828497caddf83d36d5e083d56b277dc363360614fbc135 SHA512 2cddb8b254125fc095fe0ea87f37a07c99edab8fd2dd115c4cc91a766e2e69b5c2e2061c7fa6eac64aa7d5bb3ba9c23db93ee78dcc898050496c553f41ff02f4 WHIRLPOOL 5cc136bcda948541089d2487e69b5bf8b8b874110d3f653d8844f586566296e5594b91ed2d06670d63115670c65e5f38ce79c6df1b4205438b1f7f260c268622
diff --git a/kde-apps/print-manager/metadata.xml b/kde-apps/print-manager/metadata.xml
new file mode 100644
index 000000000000..a23f444b67d6
--- /dev/null
+++ b/kde-apps/print-manager/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kde</herd>
+</pkgmetadata>
diff --git a/kde-apps/print-manager/print-manager-4.14.3.ebuild b/kde-apps/print-manager/print-manager-4.14.3.ebuild
new file mode 100644
index 000000000000..3ed3e052f93d
--- /dev/null
+++ b/kde-apps/print-manager/print-manager-4.14.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base
+
+DESCRIPTION="Manage print jobs and printers in KDE"
+KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux"
+IUSE="debug +gtk"
+
+DEPEND="
+ >=net-print/cups-1.5.0[dbus]
+"
+RDEPEND="${DEPEND}
+ !kde-base/printer-applet:4
+ !kde-base/system-config-printer-kde:4
+ !kde-misc/print-manager
+ gtk? ( app-admin/system-config-printer )
+"
+
+pkg_postinst(){
+ if ! use gtk ; then
+ ewarn
+ ewarn "By switching off \"gtk\" USE flag, you have chosen to do without"
+ ewarn "an important, though optional, runtime dependency:"
+ ewarn
+ ewarn "app-admin/system-config-printer"
+ ewarn
+ ewarn "${PN} will work nevertheless, but is going to be less comfortable"
+ ewarn "and will show the following error status during runtime:"
+ ewarn
+ ewarn "\"Failed to group devices: 'The name org.fedoraproject.Config.Printing"
+ ewarn "was not provided by any .service files'\""
+ ewarn
+ fi
+}