summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 09:30:23 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2019-01-10 16:50:00 +0100
commitf1b6a4697cb6bd8b01b005cca0996982fd736a2d (patch)
tree9b2799b0df1355e0ee40b8c909752698a0803837 /kde-apps/libksane/libksane-18.12.1.ebuild
parentapp-emulation/libvirt: init submodules for live ebuild (diff)
downloadgentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.gz
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.tar.bz2
gentoo-f1b6a4697cb6bd8b01b005cca0996982fd736a2d.zip
kde-apps: Add KDE Applications 18.12.1
Package-Manager: Portage-2.3.54, Repoman-2.3.12 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/libksane/libksane-18.12.1.ebuild')
-rw-r--r--kde-apps/libksane/libksane-18.12.1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/kde-apps/libksane/libksane-18.12.1.ebuild b/kde-apps/libksane/libksane-18.12.1.ebuild
new file mode 100644
index 000000000000..58728652c83c
--- /dev/null
+++ b/kde-apps/libksane/libksane-18.12.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+KDE_BLOCK_SLOT4="false"
+inherit kde5
+
+DESCRIPTION="SANE Library interface based on KDE Frameworks"
+LICENSE="|| ( LGPL-2.1 LGPL-3 )"
+KEYWORDS="~amd64 ~x86"
+IUSE="kwallet"
+
+DEPEND="
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtwidgets)
+ media-gfx/sane-backends
+ kwallet? ( $(add_frameworks_dep kwallet) )
+"
+RDEPEND="${DEPEND}
+ !<kde-apps/libksane-15.08.3-r1:4
+ !kde-base/legacy-icons
+"
+
+src_configure() {
+ local mycmakeargs=(
+ $(cmake-utils_use_find_package kwallet KF5Wallet)
+ )
+ kde5_src_configure
+}