summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2019-09-06 21:10:03 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-09-06 21:11:17 +0200
commitcace445d5118ee027dc43f829fc50f27d623134c (patch)
tree2dfaad77bd443bf2f28d49d3bcf8c2880aa92ff3 /kde-apps/ktp-accounts-kcm
parentdev-util/rbtools: maintainer-needed (diff)
downloadgentoo-cace445d5118ee027dc43f829fc50f27d623134c.tar.gz
gentoo-cace445d5118ee027dc43f829fc50f27d623134c.tar.bz2
gentoo-cace445d5118ee027dc43f829fc50f27d623134c.zip
kde-apps: Add KDE Applications 19.08.1
Package-Manager: Portage-2.3.75, Repoman-2.3.17 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ktp-accounts-kcm')
-rw-r--r--kde-apps/ktp-accounts-kcm/Manifest1
-rw-r--r--kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.08.1.ebuild63
2 files changed, 64 insertions, 0 deletions
diff --git a/kde-apps/ktp-accounts-kcm/Manifest b/kde-apps/ktp-accounts-kcm/Manifest
index 229c13d87bc8..9f0b0afa7c90 100644
--- a/kde-apps/ktp-accounts-kcm/Manifest
+++ b/kde-apps/ktp-accounts-kcm/Manifest
@@ -1,2 +1,3 @@
DIST ktp-accounts-kcm-19.04.3.tar.xz 262348 BLAKE2B 2f8227ae00e36b079d0a536d7d5769e0f45d8d2101e09974e59e61e734f1158614b823629bd1963498465728c82f574817e9df0e9cde4c59ac809fa869f1a15c SHA512 4b800d81dc6a61830d2e2da6ee006be2266e1d6862812d6f21b3fc9f85f5ab2ed0f617b8f0889529cd869e836c4dab51c35ce88b3a1c93877ed50949a67ad48a
DIST ktp-accounts-kcm-19.08.0.tar.xz 264852 BLAKE2B b7885fe994c22347eca3735437ee62527199e46b7baa5746d420fe00f5f3f9cf56a891faca1d347b2f3ed56bb3ac9df76e44233356507df12df4f589679c6de4 SHA512 0915ea271a70022accddbe39643d312b1c8c89a6fff5e12ea773d24d03bb0be20478a1868540c1541b73705bc40bba880143f5b5250a36c90551d513fd8d038d
+DIST ktp-accounts-kcm-19.08.1.tar.xz 264964 BLAKE2B 44fc119ec39d614a2d74e760c5671e1d7af31f406cc5fe7a79a3c1a39ed3d073434fd78a4296894de0249ee4b04b56886c5fc53209d990e00f75f40eb47040dc SHA512 c0b4c2dcddf48647f6ffbd976ab6318cf24a2aea9c19a418a350d101dbfc0ff3fcda2b69818ddd444c357ed5bdc01aae580b3757830a5e1b3d2af048ac676ee8
diff --git a/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.08.1.ebuild b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.08.1.ebuild
new file mode 100644
index 000000000000..9e36e7d45e41
--- /dev/null
+++ b/kde-apps/ktp-accounts-kcm/ktp-accounts-kcm-19.08.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit kde5
+
+DESCRIPTION="KDE Telepathy account management kcm"
+HOMEPAGE="https://community.kde.org/Real-Time_Communication_and_Collaboration"
+
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="experimental"
+
+BDEPEND="
+ dev-util/intltool
+"
+COMMON_DEPEND="
+ $(add_frameworks_dep kcodecs)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kitemviews)
+ $(add_frameworks_dep kservice)
+ $(add_frameworks_dep ktextwidgets)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_kdeapps_dep kaccounts-integration)
+ $(add_qt_dep qtdbus)
+ $(add_qt_dep qtgui)
+ $(add_qt_dep qtnetwork)
+ $(add_qt_dep qtwidgets)
+ net-libs/accounts-qt
+ net-libs/signond
+ net-libs/telepathy-qt[qt5(+)]
+"
+DEPEND="${COMMON_DEPEND}
+ $(add_frameworks_dep kcmutils)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kio)
+ net-libs/libaccounts-glib
+"
+RDEPEND="${COMMON_DEPEND}
+ $(add_kdeapps_dep kaccounts-providers)
+ net-im/telepathy-connection-managers
+"
+
+src_prepare() {
+ if use experimental; then
+ mv "${S}"/data/kaccounts/disabled/*.in "${S}"/data/kaccounts/ || \
+ die "couldn't enable experimental services"
+ fi
+ kde5_src_prepare
+}
+
+pkg_postinst() {
+ if use experimental; then
+ ewarn "Experimental providers are enabled."
+ ewarn "Most of them aren't integrated nicely and may require additional steps for account creation."
+ ewarn "Use at your own risk!"
+ fi
+ kde5_pkg_postinst
+}