summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-07-02 14:52:09 +0200
committerMichał Górny <mgorny@gentoo.org>2016-07-03 18:08:35 +0200
commit167c45876320bbea3bcbd9d749bcd438b6832c25 (patch)
tree3cbab5dbb9506cd91a5a883ff5b800266d5bb0c7 /kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild
parentkde-apps/kde-l10n: Migrate to L10N (diff)
downloadgentoo-167c45876320bbea3bcbd9d749bcd438b6832c25.tar.gz
gentoo-167c45876320bbea3bcbd9d749bcd438b6832c25.tar.bz2
gentoo-167c45876320bbea3bcbd9d749bcd438b6832c25.zip
kde-apps/kdepim-l10n: Migrate to L10N
Diffstat (limited to 'kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild')
-rw-r--r--kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild b/kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild
index 57055dcdeaac..e8c8248e1182 100644
--- a/kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild
+++ b/kde-apps/kdepim-l10n/kdepim-l10n-15.12.3.ebuild
@@ -35,8 +35,8 @@ URI_BASE="${SRC_URI/-${PV}.tar.xz/}"
SRC_URI=""
for MY_LANG in ${MY_LANGS} ; do
- IUSE="${IUSE} linguas_${MY_LANG}"
- SRC_URI="${SRC_URI} linguas_${MY_LANG}? ( ${URI_BASE/kdepim/kde}/kde-l10n-${MY_LANG}-${PV}.tar.xz )"
+ IUSE="${IUSE} l10n_${MY_LANG/[@_]/-}"
+ SRC_URI="${SRC_URI} l10n_${MY_LANG/[@_]/-}? ( ${URI_BASE/kdepim/kde}/kde-l10n-${MY_LANG}-${PV}.tar.xz )"
done
S="${WORKDIR}"
@@ -44,12 +44,10 @@ S="${WORKDIR}"
src_unpack() {
if [[ -z ${A} ]]; then
elog
- elog "You either have the LINGUAS variable unset, or it only"
- elog "contains languages not supported by ${P}."
- elog "You won't have any additional language support."
+ elog "None of the requested L10N are supported by ${P}."
elog
elog "${P} supports these language codes:"
- elog "${MY_LANGS}"
+ elog "${MY_LANGS//[@_]/-}"
elog
fi
@@ -60,9 +58,9 @@ src_prepare() {
default
local LNG DIR
- # add all linguas to cmake
+ # add all l10n to cmake
if [[ -n ${A} ]]; then
- for LNG in ${LINGUAS}; do
+ for LNG in ${MY_LANGS}; do
DIR="kde-l10n-${LNG}-${PV}"
SDIR="${S}/${DIR}/5/${LNG}"
if [[ -d "${DIR}" ]] ; then