summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2024-07-23 20:04:50 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2024-07-23 20:04:50 +0200
commit48e72a1c8066d675c17f03860a14e6e7581122d0 (patch)
tree33f1d03e21f8d6ffd430652f64b5e029cb7a4742 /kde-apps/ark
parentapp-portage/kuroo: drop 1.2.2 (diff)
downloadgentoo-48e72a1c8066d675c17f03860a14e6e7581122d0.tar.gz
gentoo-48e72a1c8066d675c17f03860a14e6e7581122d0.tar.bz2
gentoo-48e72a1c8066d675c17f03860a14e6e7581122d0.zip
kde-apps/ark: Disable app-batchextracttest, requires DBus
Closes: https://bugs.gentoo.org/927184 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'kde-apps/ark')
-rw-r--r--kde-apps/ark/ark-23.08.5.ebuild19
-rw-r--r--kde-apps/ark/ark-24.05.2-r1.ebuild24
2 files changed, 20 insertions, 23 deletions
diff --git a/kde-apps/ark/ark-23.08.5.ebuild b/kde-apps/ark/ark-23.08.5.ebuild
index be53271cbb8a..718473d023d8 100644
--- a/kde-apps/ark/ark-23.08.5.ebuild
+++ b/kde-apps/ark/ark-23.08.5.ebuild
@@ -51,6 +51,15 @@ BDEPEND="
elibc_glibc? ( test? ( amd64? ( app-arch/rar ) x86? ( app-arch/rar ) ) )
"
+CMAKE_SKIP_TESTS=(
+ # bug 822177: may segfault or hang indefinitely
+ kerfuffle-addtoarchivetest
+ # bug 827840: continuously broken with translations installed
+ plugins-clirartest
+ # bug 927184: requires DBus
+ app-batchextracttest
+)
+
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package zip LibZip)
@@ -59,16 +68,6 @@ src_configure() {
ecm_src_configure
}
-src_test() {
- local myctestargs=(
- # bug 822177: kerfuffle-addtoarchivetest: may segfault or hang indefinitely
- # bug 827840: plugins-clirartest: continuously broken with translations installed
- -E "(kerfuffle-addtoarchivetest|plugins-clirartest)"
- )
-
- ecm_src_test
-}
-
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "rar archive creation/extraction" "app-arch/rar"
diff --git a/kde-apps/ark/ark-24.05.2-r1.ebuild b/kde-apps/ark/ark-24.05.2-r1.ebuild
index 7402757e7b1b..bc5cb1735093 100644
--- a/kde-apps/ark/ark-24.05.2-r1.ebuild
+++ b/kde-apps/ark/ark-24.05.2-r1.ebuild
@@ -50,8 +50,17 @@ BDEPEND="
elibc_glibc? ( test? ( amd64? ( app-arch/rar ) x86? ( app-arch/rar ) ) )
"
-PATCHES=(
- "${FILESDIR}"/${P}-qt6.7-qtemporarydir.patch
+PATCHES=( "${FILESDIR}"/${P}-qt6.7-qtemporarydir.patch )
+
+CMAKE_SKIP_TESTS=(
+ # bug 822177: may segfault or hang indefinitely
+ kerfuffle-addtoarchivetest
+ # bug 827840: continuously broken with translations installed
+ plugins-clirartest
+ # bug 932499: failing upstream and disabled in 24.05.2
+ kerfuffle-extracttest
+ # bug 927184: requires DBus
+ app-batchextracttest
)
src_configure() {
@@ -62,17 +71,6 @@ src_configure() {
ecm_src_configure
}
-src_test() {
- local myctestargs=(
- # bug 822177: kerfuffle-addtoarchivetest: may segfault or hang indefinitely
- # bug 827840: plugins-clirartest: continuously broken with translations installed
- # bug 932499: kerfuffle-extracttest: failing upstream and disabled in 24.05.2
- -E "(kerfuffle-addtoarchivetest|plugins-clirartest|kerfuffle-extracttest)"
- )
-
- ecm_src_test
-}
-
pkg_postinst() {
if [[ -z "${REPLACING_VERSIONS}" ]]; then
optfeature "rar archive creation/extraction" "app-arch/rar"