summaryrefslogtreecommitdiff
path: root/gui-wm
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-08-03 19:42:32 +0300
committerSam James <sam@gentoo.org>2023-08-07 03:53:43 +0100
commit315cd82cde578b0288b54ec290ea7261f4455ee5 (patch)
tree43ceb2a90382f0f6df4b22bf0ab8786bf03c04d0 /gui-wm
parentgui-wm/hyprland: add 0.28.0 (diff)
downloadgentoo-315cd82cde578b0288b54ec290ea7261f4455ee5.tar.gz
gentoo-315cd82cde578b0288b54ec290ea7261f4455ee5.tar.bz2
gentoo-315cd82cde578b0288b54ec290ea7261f4455ee5.zip
gui-wm/hyprland: drop 0.26.0
Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/32157 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'gui-wm')
-rw-r--r--gui-wm/hyprland/Manifest1
-rw-r--r--gui-wm/hyprland/files/nvidia-0.25.0.patch43
-rw-r--r--gui-wm/hyprland/hyprland-0.26.0.ebuild97
3 files changed, 0 insertions, 141 deletions
diff --git a/gui-wm/hyprland/Manifest b/gui-wm/hyprland/Manifest
index 5570145a5c32..084e9cf370ae 100644
--- a/gui-wm/hyprland/Manifest
+++ b/gui-wm/hyprland/Manifest
@@ -1,3 +1,2 @@
-DIST hyprland-0.26.0.gh.tar.gz 1523005 BLAKE2B e54ebb73850f63427ff9347c7ad0cb2ffda3350baf3c4221de51b1094678f3ffdac67669f49bfe3ba416b627673f5ca8491d06e16791764ef1c39f5964f2b570 SHA512 b43639a8e0fdd60165b6caa51c9411bc6f97260690c5ee3d15126ef091ccf93955fdda904a226b4aeb4367785ecaba426882a2e9b726c2b79c81a2ede0f9e36a
DIST hyprland-0.27.2.gh.tar.gz 4992717 BLAKE2B 6725ee593edb4f7d127eb95ed567bc7344edc066a9ce818ba99bd15eb718ce1d8de86a63da5684521ccbe3ba918a3f385c3a3e662314704e60e855101d391d05 SHA512 92e8ca21eba52ff423654cd345d37125656c32e1262e4e76d8841ee4ba698788d46d70a5876fc9aca42440efa5dd4122f46c84365da53810284a666f5d13ce7e
DIST hyprland-0.28.0.gh.tar.gz 14060441 BLAKE2B 25059b74b67df222867e84f5f1d44219302e7e454ec68110b70d6e915e95913bfdc8c6112bc8725e9be61f10a44603a96ba70980a9835d4b7757363825b93326 SHA512 c0802f2b061d5c9265c7767fae6ddaf00c1bbf6dc620f75593ba1538f94105a9ebe1517b7be444a1e70b81fd3a4205afd8154ba9ad02b3d610b00a9440ee6a63
diff --git a/gui-wm/hyprland/files/nvidia-0.25.0.patch b/gui-wm/hyprland/files/nvidia-0.25.0.patch
deleted file mode 100644
index d9d2213607f4..000000000000
--- a/gui-wm/hyprland/files/nvidia-0.25.0.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-# From https://github.com/hyprwm/Hyprland/issues/2239#issuecomment-1536725235
-# This patch is recommended by the developer on systems running and Nvidia GPu
-diff --git a/render/gles2/renderer.c b/render/gles2/renderer.c
-index 6a86b183..823fc318 100644
---- a/render/gles2/renderer.c
-+++ b/render/gles2/renderer.c
-@@ -165,7 +165,7 @@ static bool gles2_bind_buffer(struct wlr_renderer *wlr_renderer,
- assert(wlr_egl_is_current(renderer->egl));
-
- push_gles2_debug(renderer);
-- glFlush();
-+ glFinish();
- glBindFramebuffer(GL_FRAMEBUFFER, 0);
- pop_gles2_debug(renderer);
-
-diff --git a/types/output/render.c b/types/output/render.c
-index ed1afa4a..ddc730c7 100644
---- a/types/output/render.c
-+++ b/types/output/render.c
-@@ -225,22 +225,7 @@ struct wlr_drm_format *output_pick_format(struct wlr_output *output,
- }
-
- uint32_t wlr_output_preferred_read_format(struct wlr_output *output) {
-- struct wlr_renderer *renderer = output->renderer;
-- assert(renderer != NULL);
--
-- if (!renderer->impl->preferred_read_format || !renderer->impl->read_pixels) {
-- return DRM_FORMAT_INVALID;
-- }
--
-- if (!output_attach_back_buffer(output, &output->pending, NULL)) {
-- return false;
-- }
--
-- uint32_t fmt = renderer->impl->preferred_read_format(renderer);
--
-- output_clear_back_buffer(output);
--
-- return fmt;
-+ return DRM_FORMAT_XRGB8888;
- }
-
- bool output_is_direct_scanout(struct wlr_output *output,
diff --git a/gui-wm/hyprland/hyprland-0.26.0.ebuild b/gui-wm/hyprland/hyprland-0.26.0.ebuild
deleted file mode 100644
index e67a76f747bd..000000000000
--- a/gui-wm/hyprland/hyprland-0.26.0.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit meson toolchain-funcs
-
-DESCRIPTION="A dynamic tiling Wayland compositor that doesn't sacrifice on its looks"
-HOMEPAGE="https://github.com/hyprwm/Hyprland"
-
-SRC_URI="https://github.com/hyprwm/${PN^}/releases/download/v${PV}/source-v${PV}.tar.gz -> ${PF}.gh.tar.gz"
-S="${WORKDIR}/${PN}-source"
-
-KEYWORDS="~amd64"
-LICENSE="BSD"
-SLOT="0"
-IUSE="X legacy-renderer systemd video_cards_nvidia"
-
-RDEPEND="
- app-misc/jq
- dev-libs/glib:2
- dev-libs/libinput:=
- dev-libs/libliftoff
- dev-libs/wayland
- dev-libs/wayland-protocols
- dev-util/glslang
- dev-util/vulkan-headers
- gui-libs/gtk-layer-shell
- media-libs/libdisplay-info
- media-libs/libglvnd[X?]
- media-libs/mesa[gles2,wayland,X?]
- media-libs/vulkan-loader
- sys-auth/seatd:=
- x11-base/xcb-proto
- x11-libs/cairo
- x11-libs/libdrm
- x11-libs/libxkbcommon
- x11-libs/pango
- x11-libs/pixman
- x11-misc/xkeyboard-config
- virtual/libudev:=
- X? (
- gui-libs/wlroots[x11-backend]
- x11-base/xwayland
- x11-libs/libxcb:=
- x11-libs/xcb-util-image
- x11-libs/xcb-util-renderutil
- x11-libs/xcb-util-wm
- )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-libs/hyprland-protocols
- >=dev-libs/wayland-1.22.0
- dev-util/wayland-scanner
- dev-vcs/git
- >=gui-libs/wlroots-0.16.0[X?]
-"
-
-pkg_setup() {
- [[ ${MERGE_TYPE} == binary ]] && return
-
- if tc-is-gcc; then
- STDLIBVER=$(echo '#include <string>' | $(tc-getCXX) -x c++ -dM -E - | \
- grep GLIBCXX_RELEASE | sed 's/.*\([1-9][0-9]\)/\1/')
-
- if ! [[ ${STDLIBVER} -ge 12 ]]; then
- die "Hyprland requires >=sys-devel/gcc-12.1.0 to build"
- fi
- elif [[ $(clang-major-version) -lt 16 ]]; then
- die "Hyprland requires >=sys-devel/clang-16.0.3 to build";
- fi
-}
-
-src_prepare() {
- if use video_cards_nvidia; then
- cd "${S}/subprojects/wlroots" || die
- eapply "${FILESDIR}/nvidia-0.25.0.patch"
- cd "${S}" || die
- fi
-
- default
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_feature legacy-renderer legacy_renderer)
- $(meson_feature X xwayland)
- $(meson_feature systemd)
- )
-
- meson_src_configure
-}
-
-src_install() {
- meson_src_install --skip-subprojects wlroots
-}