summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-07-28 14:42:40 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-07-28 14:43:17 -0400
commit5b6b773f1dce2b8aae44e6bc1326717531aaa7d8 (patch)
tree935c191a1a268b403c4881c351eeed0f3afc05bf /gui-libs
parentgames-strategy/ja2-stracciatella: drop 0.17.0 (diff)
downloadgentoo-5b6b773f1dce2b8aae44e6bc1326717531aaa7d8.tar.gz
gentoo-5b6b773f1dce2b8aae44e6bc1326717531aaa7d8.tar.bz2
gentoo-5b6b773f1dce2b8aae44e6bc1326717531aaa7d8.zip
gui-libs/egl-wayland: add 1.1.12_p20230718
Should fix a 1.1.12 regression with plasma, hardly tested so please report if it makes anything worse. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs')
-rw-r--r--gui-libs/egl-wayland/Manifest1
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.12_p20230718.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/Manifest b/gui-libs/egl-wayland/Manifest
index 0e0bb359b6c2..1a368cc5ae51 100644
--- a/gui-libs/egl-wayland/Manifest
+++ b/gui-libs/egl-wayland/Manifest
@@ -1,3 +1,4 @@
DIST egl-wayland-1.1.11_p20230202.tar.gz 67029 BLAKE2B 8261f33c885a5b9673a463d624e253c75ae5afac3364a4de7d7d51a3d0b57495fd62324e3924bd4e649475a0afd0eaab3b02b3b3fe86b689411ed123ec85e018 SHA512 ec505a76ab2b847b1e7f27969be82d86acd40fe573eaa90271971f84b0c4b6195f0fccc5ec184dc58f2b6fb5591e4a05eca1265494e0a3ce39841ae84e86fed2
DIST egl-wayland-1.1.12.tar.gz 67159 BLAKE2B e0183a5a443aeede5654e248d5fe61127fd999d9e78da7578bd46aa61d44b5b0de4109e73d611b35cba2b2e73949e3727b43d941f1f413a6786c15e366c2b634 SHA512 aa8e0d0639a8d9d85b85fa258f98f4280734cec5aefac776c5a92f04b8999cee9365e0f55cb885ce0cd6e574ae395895b9cea5efa951343eda5afb46216a5c43
+DIST egl-wayland-1.1.12_p20230718.tar.gz 67390 BLAKE2B 438f4d6ff3840162517303200bf266ae2037ad16483477f0f86c6695cfbef2ef2b5ad63d100afc0d3bd13a34ebc222fba0f098e83ce8adb7c18c4d60c66eb148 SHA512 42f1ec235eb0ce8af774d9f08b45f48f8b658d51c7e1e33a49fb734941b8db9558aac46eaa07ce7edb2c7e07f5e791d2245f1f68fb3a692a686a0296fe559433
DIST egl-wayland-1.1.7.tar.gz 48681 BLAKE2B eebbd0e36045c50b39ef70292156f5cd137a51af2169b56a35d318d90ade3d4a5b94206d86246d52fda0c6c093ff25e389b1a3ccbe60595dc9661d199e30f33b SHA512 edc81d9f2c617587044d5f9d35b3e355db8544e8fa1d861c1b92a5a11bc1af7d994ca8abd49ce6f462a1971f20296b4c757bdf1df0d2bfc981cdafaa839f12af
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.12_p20230718.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.12_p20230718.ebuild
new file mode 100644
index 000000000000..d5309dc0478c
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.12_p20230718.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+HASH_EGLWAYLAND=ea70449fd94b5f866ea6189bf4f41f7c230cccfa
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-wayland/archive/${HASH_EGLWAYLAND}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/${PN}-${HASH_EGLWAYLAND}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland
+ !<x11-drivers/nvidia-drivers-470.57.02[wayland(-)]"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ gui-libs/eglexternalplatform
+ media-libs/libglvnd
+ x11-libs/libdrm
+"
+BDEPEND="dev-util/wayland-scanner"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_install() {
+ meson_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}
+
+pkg_postinst() {
+ if has_version "<x11-drivers/nvidia-drivers-471"; then
+ ewarn "<=nvidia-drivers-470.xx may not work properly with this version of"
+ ewarn "egl-wayland, it is recommended to use nouveau drivers for wayland."
+ fi
+}