summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-08-23 01:09:57 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-08-23 01:13:18 -0400
commit60cb92ff4fedcd9a3dd08794daa863afcf7e1d10 (patch)
tree58bfb5f5edfcf874ff3f52913e03c1c34171abda /gui-libs/egl-wayland
parentdev-python/pytest-order: Remove old (diff)
downloadgentoo-60cb92ff4fedcd9a3dd08794daa863afcf7e1d10.tar.gz
gentoo-60cb92ff4fedcd9a3dd08794daa863afcf7e1d10.tar.bz2
gentoo-60cb92ff4fedcd9a3dd08794daa863afcf7e1d10.zip
gui-libs/egl-wayland: add 1.1.16
Albeit not lifting the mask yet, been going back&forth with this too much and it is likely that there is other issues (plus official nvidia-drivers still ships with 1.1.13.1). Feel free to unmask if want to try. Closes: https://bugs.gentoo.org/937773 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'gui-libs/egl-wayland')
-rw-r--r--gui-libs/egl-wayland/Manifest1
-rw-r--r--gui-libs/egl-wayland/egl-wayland-1.1.16.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/gui-libs/egl-wayland/Manifest b/gui-libs/egl-wayland/Manifest
index 950fd6fe6f35..49c788e57529 100644
--- a/gui-libs/egl-wayland/Manifest
+++ b/gui-libs/egl-wayland/Manifest
@@ -1,2 +1,3 @@
DIST egl-wayland-1.1.13.1.tar.gz 68181 BLAKE2B 12587c24828570b5ad399042bb339b27c4d17e14896398d331970b32020956f12d56155e6b97f82c0e7c5f7aa5ad962b923c37ff1609f5384a99bb83e02c2dd7 SHA512 264373b22bab2a26dcd8391308ae24c0afe31168c318fd8fdf74a9958bc41658f9295645c4d91e395b5ab472cdf9dcf5160c448ba54e0aa8eccf04c294ffdb5b
DIST egl-wayland-1.1.15.tar.gz 74483 BLAKE2B f457f27a70b132fa753c688711bb03301d7c22bc1bf039fa6dbf87f8a288572fdd4feb9b5da9e5545d06be95b8c3b3259a82189af14a5ae036f72cf0d01a8a1d SHA512 714f3d52dc1a884adc7d4942bc2486774637f61a05e74b3f00cc9389fadb1328b7fc87b31be9f49bd5be65e43bd6e6dc5341e2e7755ff6549dabaafcd2c50a3c
+DIST egl-wayland-1.1.16.tar.gz 74615 BLAKE2B ebb6c5ca00bcf78a2d09bc555da8023c16d340c0793b92833fbcc2b05de5a92e26bc59391af9b42d9ed079290c19e94897cf925bc92a926bd518aa3c1a3ccd38 SHA512 cd32f565c287808ebc9999c46650aecbd023d2df6e1824d30c58822e2f93fe807b37eb87c4626b0874797ad61cfcc75a436f528ec7947dd98c5bae24ca6e7a28
diff --git a/gui-libs/egl-wayland/egl-wayland-1.1.16.ebuild b/gui-libs/egl-wayland/egl-wayland-1.1.16.ebuild
new file mode 100644
index 000000000000..93079328f2a5
--- /dev/null
+++ b/gui-libs/egl-wayland/egl-wayland-1.1.16.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson-multilib
+
+DESCRIPTION="EGLStream-based Wayland external platform"
+HOMEPAGE="https://github.com/NVIDIA/egl-wayland/"
+SRC_URI="
+ https://github.com/NVIDIA/egl-wayland/archive/refs/tags/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-libs/wayland[${MULTILIB_USEDEP}]
+ x11-libs/libdrm[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/wayland-protocols
+ >=gui-libs/eglexternalplatform-1.1-r1
+ media-libs/libglvnd
+"
+BDEPEND="
+ dev-util/wayland-scanner
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.6-remove-werror.patch
+)
+
+src_install() {
+ meson-multilib_src_install
+
+ insinto /usr/share/egl/egl_external_platform.d
+ doins "${FILESDIR}"/10_nvidia_wayland.json
+}