summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2023-09-07 15:52:47 -0300
committerPacho Ramos <pacho@gentoo.org>2023-10-08 13:51:13 +0200
commitdb7998f698dd5555e28a39ec944fe9e563c0aab4 (patch)
tree4c8508a3f8d065c38c3860b478be56292548ed1e /gnome-extra/zenity/zenity-3.99.2.ebuild
parentgnome-extra/gnome-tweaks: Version bump to 45.0 (diff)
downloadgentoo-db7998f698dd5555e28a39ec944fe9e563c0aab4.tar.gz
gentoo-db7998f698dd5555e28a39ec944fe9e563c0aab4.tar.bz2
gentoo-db7998f698dd5555e28a39ec944fe9e563c0aab4.zip
gnome-extra/zenity: Version bump to 3.99.2
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/32676 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/zenity/zenity-3.99.2.ebuild')
-rw-r--r--gnome-extra/zenity/zenity-3.99.2.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/zenity/zenity-3.99.2.ebuild b/gnome-extra/zenity/zenity-3.99.2.ebuild
new file mode 100644
index 000000000000..b940b30e3a79
--- /dev/null
+++ b/gnome-extra/zenity/zenity-3.99.2.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Tool to display dialogs from the commandline and shell scripts"
+HOMEPAGE="https://wiki.gnome.org/Projects/Zenity"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="man webkit"
+
+# TODO: X11 dependency is automagically enabled
+RDEPEND="
+ >=gui-libs/libadwaita-1.2:1
+ webkit? ( >=net-libs/webkit-gtk-2.40.1:6 )
+ man? ( sys-apps/help2man )
+ x11-libs/gdk-pixbuf:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.4
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PV}-Make-help2man-depend-on-manpage-option.patch
+)
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use webkit webkitgtk)
+ $(meson_use man manpage)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}