summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillermo Joandet <gjoandet@gmail.com>2024-04-07 21:18:09 -0300
committerPacho Ramos <pacho@gentoo.org>2024-08-09 11:53:20 +0200
commitb263ed86f663e1e60aa8acbc73ca87cccb6fc954 (patch)
tree6293f7fb959a80c8a21a917e67c31533ec2f3525 /gnome-extra/sushi
parentdev-libs/gobject-introspection-common: Bump to 1.80.1 (diff)
downloadgentoo-b263ed86f663e1e60aa8acbc73ca87cccb6fc954.tar.gz
gentoo-b263ed86f663e1e60aa8acbc73ca87cccb6fc954.tar.bz2
gentoo-b263ed86f663e1e60aa8acbc73ca87cccb6fc954.zip
gnome-extra/sushi: Bump to 46.0
Signed-off-by: Guillermo Joandet <gjoandet@gmail.com> Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/sushi')
-rw-r--r--gnome-extra/sushi/Manifest1
-rw-r--r--gnome-extra/sushi/sushi-46.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/gnome-extra/sushi/Manifest b/gnome-extra/sushi/Manifest
index 79be4c8a5b05..647d770b43ea 100644
--- a/gnome-extra/sushi/Manifest
+++ b/gnome-extra/sushi/Manifest
@@ -1 +1,2 @@
DIST sushi-45.0.tar.xz 83404 BLAKE2B 15a6e2c3b6a50451bfe72a17efaa14a934b040a415a198502b5d39a26aa039f1ec521ad71a98f319e98b023133834fc2eba42be77f9f86dd942e96a3eb8c47b6 SHA512 25f8183e8a98ece5f8fe8b62bd60c1570e580634bc154650c044d37a18f3848fac724a2bebcc59a6d2b55290cf2ec852abda21864b15d97b3395183c2391ae0f
+DIST sushi-46.0.tar.xz 84316 BLAKE2B 1a05fbfa1a9b67401945042adc69d643d8f035a313fbeaa8c723757f7f8c36dad56a2d6f0412a347e82e02ea0793526ec96b8ac3d9a93eb4d400891b2c58da6b SHA512 a05a9e1c1135fe20b917977eb3b6c7ba35202a8e490f62e0ada913a2e3c7e98b42ef33246661843ffa2665c609e8f329fd74cc692502fc6be2b0b7eadae87634
diff --git a/gnome-extra/sushi/sushi-46.0.ebuild b/gnome-extra/sushi/sushi-46.0.ebuild
new file mode 100644
index 000000000000..42742254fa15
--- /dev/null
+++ b/gnome-extra/sushi/sushi-46.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome.org meson optfeature xdg
+
+DESCRIPTION="A quick previewer for Nautilus, the GNOME file manager"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/sushi"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="wayland +X"
+REQUIRED_USE="|| ( wayland X )"
+
+DEPEND="
+ media-libs/libepoxy
+ >=app-text/evince-3.0[introspection]
+ media-libs/freetype:2
+ >=x11-libs/gdk-pixbuf-2.23.0[introspection]
+ >=dev-libs/glib-2.29.14:2
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ >=x11-libs/gtk+-3.13.2:3[introspection,wayland?,X?]
+ >=x11-libs/gtksourceview-4.0.3:4[introspection]
+ >=media-libs/harfbuzz-0.9.9:=
+ >=dev-libs/gobject-introspection-1.54:=
+ >=dev-libs/gjs-1.40
+"
+RDEPEND="${DEPEND}
+ >=gnome-base/nautilus-3.1.90
+ media-plugins/gst-plugins-gtk:1.0[wayland?,X?]
+"
+BDEPEND="
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature wayland)
+ $(meson_feature X X11)
+ -Dprofile=default
+ )
+ meson_src_configure
+}
+
+src_compile() {
+ local -x GST_PLUGIN_SYSTEM_PATH_1_0=
+ meson_src_compile
+}
+
+pkg_postinst() {
+ optfeature "Support viewing file formats such as generated by LibreOffice" \
+ app-office/libreoffice app-office/libreoffice-bin
+}