summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-01 13:20:45 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-01 13:24:23 -0400
commitc49581ca4437c1379877a616fe9bdba6f1d557de (patch)
tree5b5c67d840858cdefda5800138ced728af2c058f /gnome-extra/gnome-weather
parenteclass/tests/unpacker.sh: Add online tests for makeself (diff)
downloadgentoo-c49581ca4437c1379877a616fe9bdba6f1d557de.tar.gz
gentoo-c49581ca4437c1379877a616fe9bdba6f1d557de.tar.bz2
gentoo-c49581ca4437c1379877a616fe9bdba6f1d557de.zip
gnome-extra/gnome-weather: Version bump to 43.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-weather')
-rw-r--r--gnome-extra/gnome-weather/Manifest1
-rw-r--r--gnome-extra/gnome-weather/gnome-weather-43.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/gnome-weather/Manifest b/gnome-extra/gnome-weather/Manifest
index 8003e84005d0..66123dc7a11c 100644
--- a/gnome-extra/gnome-weather/Manifest
+++ b/gnome-extra/gnome-weather/Manifest
@@ -1 +1,2 @@
DIST gnome-weather-42.0.tar.xz 233552 BLAKE2B 64cdefbcdc93359518b4e08564eafc3235d7b2ab92d69d79b558c5d4f5ce03425d87fb8e7e351165d00983eab5807ebc05aa7c0eb604a618d135afb66170c8ff SHA512 10471a32adc148fad393e03098396a3cfccc75d1cd18985cdd2c287927213aeb493f2878ea986e1d3a3af4b1d3f439afcdb96833d849bbd5fbe7aebb1d1992e6
+DIST gnome-weather-43.0.tar.xz 234344 BLAKE2B d255fec2103f9af3ce36db64d0d294732693850c9acd6bd53ea45552ac19e577786df3b110b66ff59d0d99df9f39f53592f48b4e1cad3aabf675bb4a410e19a9 SHA512 392f9c3f41583767d3dc8f3411b36c7eacc6191648879948f87c92d0891cf7ee34090e7093a91a5d7e07b4b795235a3ff675c1f34854b61e5faa6fe7dba17b9b
diff --git a/gnome-extra/gnome-weather/gnome-weather-43.0.ebuild b/gnome-extra/gnome-weather/gnome-weather-43.0.ebuild
new file mode 100644
index 000000000000..e5d01492a546
--- /dev/null
+++ b/gnome-extra/gnome-weather/gnome-weather-43.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A weather application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/Weather"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.32:2
+ >=dev-libs/gobject-introspection-1.56:=
+ >=gui-libs/gtk-4.5:4
+ >=dev-libs/gjs-1.71.0
+ >=app-misc/geoclue-2.3.1:2.0
+ >=gui-libs/libadwaita-1.2.0:1=
+ >=dev-libs/libgweather-3.90.0:4=
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+# libxml2 required for glib-compile-resources
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+# Tests have a lot of issues, starting with reliance on a system installation,
+# accessing the network and other intermittent failures with network-sandbox disabled
+# https://gitlab.gnome.org/GNOME/gnome-weather/issues/67 (and rest not filed)
+# test dep: $(python_gen_any_dep 'dev-util/dogtail[${PYTHON_USEDEP}]')
+# With 3.34, this is now behind a dogtail option we can pass (and have data validation)
+
+src_configure() {
+ meson_src_configure -Dprofile=default -Ddogtail=false
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}