summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorfcanlnony <76856769+fcanlnony@users.noreply.github.com>2023-01-25 16:49:12 +0800
committerMatt Turner <mattst88@gentoo.org>2023-07-18 18:04:41 -0400
commitcf86340152c1b0456b65ed7e6887976b5712d7ca (patch)
tree5fd420cd33a21053b2ae7bdf1c4e90c6e5a9c11f /gnome-extra/gnome-tweaks/gnome-tweaks-42_beta.ebuild
parentgnome-extra/gnome-calculator: Version bump to 45_alpha (diff)
downloadgentoo-cf86340152c1b0456b65ed7e6887976b5712d7ca.tar.gz
gentoo-cf86340152c1b0456b65ed7e6887976b5712d7ca.tar.bz2
gentoo-cf86340152c1b0456b65ed7e6887976b5712d7ca.zip
gnome-extra/gnome-tweaks: Version bump to 42_beta
Signed-off-by: fcanlnony <76856769+fcanlnony@users.noreply.github.com> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-tweaks/gnome-tweaks-42_beta.ebuild')
-rw-r--r--gnome-extra/gnome-tweaks/gnome-tweaks-42_beta.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/gnome-extra/gnome-tweaks/gnome-tweaks-42_beta.ebuild b/gnome-extra/gnome-tweaks/gnome-tweaks-42_beta.ebuild
new file mode 100644
index 000000000000..8190cc2f881f
--- /dev/null
+++ b/gnome-extra/gnome-tweaks/gnome-tweaks-42_beta.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 xdg
+
+DESCRIPTION="Customize advanced GNOME options"
+HOMEPAGE="https://wiki.gnome.org/Apps/Tweaks"
+
+LICENSE="GPL-3+ CC0-1.0"
+SLOT="0"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+
+DEPEND="${PYTHON_DEPS}"
+# See README.md for list of deps
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=dev-python/pygobject-3.10.2:3[${PYTHON_USEDEP}]
+ ')
+ >=gnome-base/gnome-settings-daemon-3
+ x11-themes/sound-theme-freedesktop
+
+ >=dev-libs/glib-2.58:2
+ >=x11-libs/gtk+-3.12:3[introspection]
+ >=gnome-base/gnome-desktop-3.30:3[introspection]
+ gui-libs/libhandy:1[introspection]
+ x11-libs/libnotify[introspection]
+ x11-libs/pango[introspection]
+ >=gnome-base/gsettings-desktop-schemas-40.0
+ >=gnome-base/gnome-shell-3.24
+ x11-wm/mutter
+"
+BDEPEND=">=sys-devel/gettext-0.19.8"
+
+src_install() {
+ meson_src_install
+ python_optimize
+ python_fix_shebang "${ED}"/usr/bin/
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}