summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2022-04-10 09:23:30 +0200
committerPacho Ramos <pacho@gentoo.org>2022-04-10 09:23:30 +0200
commit4c5f0699ce89fa1ec8fa9084c68d545dfba0803a (patch)
tree09e4bc7d3cbc0a483bbed2735be36457b4bb932f /gnome-extra/gnome-shell-extension-applications-overview-tooltip
parentgnome-extra/gnome-shell-extension-alphabetical-grid: drop 20.0 (diff)
downloadgentoo-4c5f0699ce89fa1ec8fa9084c68d545dfba0803a.tar.gz
gentoo-4c5f0699ce89fa1ec8fa9084c68d545dfba0803a.tar.bz2
gentoo-4c5f0699ce89fa1ec8fa9084c68d545dfba0803a.zip
gnome-extra/gnome-shell-extension-applications-overview-tooltip: add 15
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'gnome-extra/gnome-shell-extension-applications-overview-tooltip')
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest1
-rw-r--r--gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-15.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
index 3654ca9296c1..97c16eef6d9f 100644
--- a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/Manifest
@@ -1 +1,2 @@
DIST gnome-shell-extension-applications-overview-tooltip-14.tar.gz 27058 BLAKE2B 442e1b144358c40c6132ab2a067bb29439e826ccd540583a6e95d35841bca3eda53ac9b6004285c8ab63006d9e71dbdb46f0fb77310366cf976381bb70b50223 SHA512 6e5805f720e262181e4519ec8a19cf57dae41e3dcff3da4a4a1bc4a132bcc23aae575cc15aa0a0f5f04fe1a25a9ff3e03d5bcacb326c7bbc8d0b28351e0ecbfe
+DIST gnome-shell-extension-applications-overview-tooltip-15.tar.gz 25388 BLAKE2B 66efa481ac9fa10a74e5d57d309ed5a3ab8b6a11bda59273252f452b79086ab2bdd4da07ebaf7b152407409cb452bf9b3dcdceec94662c0c6d643002b1fd1f35 SHA512 34d4be856f21318c17d1675e8c097d8e2e5331b32e018d7c07a8c025ea4b9fdffa52ca491d75d4a182a2e4b63beea746707c5581e0d10d25280ec5627e92f882
diff --git a/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-15.ebuild b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-15.ebuild
new file mode 100644
index 000000000000..26b68add6dc1
--- /dev/null
+++ b/gnome-extra/gnome-shell-extension-applications-overview-tooltip/gnome-shell-extension-applications-overview-tooltip-15.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit gnome2-utils
+
+DESCRIPTION="Show tooltip with full name and description"
+HOMEPAGE="https://github.com/RaphaelRochet/applications-overview-tooltip"
+SRC_URI="https://github.com/RaphaelRochet/applications-overview-tooltip/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# https://github.com/RaphaelRochet/applications-overview-tooltip/issues/7
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ app-eselect/eselect-gnome-shell-extensions
+ >=gnome-base/gnome-shell-40
+"
+DEPEND=""
+BDEPEND=""
+
+S="${WORKDIR}/${P/gnome-shell-extension-}"
+extension_uuid="applications-overview-tooltip@RaphaelRochet"
+
+src_install() {
+ einstalldocs
+ insinto /usr/share/glib-2.0/schemas
+ doins schemas/*.xml
+ rm -rf README.md schemas || die
+ insinto /usr/share/gnome-shell/extensions/"${extension_uuid}"
+ doins -r *
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ ebegin "Updating list of installed extensions"
+ eselect gnome-shell-extensions update
+ eend $?
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}