summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /gnome-base/libgnomecanvas
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'gnome-base/libgnomecanvas')
-rw-r--r--gnome-base/libgnomecanvas/Manifest1
-rw-r--r--gnome-base/libgnomecanvas/libgnomecanvas-2.30.3-r1.ebuild64
-rw-r--r--gnome-base/libgnomecanvas/metadata.xml8
3 files changed, 73 insertions, 0 deletions
diff --git a/gnome-base/libgnomecanvas/Manifest b/gnome-base/libgnomecanvas/Manifest
new file mode 100644
index 000000000000..17fb851f12d6
--- /dev/null
+++ b/gnome-base/libgnomecanvas/Manifest
@@ -0,0 +1 @@
+DIST libgnomecanvas-2.30.3.tar.bz2 574139 SHA256 859b78e08489fce4d5c15c676fec1cd79782f115f516e8ad8bed6abcb8dedd40 SHA512 b5bfa2133f5172abd5228d467db4d980dd4ac125cdbf55dcc1d5055dc3330861320c12cccb52ea63ba7f69824504c9d25781cd78001dc7a92b11c6f7e0c550de WHIRLPOOL a39e49ec6789588fec045501b8b9d72b9de16d86f4abf87a120768152edcf3e396f2c9db1c3b2126c3cc6644cda3bd16be099078094563a2ee352a99b9eeb9a8
diff --git a/gnome-base/libgnomecanvas/libgnomecanvas-2.30.3-r1.ebuild b/gnome-base/libgnomecanvas/libgnomecanvas-2.30.3-r1.ebuild
new file mode 100644
index 000000000000..736e2099b79b
--- /dev/null
+++ b/gnome-base/libgnomecanvas/libgnomecanvas-2.30.3-r1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2 multilib multilib-minimal virtualx
+
+DESCRIPTION="The Gnome 2 Canvas library"
+HOMEPAGE="http://library.gnome.org/devel/libgnomecanvas/stable/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm ia64 ~mips ppc ppc64 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="glade"
+
+RDEPEND=">=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-2.24.23:2[${MULTILIB_USEDEP}]
+ >=media-libs/libart_lgpl-2.3.21-r2[${MULTILIB_USEDEP}]
+ >=x11-libs/pango-1.36.3[${MULTILIB_USEDEP}]
+ glade? ( >=gnome-base/libglade-2.6.4-r1:2.0[${MULTILIB_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ sys-devel/gettext
+ >=dev-util/intltool-0.35
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+
+src_prepare() {
+ gnome2_src_prepare
+
+ # Fix intltoolize broken file, see upstream #577133
+ sed "s:'\^\$\$lang\$\$':\^\$\$lang\$\$:g" -i po/Makefile.in.in \
+ || die "sed failed"
+
+ # Don't build demos that are not even installed, bug #226299
+ sed 's/^\(SUBDIRS =.*\)demos\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed 2 failed"
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE=${S} \
+ gnome2_src_configure \
+ $(use_enable glade) \
+ --disable-static
+
+ ln -s "${S}"/docs/reference/html docs/reference/html || die
+}
+
+multilib_src_install() {
+ gnome2_src_install
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ einstalldocs
+}
+
+multilib_src_test() {
+ Xemake check || die "Test phase failed"
+}
diff --git a/gnome-base/libgnomecanvas/metadata.xml b/gnome-base/libgnomecanvas/metadata.xml
new file mode 100644
index 000000000000..ea5254563c04
--- /dev/null
+++ b/gnome-base/libgnomecanvas/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+<use>
+ <flag name='glade'>Enable glade support</flag>
+</use>
+</pkgmetadata>