summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2024-06-22 23:05:50 +0100
committerJames Le Cuirot <chewi@gentoo.org>2024-06-22 23:06:13 +0100
commit3f283b648dab4eb4ff7b54d5fbd86a9c255525e0 (patch)
tree2b7c0403040d91e5b5c603208bd99552c154f7b5 /games-util
parentapp-editors/emacs: Stabilize 29.4 arm, #934746 (diff)
downloadgentoo-3f283b648dab4eb4ff7b54d5fbd86a9c255525e0.tar.gz
gentoo-3f283b648dab4eb4ff7b54d5fbd86a9c255525e0.tar.bz2
gentoo-3f283b648dab4eb4ff7b54d5fbd86a9c255525e0.zip
games-util/sc-controller: Bump to 0.4.8.16, drop old 0.4.18.15
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-util')
-rw-r--r--games-util/sc-controller/Manifest2
-rw-r--r--games-util/sc-controller/files/sc-controller-0.4.8.15-py12.patch89
-rw-r--r--games-util/sc-controller/sc-controller-0.4.8.16.ebuild (renamed from games-util/sc-controller/sc-controller-0.4.8.15.ebuild)4
3 files changed, 1 insertions, 94 deletions
diff --git a/games-util/sc-controller/Manifest b/games-util/sc-controller/Manifest
index ea5cf9c7cc89..476ec7fe3f13 100644
--- a/games-util/sc-controller/Manifest
+++ b/games-util/sc-controller/Manifest
@@ -1 +1 @@
-DIST sc-controller-0.4.8.15.tar.gz 2570427 BLAKE2B 23fe2de5557457162fccd3c88c5bc15149229ccfee2d6b473d93ddd0e747d8700a2454d32db753293bc70a95aab43d1959e93bc34f1a153b152aa9fbc1d73676 SHA512 a9b38270aaf761e0a62b690d64c64e07539292ffe7d724a31b7989afdacbf64dc1074805d34f07dfe0767cf5bdfc14e5000050782f310ea7f439f5f2af9faf07
+DIST sc-controller-0.4.8.16.tar.gz 2570556 BLAKE2B 2aafad5eeb05d0525646bc1c5c08659dc09eba764bca84c0bb25524883b40d9dc8aa26981c6aeab834e429f0211bb97da902e15433876187a3c5b22d61fe8391 SHA512 3e37049b91ff927f047b3518b0c8382875d6faf748fac842c6b3276fb327953e4b1c20ce83ec80baa2b5338d6262aa32ac7dcf6b924c886984564de97e1d8177
diff --git a/games-util/sc-controller/files/sc-controller-0.4.8.15-py12.patch b/games-util/sc-controller/files/sc-controller-0.4.8.15-py12.patch
deleted file mode 100644
index 41851c032811..000000000000
--- a/games-util/sc-controller/files/sc-controller-0.4.8.15-py12.patch
+++ /dev/null
@@ -1,89 +0,0 @@
-From 51dda4b98aac878bdbf84aa9715f7ecc9802ba1d Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Sat, 22 Jun 2024 14:24:01 +0100
-Subject: [PATCH 1/2] Fix parser to handle new non-terminating newline NL token
- in Python 3.12
-
----
- scc/parser.py | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/scc/parser.py b/scc/parser.py
-index 78633f0e..9e77de04 100644
---- a/scc/parser.py
-+++ b/scc/parser.py
-@@ -136,7 +136,7 @@ class ActionParser(object):
- def _parse_parameter(self):
- """ Parses single parameter """
- t = self._next_token()
-- while t.type == TokenType.NEWLINE or t.value == "\n":
-+ while t.type in (TokenType.NL, TokenType.NEWLINE) or t.value == "\n":
- if not self._tokens_left():
- raise ParseError("Expected parameter at end of string")
- t = self._next_token()
-@@ -236,7 +236,7 @@ class ActionParser(object):
- parameters.append(self._parse_parameter())
- # Check if next token is either ')' or ','
- t = self._peek_token()
-- while t.type == TokenType.NEWLINE or t.value == "\n":
-+ while t.type in (TokenType.NL, TokenType.NEWLINE) or t.value == "\n":
- self._next_token()
- if not self._tokens_left():
- raise ParseError("Expected ',' or end of parameter list after parameter '%s'" % (parameters[-1],))
-@@ -310,8 +310,8 @@ class ActionParser(object):
- action1 = self._create_action(action_class, *parameters)
- action2 = self._parse_action()
- return MultiAction(action1, action2)
--
-- if t.type == TokenType.NEWLINE or t.value == "\n":
-+
-+ if t.type in (TokenType.NL, TokenType.NEWLINE) or t.value == "\n":
- # Newline can be used to join actions instead of 'and'
- self._next_token()
- if not self._tokens_left():
-@@ -324,11 +324,11 @@ class ActionParser(object):
- action1 = self._create_action(action_class, *parameters)
- action2 = self._parse_action()
- return MultiAction(action1, action2)
--
-+
- if t.type == TokenType.OP and t.value == ';':
- # Two (or more) actions joined by ';'
- self._next_token()
-- while self._tokens_left() and self._peek_token().type == TokenType.NEWLINE:
-+ while self._tokens_left() and self._peek_token().type in (TokenType.NL, TokenType.NEWLINE):
- self._next_token()
- if not self._tokens_left():
- # Having ';' at end of string is not actually error
---
-2.45.1
-
-
-From e8cc68cb17effa413c3ffde2bce5f8dd1798b0c3 Mon Sep 17 00:00:00 2001
-From: James Le Cuirot <chewi@gentoo.org>
-Date: Sat, 22 Jun 2024 14:34:48 +0100
-Subject: [PATCH 2/2] Address Python ast deprecations that will be removed in
- 3.14
-
----
- scc/cheader.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/scc/cheader.py b/scc/cheader.py
-index d151d637..f84319f1 100644
---- a/scc/cheader.py
-+++ b/scc/cheader.py
-@@ -59,8 +59,8 @@ def eval_expr(expr):
- """ Eval and expression inside a #define using a suppart of python grammar """
-
- def _eval(node):
-- if isinstance(node, ast.Num):
-- return node.n
-+ if isinstance(node, ast.Constant):
-+ return node.value
- elif isinstance(node, ast.BinOp):
- return OPERATORS[type(node.op)](_eval(node.left), _eval(node.right))
- elif isinstance(node, ast.UnaryOp):
---
-2.45.1
-
diff --git a/games-util/sc-controller/sc-controller-0.4.8.15.ebuild b/games-util/sc-controller/sc-controller-0.4.8.16.ebuild
index 6f56ab7a0051..05c53bdb4a47 100644
--- a/games-util/sc-controller/sc-controller-0.4.8.15.ebuild
+++ b/games-util/sc-controller/sc-controller-0.4.8.16.ebuild
@@ -32,10 +32,6 @@ RDEPEND="
wayland? ( gui-libs/gtk-layer-shell[introspection(+)] )
"
-PATCHES=(
- "${FILESDIR}"/${P}-py12.patch
-)
-
distutils_enable_tests pytest
pkg_setup() {