summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-11-23 21:20:14 +0000
committerSam James <sam@gentoo.org>2024-11-23 21:24:56 +0000
commit7e5dd0f48556372ba10313ffc50ca05f4c072eea (patch)
tree1b942bb4df78f547cb2fc28ed44fa6f1077dc2ed /games-util/slade
parentx11-libs/libXi: Drop old versions (diff)
downloadgentoo-7e5dd0f48556372ba10313ffc50ca05f4c072eea.tar.gz
gentoo-7e5dd0f48556372ba10313ffc50ca05f4c072eea.tar.bz2
gentoo-7e5dd0f48556372ba10313ffc50ca05f4c072eea.zip
games-util/slade: fix build
"Fixes ambiguity of addActionGroup calls. In all addActionGroup calls with ambiguous usage, use a vector of strings to disambiguate." Closes: https://bugs.gentoo.org/938887 Thanks-to: Chase Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-util/slade')
-rw-r--r--games-util/slade/files/slade-3.2.4-compile.patch64
-rw-r--r--games-util/slade/slade-3.2.4-r1.ebuild1
2 files changed, 65 insertions, 0 deletions
diff --git a/games-util/slade/files/slade-3.2.4-compile.patch b/games-util/slade/files/slade-3.2.4-compile.patch
new file mode 100644
index 000000000000..3890518b3831
--- /dev/null
+++ b/games-util/slade/files/slade-3.2.4-compile.patch
@@ -0,0 +1,64 @@
+https://bugs.gentoo.org/938887#c11
+
+Fixes ambiguity of addActionGroup calls
+
+In all addActionGroup calls with ambiguous usage, use a vector of strings to disambiguate.
+--- a/src/MainEditor/UI/EntryPanel/TextEntryPanel.cpp
++++ b/src/MainEditor/UI/EntryPanel/TextEntryPanel.cpp
+@@ -93,7 +93,7 @@ TextEntryPanel::TextEntryPanel(wxWindow* parent) : EntryPanel(parent, "text")
+ text_area_->setJumpToControl(choice_jump_to_);
+
+ // Add 'Compile ACS' to end of toolbar
+- toolbar_->addActionGroup("Compile", { "arch_scripts_compileacs" }, true);
++ toolbar_->addActionGroup("Compile", vector<string>{ "arch_scripts_compileacs" }, true);
+
+ // Bind events
+ choice_text_language_->Bind(wxEVT_CHOICE, &TextEntryPanel::onChoiceLanguageChanged, this);
+--- a/src/MainEditor/UI/TextureXEditor/PatchTablePanel.cpp
++++ b/src/MainEditor/UI/TextureXEditor/PatchTablePanel.cpp
+@@ -205,7 +205,7 @@ PatchTablePanel::PatchTablePanel(wxWindow* parent, PatchTable* patch_table, Text
+ list_patches_->setSearchColumn(1); // Want to search by patch name not index
+ toolbar_ = new SToolBar(this, false, wxVERTICAL);
+ toolbar_->addActionGroup(
+- "_New", { "txed_pnames_add", "txed_pnames_addfile", "txed_pnames_delete", "txed_pnames_change" });
++ "_New", vector<string>{ "txed_pnames_add", "txed_pnames_addfile", "txed_pnames_delete", "txed_pnames_change" });
+ label_dimensions_ = new wxStaticText(this, -1, "Size: N/A");
+ label_textures_ = new wxStaticText(
+ this, -1, "In Textures: -", wxDefaultPosition, wxDefaultSize, wxST_ELLIPSIZE_END);
+--- a/src/MainEditor/UI/TextureXEditor/TextureEditorPanel.cpp
++++ b/src/MainEditor/UI/TextureXEditor/TextureEditorPanel.cpp
+@@ -295,6 +295,7 @@ wxPanel* TextureEditorPanel::createPatchControls(wxWindow* parent)
+ tb_patches_ = new SToolBar(panel, false, wxVERTICAL);
+ tb_patches_->addActionGroup(
+ "_Patch",
++ vector<string>
+ { "txed_patch_add",
+ "txed_patch_remove",
+ "txed_patch_back",
+--- a/src/MainEditor/UI/TextureXEditor/TextureXPanel.cpp
++++ b/src/MainEditor/UI/TextureXEditor/TextureXPanel.cpp
+@@ -625,10 +625,10 @@ TextureXPanel::TextureXPanel(wxWindow* parent, TextureXEditor& tx_editor) :
+
+ // Toolbar
+ toolbar_ = new SToolBar(this, false, wxVERTICAL);
+- toolbar_->addActionGroup("_Save", { "txed_savelist" });
+- toolbar_->addActionGroup("_New", { "txed_new", "txed_new_file" });
+- toolbar_->addActionGroup("_Texture", { "txed_rename", "txed_rename_each", "txed_delete" });
+- toolbar_->addActionGroup("_Sorting", { "txed_up", "txed_down", "txed_sort" });
++ toolbar_->addActionGroup("_Save", vector<string>{ "txed_savelist" });
++ toolbar_->addActionGroup("_New", vector<string>{ "txed_new", "txed_new_file" });
++ toolbar_->addActionGroup("_Texture", vector<string>{ "txed_rename", "txed_rename_each", "txed_delete" });
++ toolbar_->addActionGroup("_Sorting", vector<string>{ "txed_up", "txed_down", "txed_sort" });
+ toolbar_->group("_Texture")->setAllButtonsEnabled(false);
+ toolbar_->group("_Sorting")->setAllButtonsEnabled(false);
+ toolbar_->findActionButton("txed_sort")->Enable();
+--- a/src/MainEditor/UI/TextureXEditor/ZTextureEditorPanel.cpp
++++ b/src/MainEditor/UI/TextureXEditor/ZTextureEditorPanel.cpp
+@@ -232,6 +232,7 @@ wxPanel* ZTextureEditorPanel::createPatchControls(wxWindow* parent)
+ tb_patches_ = new SToolBar(panel, false, wxVERTICAL);
+ tb_patches_->addActionGroup(
+ "_Patch",
++ vector<string>
+ { "txed_patch_add",
+ "txed_patch_remove",
+ "txed_patch_back",
diff --git a/games-util/slade/slade-3.2.4-r1.ebuild b/games-util/slade/slade-3.2.4-r1.ebuild
index 06d0d3eeef76..5e70fd0ab9a4 100644
--- a/games-util/slade/slade-3.2.4-r1.ebuild
+++ b/games-util/slade/slade-3.2.4-r1.ebuild
@@ -49,6 +49,7 @@ S="${WORKDIR}/${PN^^}-${MY_PV}"
PATCHES=(
"${FILESDIR}"/${PN}-3.2.0_beta2-fluidsynth-driver.patch
"${FILESDIR}"/${PN}-3.2.2-wayland.patch
+ "${FILESDIR}"/${PN}-3.2.4-compile.patch
)
src_prepare() {