summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-10-06 22:38:40 -0400
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-10-06 22:42:49 -0400
commit9f9517df68bb4bbfaa308342630fc67f054af7ea (patch)
tree9dd60ece0e42049043b72d9ad96cdd764ef74f2d /games-util/pyfa/pyfa-9999.ebuild
parentprofiles/base/package.use.mask: mask wpa_supplicant[wimax] for bug #562362 (diff)
downloadgentoo-9f9517df68bb4bbfaa308342630fc67f054af7ea.tar.gz
gentoo-9f9517df68bb4bbfaa308342630fc67f054af7ea.tar.bz2
gentoo-9f9517df68bb4bbfaa308342630fc67f054af7ea.zip
games-util/pyfa: update live ebuild
Update patches for upstream code changes, update dependencies, install images in a compressed zip since upstream code now allows it, and switch to git-r3.eclass. Gentoo-Bug: 562080 Reported-by: Captain Crutches Package-Manager: portage-2.2.22
Diffstat (limited to 'games-util/pyfa/pyfa-9999.ebuild')
-rw-r--r--games-util/pyfa/pyfa-9999.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/games-util/pyfa/pyfa-9999.ebuild b/games-util/pyfa/pyfa-9999.ebuild
index 76dac888c189..5e11d005abf5 100644
--- a/games-util/pyfa/pyfa-9999.ebuild
+++ b/games-util/pyfa/pyfa-9999.ebuild
@@ -15,7 +15,7 @@ LICENSE="GPL-3+ LGPL-2.1+ CC-BY-2.5 free-noncomm"
SLOT="0"
if [[ ${PV} = 9999 ]]; then
EGIT_REPO_URI="https://github.com/DarkFenX/Pyfa.git"
- inherit git-2
+ inherit git-r3
KEYWORDS=""
else
SRC_URI="https://github.com/DarkFenX/Pyfa/archive/v${PV}.tar.gz -> pyfa-${PV}.tar.gz"
@@ -25,34 +25,34 @@ IUSE="+graph"
RDEPEND="dev-python/python-dateutil[${PYTHON_USEDEP}]
dev-python/sqlalchemy[${PYTHON_USEDEP}]
- dev-python/wxpython:2.8[${PYTHON_USEDEP}]
+ dev-python/wxpython:3.0[${PYTHON_USEDEP}]
graph? (
dev-python/matplotlib[wxwidgets,${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}] )
${PYTHON_DEPS}"
-DEPEND="app-arch/unzip"
+DEPEND="app-arch/zip"
-S=${WORKDIR}/Pyfa-${PV}
+[[ ${PV} = 9999 ]] || S=${WORKDIR}/Pyfa-${PV}
src_prepare() {
# get rid of CRLF line endings introduced in 1.1.10 so patches work
edos2unix config.py pyfa.py service/settings.py
- # make staticPath settable from configforced again
- epatch "${FILESDIR}/${PN}-1.1.20-staticPath.patch"
+ # load gameDB and images from separate staticdata directory
+ epatch "${FILESDIR}/${PN}-1.15.1-staticdata.patch"
# do not try to save exported html to python sitedir
epatch "${FILESDIR}/${PN}-1.1.8-html-export-path.patch"
# fix import path in the main script for systemwide installation
- epatch "${FILESDIR}/${PN}-1.1.11-import-pyfa.patch"
+ epatch "${FILESDIR}/${PN}-1.15.1-import-pyfa.patch"
touch __init__.py
pyfa_make_configforced() {
mkdir -p "${BUILD_DIR}" || die
sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
-e "s:%%EPREFIX%%:${EPREFIX}:" \
- "${FILESDIR}/configforced.py" > "${BUILD_DIR}/configforced.py"
+ "${FILESDIR}/configforced-1.15.1.py" > "${BUILD_DIR}/configforced.py"
sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
pyfa.py > "${BUILD_DIR}/pyfa"
}
@@ -63,7 +63,7 @@ src_install() {
pyfa_py_install() {
local packagedir=$(python_get_sitedir)/${PN}
insinto "${packagedir}"
- doins -r eos gui icons service utils config*.py __init__.py gpl.txt
+ doins -r eos gui service utils config*.py __init__.py
[[ -e info.py ]] && doins info.py # only in zip releases
doins "${BUILD_DIR}/configforced.py"
python_doscript "${BUILD_DIR}/pyfa"
@@ -72,12 +72,19 @@ src_install() {
python_foreach_impl pyfa_py_install
insinto /usr/share/${PN}
- doins -r staticdata
+ doins eve.db
+
+ einfo "Compressing images ..."
+ pushd imgs > /dev/null || die
+ zip -r imgs.zip * || die "zip failed"
+ doins imgs.zip
+ popd > /dev/null || die
+
dodoc README.md
insinto /usr/share/icons/hicolor/32x32/apps
- doins icons/pyfa.png
+ doins imgs/gui/pyfa.png
insinto /usr/share/icons/hicolor/64x64/apps
- newins icons/pyfa64.png pyfa.png
+ newins imgs/gui/pyfa64.png pyfa.png
domenu "${FILESDIR}/${PN}.desktop"
}