summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-08-19 17:11:28 +0200
committerConrad Kostecki <conikost@gentoo.org>2020-08-19 17:14:27 +0200
commit51fc11f34550b7a4002669bfca90c52aa9541249 (patch)
tree0aa6038719077e20f4a24aa6a257cfc0108b5bbe /games-util/nml
parentxfce-base/xfce4-settings: Bump to 4.15.2 (diff)
downloadgentoo-51fc11f34550b7a4002669bfca90c52aa9541249.tar.gz
gentoo-51fc11f34550b7a4002669bfca90c52aa9541249.tar.bz2
gentoo-51fc11f34550b7a4002669bfca90c52aa9541249.zip
games-util/nml: fix python3.8 support
Bug: https://bugs.gentoo.org/737952 Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'games-util/nml')
-rw-r--r--games-util/nml/files/nml-0.4.5-python38.patch37
-rw-r--r--games-util/nml/nml-0.4.5-r2.ebuild1
2 files changed, 38 insertions, 0 deletions
diff --git a/games-util/nml/files/nml-0.4.5-python38.patch b/games-util/nml/files/nml-0.4.5-python38.patch
new file mode 100644
index 000000000000..526a2e19f262
--- /dev/null
+++ b/games-util/nml/files/nml-0.4.5-python38.patch
@@ -0,0 +1,37 @@
+From 5b8764c3c4079941fab7be8d9086c38a88ae09ba Mon Sep 17 00:00:00 2001
+From: glx22 <glx22@users.noreply.github.com>
+Date: Sun, 20 Oct 2019 11:05:25 +0200
+Subject: [PATCH] Fix #52: time.clock() has been removed in python 3.8 (#53)
+
+---
+ nml/generic.py | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/nml/generic.py b/nml/generic.py
+index ce064b6c..8ee602f1 100644
+--- a/nml/generic.py
++++ b/nml/generic.py
+@@ -295,7 +295,7 @@ def clear_progress():
+ hide_progress()
+
+ if (progress_message is not None) and (verbosity_level >= VERBOSITY_TIMING):
+- print("{} {:.1f} s".format(progress_message, time.clock() - progress_start_time))
++ print("{} {:.1f} s".format(progress_message, time.process_time() - progress_start_time))
+
+ progress_message = None
+ progress_start_time = None
+@@ -324,12 +324,12 @@ def print_progress(msg, incremental = False):
+ progress_message = msg
+
+ if incremental:
+- t = time.clock()
++ t = time.process_time()
+ if (progress_update_time is not None) and (t - progress_update_time < 1):
+ return
+ progress_update_time = t
+ else:
+- progress_start_time = time.clock()
++ progress_start_time = time.process_time()
+
+ print_eol(msg)
+
diff --git a/games-util/nml/nml-0.4.5-r2.ebuild b/games-util/nml/nml-0.4.5-r2.ebuild
index 7627ddc1e890..3588cfc60e87 100644
--- a/games-util/nml/nml-0.4.5-r2.ebuild
+++ b/games-util/nml/nml-0.4.5-r2.ebuild
@@ -31,6 +31,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-0.4.4-pillow3.patch
"${FILESDIR}"/${PN}-0.4.5-pillow6.patch
"${FILESDIR}"/${PN}-0.4.5-pillow7.patch
+ "${FILESDIR}"/${PN}-0.4.5-python38.patch
)
src_install() {