summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-23 01:54:33 +0000
committerSam James <sam@gentoo.org>2023-01-23 02:32:49 +0000
commite4dcbf5e60b24ec0d33884abc026068cc3b94faf (patch)
treeb7e42e0a7bf0f43380334d99fe307188176b8c8a /games-strategy
parentdev-util/cloc: add 1.96 (diff)
downloadgentoo-e4dcbf5e60b24ec0d33884abc026068cc3b94faf.tar.gz
gentoo-e4dcbf5e60b24ec0d33884abc026068cc3b94faf.tar.bz2
gentoo-e4dcbf5e60b24ec0d33884abc026068cc3b94faf.zip
games-strategy/s25rttr: fix build w/ gcc 13
Closes: https://bugs.gentoo.org/891713 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/s25rttr/files/s25rttr-0.9.5-gcc-13.patch50
-rw-r--r--games-strategy/s25rttr/s25rttr-0.9.5.ebuild3
2 files changed, 52 insertions, 1 deletions
diff --git a/games-strategy/s25rttr/files/s25rttr-0.9.5-gcc-13.patch b/games-strategy/s25rttr/files/s25rttr-0.9.5-gcc-13.patch
new file mode 100644
index 000000000000..117c2645cc40
--- /dev/null
+++ b/games-strategy/s25rttr/files/s25rttr-0.9.5-gcc-13.patch
@@ -0,0 +1,50 @@
+https://bugs.gentoo.org/891713
+https://github.com/Return-To-The-Roots/s25client/pull/1548
+https://github.com/Return-To-The-Roots/libsiedler2/pull/21
+
+From d59abd4b565cd6f11dd64f6e4f497c9797e52c5a Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Mon, 23 Jan 2023 01:49:47 +0000
+Subject: [PATCH] LanGameInfo: Add missing <cstdint> include
+
+GCC 13 (as usual for new compiler releases) shuffles around some
+internal includes and so <cstdint> etc is no longer transitively included.
+
+See https://www.gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Closes: https://github.com/Return-To-The-Roots/libsiedler2/issues/20
+Bug: https://bugs.gentoo.org/891713
+--- a/libs/s25main/gameTypes/LanGameInfo.h
++++ b/libs/s25main/gameTypes/LanGameInfo.h
+@@ -4,6 +4,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+
+ class Serializer;
+
+From 6a289fa3a3f50f0967a072292f3e0c628144ab8d Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Mon, 23 Jan 2023 01:47:19 +0000
+Subject: [PATCH] oem: Add missing <cstdint> include
+
+GCC 13 (as usual for new compiler releases) shuffles around some
+internal includes and so <cstdint> etc is no longer transitively included.
+
+See https://www.gnu.org/software/gcc/gcc-13/porting_to.html.
+
+Closes: https://github.com/Return-To-The-Roots/libsiedler2/issues/20
+Bug: https://bugs.gentoo.org/891713
+--- a/external/libsiedler2/src/oem.cpp
++++ b/external/libsiedler2/src/oem.cpp
+@@ -4,6 +4,7 @@
+
+ #include "oem.h"
+ #include <array>
++#include <cstdint>
+
+ namespace libsiedler2 {
+
+
diff --git a/games-strategy/s25rttr/s25rttr-0.9.5.ebuild b/games-strategy/s25rttr/s25rttr-0.9.5.ebuild
index e5f8470614a6..4986896fd623 100644
--- a/games-strategy/s25rttr/s25rttr-0.9.5.ebuild
+++ b/games-strategy/s25rttr/s25rttr-0.9.5.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -41,6 +41,7 @@ BDEPEND="
PATCHES=(
"${FILESDIR}"/${PN}-0.9.0_pre20200723-cmake_lua_version.patch
+ "${FILESDIR}"/${PN}-0.9.5-gcc-13.patch
)
S="${WORKDIR}/${MY_PN}_v${PV}"