summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-05-28 02:41:33 +0100
committerSam James <sam@gentoo.org>2024-05-28 02:41:33 +0100
commit768f7595d58ed27e21fea815a52c5ca20c21410a (patch)
treec81d9802be72e4d30a6b8b801153ff3473d4e140 /games-strategy
parentdev-db/mongodb: fix build w/ boost-1.85 (diff)
downloadgentoo-768f7595d58ed27e21fea815a52c5ca20c21410a.tar.gz
gentoo-768f7595d58ed27e21fea815a52c5ca20c21410a.tar.bz2
gentoo-768f7595d58ed27e21fea815a52c5ca20c21410a.zip
games-strategy/wesnoth: fix build w/ boost-1.85
Closes: https://bugs.gentoo.org/932255 Thanks-to: Marcin Deranek <marcin.deranek@slonko.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/wesnoth/files/wesnoth-1.18.0-boost-1.85.patch12
-rw-r--r--games-strategy/wesnoth/wesnoth-1.18.0.ebuild4
2 files changed, 16 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/files/wesnoth-1.18.0-boost-1.85.patch b/games-strategy/wesnoth/files/wesnoth-1.18.0-boost-1.85.patch
new file mode 100644
index 000000000000..412a4cf8e39d
--- /dev/null
+++ b/games-strategy/wesnoth/files/wesnoth-1.18.0-boost-1.85.patch
@@ -0,0 +1,12 @@
+https://bugs.gentoo.org/932255
+--- a/src/filesystem.cpp
++++ b/src/filesystem.cpp
+@@ -30,6 +30,7 @@
+ #include "serialization/unicode.hpp"
+ #include "utils/general.hpp"
+
++#include <boost/filesystem/directory.hpp>
+ #include <boost/filesystem/fstream.hpp>
+ #include <boost/iostreams/device/file_descriptor.hpp>
+ #include <boost/iostreams/stream.hpp>
+
diff --git a/games-strategy/wesnoth/wesnoth-1.18.0.ebuild b/games-strategy/wesnoth/wesnoth-1.18.0.ebuild
index ba33c9b827a8..1843a5985958 100644
--- a/games-strategy/wesnoth/wesnoth-1.18.0.ebuild
+++ b/games-strategy/wesnoth/wesnoth-1.18.0.ebuild
@@ -43,6 +43,10 @@ BDEPEND="
virtual/pkgconfig
"
+PATCHES=(
+ "${FILESDIR}"/wesnoth-1.18.0-boost-1.85.patch
+)
+
src_prepare() {
cmake_src_prepare