summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-27 04:55:27 +0000
committerSam James <sam@gentoo.org>2023-01-27 05:23:34 +0000
commitad08b108753d55f6075c0a5cf6bd506f7b34ab4c (patch)
tree1053e770bc193acfbbc59e923b74a2f3bab637ee /games-strategy/wesnoth
parentgames-strategy/widelands: fix build w/ gcc 13 (diff)
downloadgentoo-ad08b108753d55f6075c0a5cf6bd506f7b34ab4c.tar.gz
gentoo-ad08b108753d55f6075c0a5cf6bd506f7b34ab4c.tar.bz2
gentoo-ad08b108753d55f6075c0a5cf6bd506f7b34ab4c.zip
games-strategy/wesnoth: add 1.16.8
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/Manifest1
-rw-r--r--games-strategy/wesnoth/files/wesnoth-1.16.8-gcc-13.patch32
-rw-r--r--games-strategy/wesnoth/wesnoth-1.16.8.ebuild106
3 files changed, 139 insertions, 0 deletions
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index a621190038af..9cf9ac6ad743 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,2 +1,3 @@
DIST wesnoth-1.16.6.tar.gz 518250360 BLAKE2B 3fc5f5827beacc309a42d1d135eadefbace57866397eed4e3c5618ba6372ae31fc0350b2180c1323872ae59789ca67cd1b4a973c2257c7fac59508af93e0b758 SHA512 fcf9e50ce065f7c8d2b940eec88de27f18c3adbb9c7ae238bf6821eef233a45c2bdc7a58d5cd2abc4f37bcab6e503aa72d46f623c882c711d9f06b2826340bf5
+DIST wesnoth-1.16.8.tar.gz 518468407 BLAKE2B 9c224757e0d1727acc66a5421266fa6e050bb3727040b457379dd164097c88850f9b2d8b81422ff277548cb8cd51da70f5da63254c2c4ccedc3a45d1789c6037 SHA512 9e41e1c574c9744ba9818298d77df1503d7fc70ee24e4bf9d1f59ef17c2bc123f38f0aa21eddccce88cc28b62f2a2d12133ab25dd111655abf5b620f18457bf7
DIST wesnoth-1.17.11.tar.bz2 421068195 BLAKE2B 43106bb72c6b4a39b4995fb9804733e5420b636db08254e75e7698c58740b84a33c387194bf048247bddf1808f73d0d07b3816f18687390760fb5fab7c2d8449 SHA512 8208ae1c02d5e6a9fe50a2cf533d3b0b207151e5b877c98b003117641ae3c46ad31dbbe4bc46481f4f30382ae65b0183d7636452de5f6d42c8bd48d040f3dd5a
diff --git a/games-strategy/wesnoth/files/wesnoth-1.16.8-gcc-13.patch b/games-strategy/wesnoth/files/wesnoth-1.16.8-gcc-13.patch
new file mode 100644
index 000000000000..f2d79ba6ad06
--- /dev/null
+++ b/games-strategy/wesnoth/files/wesnoth-1.16.8-gcc-13.patch
@@ -0,0 +1,32 @@
+https://github.com/wesnoth/wesnoth/commit/5fa07ea15c1736f74d89786d5ae449ed0f91c8a8
+
+From 5fa07ea15c1736f74d89786d5ae449ed0f91c8a8 Mon Sep 17 00:00:00 2001
+From: Martin Liska <mliska@suse.cz>
+Date: Mon, 23 May 2022 13:44:39 +0200
+Subject: [PATCH] Fix building with GCC 13.
+
+Fixes the following issue:
+base64.hpp:23:49: error: 'uint8_t' was not declared in this scope
+
+and:
+deprecation.hpp:20:22: error: found ':' in nested-name-specifier, expected '::'
+--- a/src/deprecation.hpp
++++ b/src/deprecation.hpp
+@@ -14,6 +14,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string>
+
+ /** See https://wiki.wesnoth.org/CompatibilityStandards for more info. */
+--- a/src/serialization/base64.hpp
++++ b/src/serialization/base64.hpp
+@@ -15,6 +15,7 @@
+
+ #pragma once
+
++#include <cstdint>
+ #include <string_view>
+ #include <vector>
+
diff --git a/games-strategy/wesnoth/wesnoth-1.16.8.ebuild b/games-strategy/wesnoth/wesnoth-1.16.8.ebuild
new file mode 100644
index 000000000000..7a0223c3d681
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-1.16.8.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake flag-o-matic xdg
+
+DESCRIPTION="Battle for Wesnoth - A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org
+ https://github.com/wesnoth/wesnoth"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# uneven minor versions are development versions
+if [[ $(( $(ver_cut 2) % 2 )) == 0 ]] ; then
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+fi
+IUSE="dbus dedicated doc nls server"
+
+RDEPEND="
+ acct-group/wesnoth
+ acct-user/wesnoth
+ dev-libs/boost:=[bzip2,context,icu,nls]
+ >=media-libs/libsdl2-2.0.4:0[joystick,video,X]
+ !dedicated? (
+ dev-libs/glib:2
+ dev-libs/openssl:0=
+ >=media-libs/fontconfig-2.4.1
+ >=media-libs/sdl2-image-2.0.0[jpeg,png]
+ >=media-libs/sdl2-mixer-2.0.0[vorbis]
+ media-libs/libvorbis
+ >=x11-libs/pango-1.22.0
+ >=x11-libs/cairo-1.10.0
+ sys-libs/readline:0=
+ dbus? ( sys-apps/dbus )
+ )"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.16.8-gcc-13.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ if ! use doc ; then
+ sed -i \
+ -e '/manual/d' \
+ doc/CMakeLists.txt || die
+ fi
+
+ # respect LINGUAS (bug #483316)
+ if [[ ${LINGUAS+set} ]] ; then
+ local lang langs=()
+ for lang in $(cat po/LINGUAS) ; do
+ has ${lang} ${LINGUAS} && langs+=( ${lang} )
+ done
+ echo "${langs[@]}" > po/LINGUAS || die
+ fi
+}
+
+src_configure() {
+ filter-flags -ftracer -fomit-frame-pointer
+
+ local mycmakeargs=()
+
+ if use dedicated || use server ; then
+ mycmakeargs+=(
+ -DENABLE_CAMPAIGN_SERVER="ON"
+ -DENABLE_SERVER="ON"
+ -DSERVER_UID="${PN}"
+ -DSERVER_GID="${PN}"
+ -DFIFO_DIR="/run/wesnothd"
+ )
+ else
+ mycmakeargs+=(
+ -DENABLE_CAMPAIGN_SERVER="OFF"
+ -DENABLE_SERVER="OFF"
+ )
+ fi
+ mycmakeargs+=(
+ -Wno-dev
+ -DENABLE_GAME="$(usex !dedicated)"
+ -DENABLE_DESKTOP_ENTRY="$(usex !dedicated)"
+ -DENABLE_NLS="$(usex nls)"
+ -DENABLE_NOTIFICATIONS="$(usex dbus)"
+ -DENABLE_STRICT_COMPILATION="OFF"
+ )
+ cmake_src_configure
+}
+
+src_install() {
+ local DOCS=( README.md changelog.md )
+ cmake_src_install
+ if use dedicated || use server ; then
+ rmdir "${ED}"/run{/wesnothd,} || die
+ newinitd "${FILESDIR}"/wesnothd.rc-r1 wesnothd
+ fi
+}