summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-strategy/coldwar
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-strategy/coldwar')
-rw-r--r--games-strategy/coldwar/Manifest1
-rw-r--r--games-strategy/coldwar/coldwar-1.0.1-r1.ebuild73
-rw-r--r--games-strategy/coldwar/metadata.xml5
3 files changed, 79 insertions, 0 deletions
diff --git a/games-strategy/coldwar/Manifest b/games-strategy/coldwar/Manifest
new file mode 100644
index 000000000000..d3b6bb2c8193
--- /dev/null
+++ b/games-strategy/coldwar/Manifest
@@ -0,0 +1 @@
+DIST coldwar-1.0-1.0.1-x86.run 181769 SHA256 adffc27da6eff739a46193dd095d4b10048a251997b8c876befcae94423a1f32
diff --git a/games-strategy/coldwar/coldwar-1.0.1-r1.ebuild b/games-strategy/coldwar/coldwar-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..8cf98a6aa682
--- /dev/null
+++ b/games-strategy/coldwar/coldwar-1.0.1-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils unpacker cdrom versionator games
+
+PV_MAJOR=$(get_version_component_range 1-2)
+MY_P=${PN}-${PV_MAJOR}-${PV}
+
+DESCRIPTION="Third-person sneaker like Splinter Cell"
+HOMEPAGE="http://linuxgamepublishing.com/info.php?id=coldwar"
+SRC_URI="http://updatefiles.linuxgamepublishing.com/${PN}/${MY_P}-x86.run"
+
+LICENSE="all-rights-reserved"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="linguas_de linguas_fr linguas_ru"
+RESTRICT="mirror bindist strip"
+
+RDEPEND="
+ >=dev-libs/glib-2.34.3[abi_x86_32(-)]
+ >=media-libs/libogg-1.3.0[abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ >=media-libs/openal-1.15.1[abi_x86_32(-)]
+ >=media-libs/smpeg-0.4.4-r10[abi_x86_32(-)]
+ >=virtual/opengl-7.0-r1[abi_x86_32(-)]
+ >=x11-libs/libX11-1.6.2[abi_x86_32(-)]
+ >=x11-libs/libXext-1.3.2[abi_x86_32(-)]"
+
+S=${WORKDIR}
+
+src_unpack() {
+ cdrom_get_cds bin/Linux/x86/${PN}
+ ln -sfn "${CDROM_ROOT}"/data cd
+ unpack "./cd/data.tar.gz"
+ use linguas_de && unpack "./cd/langpack_de.tar.gz"
+ use linguas_fr && unpack "./cd/langpack_fr.tar.gz"
+ use linguas_ru && unpack "./cd/langpack_ru.tar.gz"
+ rm -f cd
+
+ cp -rf "${CDROM_ROOT}"/bin/Linux/x86/* . || die
+ cp -f "${CDROM_ROOT}"/{READ*,icon*} . || die
+
+ mkdir -p patch_dir
+ cd patch_dir
+ unpack_makeself ${MY_P}-x86.run
+ bin/Linux/x86/loki_patch patch.dat "${S}" || die
+ cd "${S}"
+ rm -rf patch_dir
+}
+
+src_install() {
+ dir=${GAMES_PREFIX_OPT}/${PN}
+
+ insinto "${dir}"
+ doins -r *
+
+ exeinto "${dir}"
+ doexe ${PN}
+
+ exeinto "${dir}"/bin
+ doexe bin/{launch*,meng}
+
+ exeinto "${dir}"/lib
+ doexe lib/lib*
+
+ games_make_wrapper ${PN} ./${PN} "${dir}"
+ newicon "${CDROM_ROOT}"/icon.xpm ${PN}.xpm
+ make_desktop_entry ${PN} "Cold War" ${PN}
+
+ prepgamesdirs
+}
diff --git a/games-strategy/coldwar/metadata.xml b/games-strategy/coldwar/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-strategy/coldwar/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>