summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-puzzle/monsterz
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-puzzle/monsterz')
-rw-r--r--games-puzzle/monsterz/Manifest1
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch26
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch32
-rw-r--r--games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch20
-rw-r--r--games-puzzle/monsterz/metadata.xml5
-rw-r--r--games-puzzle/monsterz/monsterz-0.7.1-r3.ebuild45
6 files changed, 129 insertions, 0 deletions
diff --git a/games-puzzle/monsterz/Manifest b/games-puzzle/monsterz/Manifest
new file mode 100644
index 000000000000..4043576a6c65
--- /dev/null
+++ b/games-puzzle/monsterz/Manifest
@@ -0,0 +1 @@
+DIST monsterz-0.7.1.tar.gz 1879537 SHA256 50828b8fa26d107bcc2bd134328f83c905b9f5e124846bdf239daf0eed34973d SHA512 62de125251a74e7ff237c90ad88e10a4953b8841251dfec45cc6b77f416677ef6d68cf4308c3190f65896b5bb1312934abd5e438f0341f08c02884585f0e4787 WHIRLPOOL d2aa08ae267f0ba7c57e62a25d54a670934498048d3cf4420e558564c1e1132e687051bfbc4175bd667d2f21411641ccc28820fbbab5d6f1348152cef4749585
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch
new file mode 100644
index 000000000000..64d6527768f8
--- /dev/null
+++ b/games-puzzle/monsterz/files/monsterz-0.7.1-64bit.patch
@@ -0,0 +1,26 @@
+Index: monsterz-0.7.1/monsterz.py
+===================================================================
+--- monsterz-0.7.1.orig/monsterz.py 2008-05-09 16:35:25.000000000 +0000
++++ monsterz-0.7.1/monsterz.py 2008-05-09 16:35:33.000000000 +0000
+@@ -108,7 +108,9 @@
+ M = int(max(r, g, b))
+ m = int(min(r, g, b))
+ val = (2 * M + r + g + b) / 5
+- p[:] = (val + r) / 2, (val + g) / 2, (val + b) / 2
++ p[0] = (val + r) / 2
++ p[1] = (val + g) / 2
++ p[2] = (val + b) / 2
+ if alpha[y][x] >= 250:
+ alpha[y][x] = 255 - (M - m) * 3 / 4
+ del pixels
+@@ -129,7 +131,9 @@
+ r, g, b = p
+ M = int(max(r, g, b))
+ m = int(min(r, g, b))
+- p[:] = (m + r) / 2, (m + g) / 2, (m + b) / 2
++ p[0] = (m + r) / 2
++ p[1] = (m + g) / 2
++ p[2] = (m + b) / 2
+ if alpha[y][x] >= 250:
+ alpha[y][x] = 255 - M * 2 / 3
+ del pixels
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch
new file mode 100644
index 000000000000..8e55b23a327c
--- /dev/null
+++ b/games-puzzle/monsterz/files/monsterz-0.7.1-blit.patch
@@ -0,0 +1,32 @@
+--- monsterz.py
++++ monsterz.py
+@@ -829,10 +829,10 @@
+ pass
+ else:
+ for x in range(4):
+- for y, p in enumerate(alpha[x]):
+- alpha[x][y] = p * x / 4
+- for y, p in enumerate(alpha[406 - x - 1]):
+- alpha[406 - x - 1][y] = p * x / 4
++ for y in range(len(alpha[x])):
++ alpha[x][y] = alpha[x][y] * x / 4
++ for y in range(len(alpha[406 - x - 1])):
++ alpha[406 - x - 1][y] = alpha[406 - x - 1][y] * x / 4
+ for col in alpha:
+ l = len(col)
+ for y in range(4):
+@@ -1287,10 +1287,10 @@
+ pass
+ else:
+ for x in range(10):
+- for y, p in enumerate(alpha[x]):
+- alpha[x][y] = p * x / 12
+- for y, p in enumerate(alpha[406 - x - 1]):
+- alpha[406 - x - 1][y] = p * x / 12
++ for y in range(len(alpha[x])):
++ alpha[x][y] = alpha[x][y] * x / 12
++ for y in range(len(alpha[406 - x - 1])):
++ alpha[406 - x - 1][y] = alpha[406 - x - 1][y] * x / 12
+ del alpha
+ scroll.unlock()
+ system.blit(scroll, (13, 437))
diff --git a/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch b/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch
new file mode 100644
index 000000000000..652450bf190b
--- /dev/null
+++ b/games-puzzle/monsterz/files/monsterz-0.7.1-gentoo.patch
@@ -0,0 +1,20 @@
+--- monsterz.py.orig 2006-05-12 18:55:51.000000000 -0400
++++ monsterz.py 2006-05-12 18:57:44.000000000 -0400
+@@ -1907,7 +1906,7 @@
+ print ' (C) Mike Kershaw <dragorn@kismetwireless.net>'
+
+ print 'This program is free software; you can redistribute it and/or modify it under'
+- print 'the terms of the Do What The Fuck You Want To Public License, Version 2, as'
++ print 'the terms of the WTFPL, Version 2, as'
+ print 'published by Sam Hocevar. See http://sam.zoy.org/wtfpl/ for more details.'
+ print 'The sound effects are released under their own licences: applause.wav and'
+ print 'pop.wav are covered by the LGPL, the others are covered by the GPL.'
+@@ -1932,7 +1931,7 @@
+ global system, data, settings, fonter, monsterz
+ override = {}
+ scorefile = None
+- sharedir = dirname(argv[0])
++ sharedir = "GENTOO_DATADIR"
+ outfd = None
+ try:
+ long = ['help', 'version', 'music', 'sound', 'fullscreen',
diff --git a/games-puzzle/monsterz/metadata.xml b/games-puzzle/monsterz/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-puzzle/monsterz/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>
diff --git a/games-puzzle/monsterz/monsterz-0.7.1-r3.ebuild b/games-puzzle/monsterz/monsterz-0.7.1-r3.ebuild
new file mode 100644
index 000000000000..ba1df0c5634f
--- /dev/null
+++ b/games-puzzle/monsterz/monsterz-0.7.1-r3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+inherit eutils python-r1 games
+
+DESCRIPTION="a little puzzle game, similar to the famous Bejeweled or Zookeeper"
+HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
+SRC_URI="http://sam.zoy.org/projects/monsterz/${P}.tar.gz"
+
+LICENSE="GPL-1+ LGPL-2+ WTFPL-2"
+SLOT="0"
+KEYWORDS="amd64 hppa ppc x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-python/pygame[${PYTHON_USEDEP}]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-64bit.patch \
+ "${FILESDIR}"/${P}-blit.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ monsterz.py || die "sed failed"
+ rm Makefile || die
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r graphics sound
+ newgamesbin monsterz.py ${PN}
+ newicon graphics/icon.png ${PN}.png
+ make_desktop_entry ${PN} Monsterz
+ dodoc README AUTHORS TODO
+ python_replicate_script "${ED%/}${GAMES_BINDIR}"/monsterz
+ prepgamesdirs
+}