summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-fps/serious-sam-tse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-fps/serious-sam-tse')
-rw-r--r--games-fps/serious-sam-tse/Manifest1
-rw-r--r--games-fps/serious-sam-tse/metadata.xml8
-rw-r--r--games-fps/serious-sam-tse/serious-sam-tse-1_beta1.ebuild143
3 files changed, 152 insertions, 0 deletions
diff --git a/games-fps/serious-sam-tse/Manifest b/games-fps/serious-sam-tse/Manifest
new file mode 100644
index 000000000000..943f773326fd
--- /dev/null
+++ b/games-fps/serious-sam-tse/Manifest
@@ -0,0 +1 @@
+DIST ssamtse-beta1.sh.bin 7952607 SHA256 4be124430c5d013842b97287623e0aed83d2003eeb619abbcb286bc95e036304 SHA512 43f07fbaef0bf8f90644a748931220331ed5f9179412e5a37daf0472aa98c5bb2455148c54254eae1af0b38ba8a3fde9c310cd8d488ea6b2806fa0f6fb1e1644 WHIRLPOOL b05dcf3e15a488bbf5fe7a076c1ca49ced5f8ba6887750c2f1c6306ce74716d71ce3a7fa83c9e33f4c97b87778a2b631afb8b11f597f77907a639bc428c314ee
diff --git a/games-fps/serious-sam-tse/metadata.xml b/games-fps/serious-sam-tse/metadata.xml
new file mode 100644
index 000000000000..b6b8956cde34
--- /dev/null
+++ b/games-fps/serious-sam-tse/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/games-fps/serious-sam-tse/serious-sam-tse-1_beta1.ebuild b/games-fps/serious-sam-tse/serious-sam-tse-1_beta1.ebuild
new file mode 100644
index 000000000000..9e9fe90bca67
--- /dev/null
+++ b/games-fps/serious-sam-tse/serious-sam-tse-1_beta1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit cdrom eutils versionator games unpacker
+
+# MY_PV will be e.g. "beta1"
+MY_PN="ssamtse"
+MY_PV=$(get_version_component_range 2-2)
+
+DESCRIPTION="Serious Sam: The Second Encounter"
+HOMEPAGE="http://www.croteam.com/
+ http://www.seriouszone.com/"
+SRC_URI="http://icculus.org/betas/ssam/${MY_PN}-${MY_PV}.sh.bin"
+
+LICENSE="LOKI-EULA"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+RESTRICT="strip"
+IUSE="alsa"
+
+DEPEND=">=app-arch/unshield-0.6"
+RDEPEND="
+ >=media-libs/libogg-1.3.1[abi_x86_32(-)]
+ >=media-libs/libsdl-1.2.15-r5[X,joystick,opengl,video,abi_x86_32(-)]
+ virtual/opengl[abi_x86_32(-)]
+ alsa? (
+ >=media-libs/libsdl-1.2.15-r5[alsa,sound,abi_x86_32(-)]
+ >=media-libs/libvorbis-1.3.3-r1[abi_x86_32(-)]
+ )
+"
+
+S=${WORKDIR}
+
+QA_TEXTRELS="
+opt/ssamtse/Bin/libEntitiesMP.so
+opt/ssamtse/Bin/libGameMP.so
+opt/ssamtse/Bin/libamp11lib.so
+opt/ssamtse/Bin/libShaders.so
+"
+
+QA_FLAGS_IGNORED="
+opt/ssamtse/Bin/libEntitiesMP.so
+opt/ssamtse/Bin/libGameMP.so
+opt/ssamtse/Bin/libamp11lib.so
+opt/ssamtse/Bin/libShaders.so
+opt/ssamtse/Bin/ssam_lnxded
+opt/ssamtse/Bin/ssam_lnxded.dynamic
+opt/ssamtse/Bin/ssam_lnx.dynamic
+opt/ssamtse/Bin/ssam_lnx
+"
+
+pkg_setup() {
+ games_pkg_setup
+
+ cdrom_get_cds "Install/SE1_00.gro"
+}
+
+src_unpack() {
+ mkdir Levels Mods
+
+ unpack_makeself "${MY_PN}-${MY_PV}.sh.bin"
+ unpack ./setupstuff.tar.gz
+ unpack ./bins.tar.bz2
+}
+
+src_prepare() {
+ # Switch to dynamic executable - runs at sane speeds on modern hardware
+ sed -i -e 's;exec "./ssam_lnx";exec "./ssam_lnx.dynamic";' bin/${MY_PN} \
+ || die "dynamic binary update failed"
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/${MY_PN}
+
+ # Remove bundled libs
+ rm -f Bin/{libogg.so,libvorbis.so,libvorbisfile.so}
+
+ einfo "Copying from ${CDROM_ROOT}"
+ insinto "${dir}"
+ doins -r "${CDROM_ROOT}"/Install/* || die "doins CD failed"
+
+ # Correct paths of copied resource files
+ mv "${D}/${dir}"/Locales/eng/Controls/* "${D}/${dir}"/Controls/
+ mv "${D}/${dir}"/Locales/eng/Data/Var/* "${D}/${dir}"/Data/Var/
+ mv "${D}/${dir}"/Locales/eng/Demos/* "${D}/${dir}"/Demos/
+ mv "${D}/${dir}"/Locales/eng/Help/* "${D}/${dir}"/Help/
+ mv "${D}/${dir}"/Locales/eng/Mods/Warped/Scripts/Addons/WarpedTweak.des "${D}/${dir}"/Mods/Warped/Scripts/Addons/
+ mv "${D}/${dir}"/Locales/eng/Mods/Warped/Readme.html "${D}/${dir}"/Mods/Warped/
+ mv "${D}/${dir}"/Locales/eng/Mods/*.des "${D}/${dir}"/Mods/
+ mv "${D}/${dir}"/Locales/eng/Scripts/Addons/* "${D}/${dir}"/Scripts/Addons/
+ mv "${D}/${dir}"/Locales/eng/Scripts/CustomOptions/* "${D}/${dir}"/Scripts/CustomOptions/
+ mv "${D}/${dir}"/Locales/eng/Scripts/NetSettings/* "${D}/${dir}"/Scripts/NetSettings/
+ rm -rf "${D}/${dir}"/Locales
+
+ # The data CABs contain optional multiplayer maps in the "Levels" directory
+ einfo "Extracting additional levels"
+ unshield x "${D}/${dir}"/data1.cab >/dev/null || die "unshield data1.cab failed"
+ rm "${D}/${dir}"/data?.cab
+
+ # Correct paths of extracted levels
+ mv Levels/Levels/LevelsMP/* Levels/LevelsMP/
+ rm -rf Levels/Levels
+ mv Levels/LevelsMP/Technology/* Levels/
+ rmdir Levels/LevelsMP/Technology
+ mv Levels/Mods/Warped/ Mods/
+ rmdir Levels/Mods/
+
+ doins -r Bin Data Levels Mods *.txt README* \
+ || die "doins main failed"
+
+ # Install bins last to ensure they are marked executable
+ exeinto "${dir}"
+ doexe bin/${MY_PN}
+ exeinto "${dir}"/Bin
+ doexe Bin/{ssam_lnx*,*.so}
+
+ # Remove useless Windows files
+ rm -rf "${D}/${dir}/Bin"/{*.exe,*.dll,*.DLL,GameSpy}
+ rm -f "${D}/${dir}"/{*.exe,*.ex_,*.bmp,*.inx,*.hdr,*.bin}
+
+ dodoc README.linux
+
+ newicon ssam.xpm ${MY_PN}.xpm
+ games_make_wrapper ${MY_PN} ./${MY_PN} "${dir}" "${dir}"
+ make_desktop_entry ${MY_PN} "Serious Sam - Second Encounter" ${MY_PN}
+
+ # Ensure that file datestamps from the CD are sane
+ find "${D}/${dir}" -exec touch '{}' \;
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog "The warning regarding 'XiG-SUNDRY-NONSTANDARD missing' is harmless."
+ elog "Important information about the Linux port is at:"
+ elog " http://files.seriouszone.com/download.php?fileid=616"
+ echo
+}