summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2024-12-12 17:57:24 -0800
committerSam James <sam@gentoo.org>2024-12-13 09:34:21 +0000
commit39019fd61dcfea7b8aceeef040b590b7dffc064c (patch)
tree74f56577ae61ff56aef53396e056991b53e4d7c0 /games-emulation
parentgames-emulation/mgba-jg: drop 0.10.2 (diff)
downloadgentoo-39019fd61dcfea7b8aceeef040b590b7dffc064c.tar.gz
gentoo-39019fd61dcfea7b8aceeef040b590b7dffc064c.tar.bz2
gentoo-39019fd61dcfea7b8aceeef040b590b7dffc064c.zip
games-emulation/sameboy-jg: add 1.0.0
Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/sameboy-jg/Manifest1
-rw-r--r--games-emulation/sameboy-jg/sameboy-jg-1.0.0.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/games-emulation/sameboy-jg/Manifest b/games-emulation/sameboy-jg/Manifest
index eae0f137b0eb..0af711c07f44 100644
--- a/games-emulation/sameboy-jg/Manifest
+++ b/games-emulation/sameboy-jg/Manifest
@@ -1,2 +1,3 @@
DIST sameboy-0.16.5.tar.bz2 4143349 BLAKE2B e56df9bd38a550a78a0f30ab0259b3b11e7af4bc14f0c8a7a51de34af49eac40f09c57b54ce5640ee697eaf8a3b586d0390bebc6f25ddf44ced4a65c7b8f3476 SHA512 e0f463f77236196e00834aa0e814e4cfe78947da73310bb37c23e5a0a7644015467c646825971c0ef6b10c7ba8c058589729271eeacf089ff6d5cad188f2c246
DIST sameboy-0.16.6.tar.bz2 4153538 BLAKE2B e670ba2ee3240b235d776c5b9a55b5b16dc692c63f3c6d8d03eb56c832c655d6782221afb1028b15a0af6b30ac398c7828e8759b8766ce19cd0064815c8890b3 SHA512 355674a3c4b612cf6b03c094cd3067224779d50789599e0fa7dfc3843201d140befc2058c1bd461e8cab11c5ebbbdb8fceaf4b5feee86a59bd49a50b808dca31
+DIST sameboy-1.0.0.tar.bz2 7166814 BLAKE2B b004fe08af738e4e00e7144073f477c62603b6921730d0c2f59064781e3408f0e61be8a1eb40ce68c08ae286c47f4d4875666bc0f65c2232d0662bad1e83cecd SHA512 4da43490b502e59013153f4eabd8c943f81a4a27fd20ffb478770f19897c31d28e6d264e7ec3c3a55029214b8d95f527b564f65a010634d2203b6faa231e1626
diff --git a/games-emulation/sameboy-jg/sameboy-jg-1.0.0.ebuild b/games-emulation/sameboy-jg/sameboy-jg-1.0.0.ebuild
new file mode 100644
index 000000000000..c41503e9640a
--- /dev/null
+++ b/games-emulation/sameboy-jg/sameboy-jg-1.0.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+MY_PN=${PN%-*}
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Jolly Good Port of SameBoy"
+HOMEPAGE="https://gitlab.com/jgemu/sameboy"
+if [[ "${PV}" == *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/jgemu/${MY_PN}.git"
+else
+ SRC_URI="https://gitlab.com/jgemu/${MY_PN}/-/archive/${PV}/${MY_P}.tar.bz2"
+ S="${WORKDIR}/${MY_P}"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="1"
+
+DEPEND="
+ media-libs/jg:1=
+"
+RDEPEND="
+ ${DEPEND}
+ games-emulation/jgrf
+"
+BDEPEND="
+ >=dev-util/rgbds-0.6.0
+ virtual/pkgconfig
+"
+
+src_compile() {
+ emake -C jollygood \
+ CC="$(tc-getCC)" \
+ CC_FOR_BUILD="$(tc-getBUILD_CC)" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ emake -C jollygood install \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}"/usr \
+ DOCDIR="${EPREFIX}"/usr/share/doc/${PF} \
+ LIBDIR="${EPREFIX}/usr/$(get_libdir)"
+}