summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-25 19:15:23 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-25 22:38:56 -0400
commita21051f8ceacb84df069bda7f794cc3b83f29a43 (patch)
tree862394cf9da08f332a00e0c8aeb355dd6b5ce50e /games-emulation/pcsx2/pcsx2-9999.ebuild
parentprofiles/base: add bug ref to LLVM_TARGETS force (diff)
downloadgentoo-a21051f8ceacb84df069bda7f794cc3b83f29a43.tar.gz
gentoo-a21051f8ceacb84df069bda7f794cc3b83f29a43.tar.bz2
gentoo-a21051f8ceacb84df069bda7f794cc3b83f29a43.zip
games-emulation/pcsx2: filter-lto with USE=vulkan
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-emulation/pcsx2/pcsx2-9999.ebuild')
-rw-r--r--games-emulation/pcsx2/pcsx2-9999.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/games-emulation/pcsx2/pcsx2-9999.ebuild b/games-emulation/pcsx2/pcsx2-9999.ebuild
index be8593008a14..1c93197e9991 100644
--- a/games-emulation/pcsx2/pcsx2-9999.ebuild
+++ b/games-emulation/pcsx2/pcsx2-9999.ebuild
@@ -156,8 +156,14 @@ src_prepare() {
}
src_configure() {
- # for bundled glslang (bug #858374)
- use vulkan && append-flags -fno-strict-aliasing
+ if use vulkan; then
+ # for bundled glslang (bug #858374)
+ append-flags -fno-strict-aliasing
+
+ # odr violations in pcsx2's vulkan code, disabling as a safety for now
+ # (vulkan support tend to receive major changes, is more on WIP side)
+ filter-lto
+ fi
local mycmakeargs=(
$(cmake_use_find_package backtrace Libbacktrace)