summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-04-23 23:04:41 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-04-23 23:24:35 -0400
commitcaa10849e8f9e4f26457f427dd7fc1f486862885 (patch)
tree2d5a34856bf118be03d9e2d596419dea182b637c /games-board
parentapp-emulation/wine-proton: add live ebuild for experimental_8.0 (diff)
downloadgentoo-caa10849e8f9e4f26457f427dd7fc1f486862885.tar.gz
gentoo-caa10849e8f9e4f26457f427dd7fc1f486862885.tar.bz2
gentoo-caa10849e8f9e4f26457f427dd7fc1f486862885.zip
games-board/pysolfc: add 2.20.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'games-board')
-rw-r--r--games-board/pysolfc/Manifest3
-rw-r--r--games-board/pysolfc/pysolfc-2.20.1.ebuild68
2 files changed, 71 insertions, 0 deletions
diff --git a/games-board/pysolfc/Manifest b/games-board/pysolfc/Manifest
index 87e3ae7782ac..7a2e27cf64b5 100644
--- a/games-board/pysolfc/Manifest
+++ b/games-board/pysolfc/Manifest
@@ -1,3 +1,6 @@
DIST PySolFC-2.18.0.tar.xz 9134632 BLAKE2B 68d777afa058ce73d6888b40e5fef060257f7449e3c1dbf2ec02c4ab35c5917000be3d2ec815e02b2353b793d6a7e010721f498098786f7f172181cda01039a0 SHA512 6e8b46cf3271f8695da6b6fd3090a32839beeed237d35a77f47ad95dfe1690ea471f35e722af65dba9d908f74ace109d1c06d7dd37889962ca0d610c62215397
+DIST PySolFC-2.20.1.tar.xz 9175764 BLAKE2B 3eba9044cc37f96d85e51f5bb5faa5605e8a5de887fe0c73a9bea7dde1a49e63263d7a9b66113e975a26d71de2611e0b5dc176713734316b8c0410fb8145a539 SHA512 f801dacfb3f538496a7dd2fd1777897681521928fe7ea8aec7ea514c1422e8d4ad6c0943ba534914d95544d8eb5e4868f860e6864a8e105f6cc0d16a3d678346
DIST PySolFC-Cardsets--Minimal-2.1.0.tar.xz 28484652 BLAKE2B a7537557ce978d296d1a11253a5bfa80a19fc67b495948e35d43d64bcc1283812e753ccf9ee1828461b723e6a21070b3003435f046a590507a7fa6f95bae09c2 SHA512 cc83a26470c2fb13e70741bd8caccb8bd3b0491672eae0caf7437cf38d57e324d225186dde3be49c091d6960dbaefaa23814bcdd7326b07f0f1e32dda15b251c
+DIST PySolFC-Cardsets--Minimal-2.2.0.tar.xz 23145612 BLAKE2B f98e51c9609bda850cf39ffcd255c7d5c729bc01c35475b1f99a4a4d4ec6a436d44d7e5ecdcce3726616aeaff19617dba6735861f6c5677d2c197882d631a475 SHA512 d5eb0753d14e0758f410d843f553ca6c03acc6d4283b447016e959c889c9dada29fa3facead44354782010b52ec51e0d095858d3b78243ad5280068ec6cd3e31
DIST PySolFC-Cardsets-2.1.tar.bz2 61214563 BLAKE2B 06bf69f22fdcdfbd652bbe75f05722a452609da435a688a04227d235f7a4bd618cb3832e9143d224571eb20c1948014a456d697923623354c81ec12eff365bd9 SHA512 64909dec3d7f0a683e3c0d536f2c3435d0b021b390e411bcd6c9774562483413864105837e57c3210168330f17eda779055a1ec3b52d91aa05f405b990bd6fca
+DIST PySolFC-Cardsets-2.2.tar.bz2 65408375 BLAKE2B 7c0f4bb245d628222e0c8e3b56739c52d77aa6f62088b547c077368591ac3632300a9a35145ddbc33bfdf3accd91d261d103be6777db8c3cbb5576683358b0de SHA512 5562e572909eba96399c79487127b3d98c8f0e1ad145469e48fd6c3803334ba11c41e403d7dcaab5cd01324219426f7afdba9459d97b03071dd67b6dd73ce304
diff --git a/games-board/pysolfc/pysolfc-2.20.1.ebuild b/games-board/pysolfc/pysolfc-2.20.1.ebuild
new file mode 100644
index 000000000000..2ea1b0efaf6e
--- /dev/null
+++ b/games-board/pysolfc/pysolfc-2.20.1.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_REQ_USE="tk"
+inherit distutils-r1 xdg
+
+MY_PN="PySolFC"
+MY_P="${MY_PN}-${PV}"
+PS_CARD_P="${MY_PN}-Cardsets-2.2"
+PS_CARD_MIN_P="${MY_PN}-Cardsets--Minimal-2.2.0"
+
+DESCRIPTION="Exciting collection of more than 1000 solitaire card games"
+HOMEPAGE="https://pysolfc.sourceforge.io/"
+SRC_URI="mirror://sourceforge/pysolfc/${MY_P}.tar.xz
+ extra-cardsets? ( mirror://sourceforge/pysolfc/${PS_CARD_P}.tar.bz2 )
+ !extra-cardsets? ( mirror://sourceforge/pysolfc/${PS_CARD_MIN_P}.tar.xz )"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-3+ GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="extra-cardsets minimal +sound"
+
+RDEPEND="
+ $(python_gen_cond_dep '
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ dev-python/pysol_cards[${PYTHON_USEDEP}]
+ dev-python/random2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ sound? ( dev-python/pygame[${PYTHON_USEDEP}] )
+ !minimal? ( dev-python/pillow[jpeg,tk,${PYTHON_USEDEP}] )')
+ !minimal? ( dev-tcltk/tktable )"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # make pip check happier, pycotap is not needed
+ sed -i "/'pycotap'/d" setup.py || die
+
+ if use extra-cardsets; then
+ find ../${PS_CARD_P} -type d -name .thumbnails -exec rm -r {} + || die
+ fi
+}
+
+python_install_all() {
+ local DOCS=( AUTHORS.md NEWS.asciidoc README.md )
+ distutils-r1_python_install_all
+
+ doman docs/pysol{,fc}.6
+
+ insinto /usr/share/${MY_PN}
+ doins -r ../$(usex extra-cardsets ${PS_CARD_P} ${PS_CARD_MIN_P})/.
+
+ # html files are used at runtime, keep at default location
+ dosym -r /usr/share/{${MY_PN},doc/${PF}}/html
+
+ # russian translation is not currently displaying right
+ # https://forums.gentoo.org/viewtopic-t-1142910.html
+ rm "${ED}"/usr/share/locale/ru/LC_MESSAGES/pysol.mo || die
+}