summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-board/scid/files/scid-4.6.0-gentoo.patch
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-board/scid/files/scid-4.6.0-gentoo.patch')
-rw-r--r--games-board/scid/files/scid-4.6.0-gentoo.patch124
1 files changed, 124 insertions, 0 deletions
diff --git a/games-board/scid/files/scid-4.6.0-gentoo.patch b/games-board/scid/files/scid-4.6.0-gentoo.patch
new file mode 100644
index 000000000000..a6f525ad8c3a
--- /dev/null
+++ b/games-board/scid/files/scid-4.6.0-gentoo.patch
@@ -0,0 +1,124 @@
+--- scid-4.6.0.orig/engines/togaII1.2.1a/src/Makefile
++++ scid-4.6.0/engines/togaII1.2.1a/src/Makefile
+@@ -18,23 +18,16 @@
+
+ # general
+
+-CXX = g++
+-CXXFLAGS = -pipe -Wall
+-LDFLAGS = -lm
+
+ # C++
+
+-CXXFLAGS += -fno-exceptions -fno-rtti
+
+ # optimisation
+
+-CXXFLAGS += -O3 -fstrict-aliasing
+-CXXFLAGS += -fomit-frame-pointer
+ # CXXFLAGS += -march=athlon-xp # SELECT ME
+
+ # strip
+
+-LDFLAGS += -s
+
+ # dependencies
+
+--- scid-4.6.0.orig/Makefile.conf
++++ scid-4.6.0/Makefile.conf
+@@ -157,32 +157,31 @@
+ install: $(INSTALL)
+
+ install_scid: all_scid
+- install -m 755 -d "$(SHAREDIR)"
+- install -m 755 -d "$(BINDIR)"
+- install -m 755 $(SCRIPTS) $(EXECS) "$(BINDIR)"
+- rm -f "$(BINDIR)/scid"
+- @echo "#!/bin/sh" > "$(BINDIR)/scid"
+- @echo 'exec "$(BINDIR)/tkscid" "$(SHAREDIR)/tcl/start.tcl" "$$@"' >> "$(BINDIR)/scid"
+- chmod 755 "$(BINDIR)/scid"
+- chmod +x "$(BINDIR)/scid"
+- install -m 644 -p scid.eco "$(SHAREDIR)"
+- install -m 755 -d "$(SHAREDIR)/books"
+- install -m 666 ./books/*.* "$(SHAREDIR)/books/"
+- install -m 755 -d "$(SHAREDIR)/bases"
+- if test -d ./bases; then install -m 666 ./bases/*.* "$(SHAREDIR)/bases/" ; fi
+- install -m 755 -d "$(SHAREDIR)/html"
+- cp -r ./html/* "$(SHAREDIR)/html/"
+- install -m 755 -d "$(SHAREDIR)/img/"
+- cp -r ./img/* "$(SHAREDIR)/img/"
+- install -m 755 -d "$(SHAREDIR)/tcl/"
+- cp -r ./tcl/* "$(SHAREDIR)/tcl/"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)"
++ install -m 755 -d "$(DESTDIR)$(BINDIR)"
++ install -m 755 $(SCRIPTS) $(EXECS) "$(DESTDIR)$(BINDIR)"
++ @echo "#!/bin/sh" > "$(DESTDIR)$(BINDIR)/scid"
++ @echo 'exec "$(BINDIR)/tkscid" "$(SHAREDIR)/tcl/start.tcl" "$$@"' >> "$(DESTDIR)$(BINDIR)/scid"
++ chmod 755 "$(DESTDIR)$(BINDIR)/scid"
++ chmod +x "$(DESTDIR)$(BINDIR)/scid"
++ install -m 644 -p scid.eco "$(DESTDIR)$(SHAREDIR)"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/books"
++ install -m 666 ./books/*.* "$(DESTDIR)$(SHAREDIR)/books/"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/bases"
++ if test -d ./bases; then install -m 666 ./bases/*.* "$(DESTDIR)$(SHAREDIR)/bases/" ; fi
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/html"
++ cp -r ./html/* "$(DESTDIR)$(SHAREDIR)/html/"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/img/"
++ cp -r ./img/* "$(DESTDIR)$(SHAREDIR)/img/"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/tcl/"
++ cp -r ./tcl/* "$(DESTDIR)$(SHAREDIR)/tcl/"
+
+ install_engines: all_engines
+- install -m 755 -d "$(SHAREDIR)/engines"
+- install -m 755 -d "$(SHAREDIR)/engines/phalanx-scid"
+- install ./engines/phalanx-scid/phalanx-scid "$(SHAREDIR)/engines/phalanx-scid"
+- install -m 755 -d "$(SHAREDIR)/engines/togaII1.2.1a"
+- install ./engines/togaII1.2.1a/src/togaII "$(SHAREDIR)/engines/togaII1.2.1a/"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/engines"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/engines/phalanx-scid"
++ install ./engines/phalanx-scid/phalanx-scid "$(DESTDIR)$(SHAREDIR)/engines/phalanx-scid"
++ install -m 755 -d "$(DESTDIR)$(SHAREDIR)/engines/togaII1.2.1a"
++ install ./engines/togaII1.2.1a/src/togaII "$(DESTDIR)$(SHAREDIR)/engines/togaII1.2.1a/"
+
+ install_mac: all
+ install -m 755 -d dist/Scid.app/Contents/MacOS
+--- scid-4.6.0.orig/tcl/start.tcl
++++ scid-4.6.0/tcl/start.tcl
+@@ -93,7 +93,7 @@
+
+ # scidShareDir, scidImgDir, scidTclDir, scidBooksDir, scidBasesDir, ecoFile:
+ # Location of Scid resources
+- set scidShareDir [file normalize [file join $scidExeDir "../share/scid"]]
++ set scidShareDir "@GENTOO_DATADIR@"
+ if {! [file isdirectory $::scidShareDir]} {
+ set scidShareDir $::scidExeDir
+ }
+@@ -785,7 +785,7 @@
+ }
+
+ ### Audio move announcement options:
+-set ::utils::sound::soundFolder [file nativename [file join $::scidExeDir sounds]]
++set ::utils::sound::soundFolder "@GENTOO_DATADIR@/sounds"
+ set ::utils::sound::announceNew 0
+ set ::utils::sound::announceForward 0
+ set ::utils::sound::announceBack 0
+@@ -794,7 +794,7 @@
+ if {$windowsOS} {
+ set spellCheckFile [file join $scidDataDir "spelling.ssp"]
+ } else {
+- set spellCheckFile "/usr/local/share/scid/spelling.ssp"
++ set spellCheckFile "@GENTOO_DATADIR@//spelling.ssp"
+ }
+
+ # book configuration
+--- scid-4.6.0.orig/tcl/utils/sound.tcl
++++ scid-4.6.0/tcl/utils/sound.tcl
+@@ -43,7 +43,7 @@
+ variable soundFolder
+
+ set hasSound 1
+- if {[catch {package require snack 2.0}]} {
++ if {[catch {package require snack}]} {
+ if {$::windowsOS} {
+ catch {
+ set ::utils::sound::pipe [open "| scidsnd.exe" "r+"]