summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2017-02-11 20:21:51 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-11 20:44:01 +0100
commit7afe5879832db40543cd5625c122674526c0e84d (patch)
tree57b73e8832d1f051b53544ac834eabc07b9f8687 /games-board/cgoban/cgoban-1.9.14-r2.ebuild
parentdev-ruby/mini_magick: Depend on virtual/imagemagick-tools (diff)
downloadgentoo-7afe5879832db40543cd5625c122674526c0e84d.tar.gz
gentoo-7afe5879832db40543cd5625c122674526c0e84d.tar.bz2
gentoo-7afe5879832db40543cd5625c122674526c0e84d.zip
games-board/cgoban: Depend on virtual/imagemagick-tools
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/3907
Diffstat (limited to 'games-board/cgoban/cgoban-1.9.14-r2.ebuild')
-rw-r--r--games-board/cgoban/cgoban-1.9.14-r2.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-board/cgoban/cgoban-1.9.14-r2.ebuild b/games-board/cgoban/cgoban-1.9.14-r2.ebuild
new file mode 100644
index 000000000000..92cf71adde65
--- /dev/null
+++ b/games-board/cgoban/cgoban-1.9.14-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils autotools
+
+DESCRIPTION="A Go-frontend"
+HOMEPAGE="http://cgoban1.sourceforge.net/"
+SRC_URI="mirror://sourceforge/cgoban1/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/imagemagick-tools
+ x11-libs/libX11
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-cflags.patch
+)
+
+src_prepare() {
+ # ${P}-cflags.patch patches configure.ac, not .in:
+ mv configure.{in,ac} || die
+
+ default
+
+ cp cgoban_icon.png ${PN}.png || die
+ eautoreconf
+}
+
+src_install() {
+ default
+ doicon ${PN}.png
+ make_desktop_entry cgoban Cgoban
+}