summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2016-07-16 01:17:12 -0500
committerAustin English <wizardedit@gentoo.org>2016-07-16 01:17:12 -0500
commit99c565c25515203107addeb254ecc98536fdf028 (patch)
tree6fc9025caf7d9506951c99679ca1f8448df18fb6 /games-action
parentgames-action/beathazardultra: remove deprecated games eclass (diff)
downloadgentoo-99c565c25515203107addeb254ecc98536fdf028.tar.gz
gentoo-99c565c25515203107addeb254ecc98536fdf028.tar.bz2
gentoo-99c565c25515203107addeb254ecc98536fdf028.zip
games-action/bomberclone: remove deprecated games eclass
Also update to EAPI 6 Package-Manager: portage-2.3.0
Diffstat (limited to 'games-action')
-rw-r--r--games-action/bomberclone/bomberclone-0.11.8-r1.ebuild60
-rw-r--r--games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch4
-rw-r--r--games-action/bomberclone/files/bomberclone-0.11.8-underlink.patch4
3 files changed, 64 insertions, 4 deletions
diff --git a/games-action/bomberclone/bomberclone-0.11.8-r1.ebuild b/games-action/bomberclone/bomberclone-0.11.8-r1.ebuild
new file mode 100644
index 000000000000..62441c105d47
--- /dev/null
+++ b/games-action/bomberclone/bomberclone-0.11.8-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils autotools
+
+DESCRIPTION="BomberMan clone with network game support"
+HOMEPAGE="http://www.bomberclone.de/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~mips ~ppc ~ppc64 ~x86"
+IUSE="X"
+
+DEPEND=">=media-libs/libsdl-1.1.0[video]
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mod]
+ X? ( x11-libs/libXt )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gcc52.patch
+ "${FILESDIR}"/${P}-underlink.patch
+)
+
+src_prepare() {
+ default
+
+ ecvs_clean
+ mv configure.{in,ac} || die
+ sed -i -e 's/configure.in/configure.ac/' configure.ac || die
+ sed -i \
+ -e "s:/share/games/:share/:" \
+ configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with X x) \
+ --datadir=/usr/share
+ sed -i \
+ -e "/PACKAGE_DATA_DIR/ s:/usr/games/share/games/:/usr/share:" \
+ config.h || die
+}
+
+src_install() {
+ default
+
+ dobin src/${PN}
+
+ insinto /usr/share/${PN}
+ doins -r data/{gfx,maps,player,tileset,music}
+ find "${D}" -name "Makefile*" -exec rm -f '{}' +
+
+ doicon data/pixmaps/bomberclone.png
+ make_desktop_entry bomberclone Bomberclone
+}
diff --git a/games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch b/games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch
index 51fdaee52c5f..fd77e1b7b1d6 100644
--- a/games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch
+++ b/games-action/bomberclone/files/bomberclone-0.11.8-gcc52.patch
@@ -1,5 +1,5 @@
---- src/single.c.old 2015-09-17 09:21:57.826930680 +0200
-+++ src/single.c 2015-09-17 09:22:04.315824372 +0200
+--- a/src/single.c 2015-09-17 09:21:57.826930680 +0200
++++ b/src/single.c 2015-09-17 09:22:04.315824372 +0200
@@ -476,7 +476,7 @@
};
diff --git a/games-action/bomberclone/files/bomberclone-0.11.8-underlink.patch b/games-action/bomberclone/files/bomberclone-0.11.8-underlink.patch
index d534df6192b6..18c063b56db9 100644
--- a/games-action/bomberclone/files/bomberclone-0.11.8-underlink.patch
+++ b/games-action/bomberclone/files/bomberclone-0.11.8-underlink.patch
@@ -1,5 +1,5 @@
---- configure.in.old 2011-06-18 18:23:48.633605738 +0200
-+++ configure.in 2011-06-18 18:26:26.910628408 +0200
+--- a/configure.in 2011-06-18 18:23:48.633605738 +0200
++++ b/configure.in 2011-06-18 18:26:26.910628408 +0200
@@ -33,7 +33,7 @@
)