summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2023-06-17 15:55:06 +0100
committerJames Le Cuirot <chewi@gentoo.org>2023-06-17 15:56:47 +0100
commit73f2ad08a20038a2c3b3635feb55015df12ee337 (patch)
tree58d5f0db0b27c0be9c027f3476574a60314b0a48 /games-action
parentgames-action/psychonauts-hb: New package (diff)
downloadgentoo-73f2ad08a20038a2c3b3635feb55015df12ee337.tar.gz
gentoo-73f2ad08a20038a2c3b3635feb55015df12ee337.tar.bz2
gentoo-73f2ad08a20038a2c3b3635feb55015df12ee337.zip
games-action/psychonauts-gog: Some last minute adjustments
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'games-action')
-rw-r--r--games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild24
1 files changed, 14 insertions, 10 deletions
diff --git a/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild b/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild
index 2c30c1827211..bfe45f2b11b3 100644
--- a/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild
+++ b/games-action/psychonauts-gog/psychonauts-gog-2.0.0.4.ebuild
@@ -3,7 +3,8 @@
EAPI=8
-inherit desktop unpacker wrapper xdg
+CHECKREQS_DISK_BUILD="5238M"
+inherit check-reqs desktop unpacker wrapper xdg
MY_PN="Psychonauts"
@@ -14,21 +15,24 @@ SRC_URI="gog_${MY_PN,,}_${PV}.sh"
LICENSE="GOG-EULA"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RESTRICT="bindist fetch strip"
+RESTRICT="bindist fetch splitdebug"
-BDEPEND="app-arch/unzip"
+BDEPEND="
+ app-arch/unzip
+"
RDEPEND="
media-libs/libsdl[abi_x86_32,opengl,video]
media-libs/openal[abi_x86_32]
- >=sys-devel/gcc-3.4
+ >=sys-devel/gcc-3.4[cxx]
sys-libs/glibc
- !games-action/${MY_PN,,}
+ !${CATEGORY}/${MY_PN,,}
+ !${CATEGORY}/${MY_PN,,}-hb
"
S="${WORKDIR}/data/noarch"
-dir="/opt/${MY_PN,,}"
-QA_PREBUILT="${dir#/}/*"
+DIR="/opt/${MY_PN,,}"
+QA_PREBUILT="${DIR#/}/*"
pkg_nofetch() {
elog "Please buy and download ${SRC_URI} from:"
@@ -41,11 +45,11 @@ src_unpack() {
}
src_install() {
- exeinto "${dir}"
+ exeinto "${DIR}"
doexe game/${MY_PN}
- make_wrapper ${MY_PN,,} "${dir}"/${MY_PN}
+ make_wrapper ${MY_PN,,} "${DIR}"/${MY_PN}
- insinto "${dir}"
+ insinto "${DIR}"
doins -r game/{icon.bmp,WorkResource/,*.pkg}
newicon -s 256 support/icon.png ${MY_PN,,}.png