summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /games-action/luola
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'games-action/luola')
-rw-r--r--games-action/luola/Manifest3
-rw-r--r--games-action/luola/files/luola-1.3.2-underlink.patch11
-rw-r--r--games-action/luola/luola-1.3.2.ebuild59
-rw-r--r--games-action/luola/metadata.xml8
4 files changed, 81 insertions, 0 deletions
diff --git a/games-action/luola/Manifest b/games-action/luola/Manifest
new file mode 100644
index 000000000000..eeca78bed5d1
--- /dev/null
+++ b/games-action/luola/Manifest
@@ -0,0 +1,3 @@
+DIST luola-1.3.2.tar.gz 1774711 SHA256 3d0af35f379f9e058a0178f341100c1f9d28ced21d6c623a458661ca44cda337 SHA512 4e8b2f5e813dbb4d951632ded20f013aae6837d525d0068b430ae41319503f206ec27f2873cff241af8ba4cd1728ec89dcf8279a94dbb3094330de1ca531712f WHIRLPOOL 0de87e0ae1bd5075048ae5b5142143da82c430c5ed596fb46e2738f7e4d9f3b8e35fdd3e03a1c2b9b944a419f253877bf29c64c27c628caf32ca752cefeefa80
+DIST nostalgia-1.2.tar.gz 1475672 SHA256 675b51423cae1fcf2c4b0cb774e2130c8ce761b6cd91c1db59a6fca0ba18f202 SHA512 06a03b3398204c04f88fccbbf6a59f11da043c73dc203fe258e09e036364ee73cae337b9828bd27b52ebee6ff456c317143444c3b6c395addcdedf720988731f WHIRLPOOL f9bfff140085d2eaf4ff0e02844e7d3dbc7de20a5592324edbbcc1306de09b0955dfd731a3685361b97b8045dbf59e35ef54cc0b37db6670022ac63e1f9a3ecc
+DIST stdlevels-6.0.tar.gz 1850148 SHA256 70882a078de3e81793c31d1cfea11981dae4c1475c6f8a68c514e2461a64338b SHA512 d1823ca8340dea8766310962507bc5aad06c0f737c16c3ce32afaafc0e83a8b7b4d301d5cf65a0466fdaee9ec2a7ce718d03be61b383ac6fe030101466eff11a WHIRLPOOL fd2ec19f95a695ea1f2450063daff43b5d745d0b9cb788f6a722585706a8ec7be615d5bb3f369b7921c8a5471d559f55ba7e5aad3629aaec4d255cc95fe4d776
diff --git a/games-action/luola/files/luola-1.3.2-underlink.patch b/games-action/luola/files/luola-1.3.2-underlink.patch
new file mode 100644
index 000000000000..5bf998177be7
--- /dev/null
+++ b/games-action/luola/files/luola-1.3.2-underlink.patch
@@ -0,0 +1,11 @@
+--- src/Makefile.am.old 2011-06-17 08:41:40.882481147 +0200
++++ src/Makefile.am 2011-06-17 08:41:58.497602372 +0200
+@@ -2,7 +2,7 @@
+
+ bin_PROGRAMS = luola
+
+-luola_LDADD = @SDL_LIBS@
++luola_LDADD = @SDL_LIBS@ -lm
+
+ luola_SOURCES = \
+ defines.h \
diff --git a/games-action/luola/luola-1.3.2.ebuild b/games-action/luola/luola-1.3.2.ebuild
new file mode 100644
index 000000000000..15a6a2ce588d
--- /dev/null
+++ b/games-action/luola/luola-1.3.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils autotools gnome2-utils games
+
+DESCRIPTION="A 2D multiplayer arcade game resembling V-Wing"
+HOMEPAGE="https://freecode.com/projects/luola"
+SRC_URI="mirror://gentoo/${P}.tar.gz
+ mirror://gentoo/stdlevels-6.0.tar.gz
+ mirror://gentoo/nostalgia-1.2.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="media-libs/libsdl[X,sound,joystick,video]
+ media-libs/sdl-gfx
+ media-libs/sdl-image[jpeg,png]
+ media-libs/sdl-mixer
+ media-libs/sdl-ttf"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-underlink.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf --enable-sound
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ insinto "${GAMES_DATADIR}"/${PN}/levels
+ doins "${WORKDIR}"/*.{lev,png}
+ dodoc AUTHORS ChangeLog DATAFILE FAQ LEVELFILE README TODO \
+ RELEASENOTES.txt ../README.Nostalgia
+ newdoc ../README README.stdlevels
+ doicon -s 64 luola.png
+ make_desktop_entry luola Luola
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}
diff --git a/games-action/luola/metadata.xml b/games-action/luola/metadata.xml
new file mode 100644
index 000000000000..7833f208568e
--- /dev/null
+++ b/games-action/luola/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>games</herd>
+ <upstream>
+ <remote-id type="freecode">luola</remote-id>
+ </upstream>
+</pkgmetadata>