summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAustin English <wizardedit@gentoo.org>2017-01-25 16:48:45 -0600
committerAustin English <wizardedit@gentoo.org>2017-01-25 17:05:05 -0600
commita27d7123ca199c7bc22b73d2874c0bb60c35d799 (patch)
tree60b8dfe84319a3b743726ad412ad591a7594fe97 /games-action/lugaru/lugaru-9999.ebuild
parentgames-action/heroes: remove deprecated games eclass (diff)
downloadgentoo-a27d7123ca199c7bc22b73d2874c0bb60c35d799.tar.gz
gentoo-a27d7123ca199c7bc22b73d2874c0bb60c35d799.tar.bz2
gentoo-a27d7123ca199c7bc22b73d2874c0bb60c35d799.zip
games-action/lugaru: remove deprecated games eclass
Also update to EAPI 6 Gentoo-Bug: https://bugs.gentoo.org/574082 Package-Manager: Portage-2.3.2, Repoman-2.3.1
Diffstat (limited to 'games-action/lugaru/lugaru-9999.ebuild')
-rw-r--r--games-action/lugaru/lugaru-9999.ebuild33
1 files changed, 18 insertions, 15 deletions
diff --git a/games-action/lugaru/lugaru-9999.ebuild b/games-action/lugaru/lugaru-9999.ebuild
index 2c42553fdb8f..7aa42ee9c090 100644
--- a/games-action/lugaru/lugaru-9999.ebuild
+++ b/games-action/lugaru/lugaru-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
-inherit eutils cmake-utils mercurial games
+EAPI=6
+inherit eutils cmake-utils mercurial
EHG_REPO_URI="https://bitbucket.org/osslugaru/lugaru/"
DESCRIPTION="3D arcade with unique fighting system and anthropomorphic characters"
@@ -16,14 +16,14 @@ KEYWORDS=""
IUSE=""
RDEPEND="
- virtual/glu
- virtual/opengl
media-libs/libsdl[opengl,video]
- media-libs/openal
+ media-libs/libpng:0
media-libs/libvorbis
+ media-libs/openal
+ sys-libs/zlib
+ virtual/glu
virtual/jpeg:0
- media-libs/libpng:0
- sys-libs/zlib"
+ virtual/opengl"
DEPEND="${RDEPEND}
virtual/pkgconfig"
@@ -31,11 +31,15 @@ src_unpack() {
mercurial_src_unpack
}
+PATCHES=(
+ "${FILESDIR}/${P}-dir.patch"
+)
+
src_prepare() {
- epatch "${FILESDIR}/${P}-dir.patch"
- sed -i \
- -e "s:@GENTOO_DIR@:${GAMES_DATADIR}/${PN}:" \
- Source/OpenGL_Windows.cpp || die
+ default
+ sed -i \
+ -e "s:@GENTOO_DIR@:/usr/share/${PN}:" \
+ Source/OpenGL_Windows.cpp || die
}
src_configure() {
@@ -51,10 +55,9 @@ src_compile() {
}
src_install() {
- dogamesbin "${WORKDIR}/${P}_build/lugaru"
- insinto "${GAMES_DATADIR}/${PN}"
+ dobin "${WORKDIR}/${P}_build/lugaru"
+ insinto /usr/share/${PN}
doins -r Data/
newicon Source/win-res/Lugaru.png ${PN}.png
make_desktop_entry ${PN} Lugaru ${PN}
- prepgamesdirs
}