summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorRepository mirror & CI <repomirrorci@gentoo.org>2022-01-09 08:23:19 +0000
committerRepository mirror & CI <repomirrorci@gentoo.org>2022-01-09 08:23:19 +0000
commit4135cc08401202e2390fc9b15cf0343ddb6ed452 (patch)
tree522c349cf83429aaa6625386f3730433593593d9 /eclass
parent2022-01-09 08:07:06 UTC (diff)
parentdistutils-r1.eclass: Bump minimal pytest dep (diff)
downloadgentoo-4135cc08401202e2390fc9b15cf0343ddb6ed452.tar.gz
gentoo-4135cc08401202e2390fc9b15cf0343ddb6ed452.tar.bz2
gentoo-4135cc08401202e2390fc9b15cf0343ddb6ed452.zip
Merge updates from master
Diffstat (limited to 'eclass')
-rw-r--r--eclass/distutils-r1.eclass4
-rw-r--r--eclass/python-r1.eclass9
-rw-r--r--eclass/python-single-r1.eclass8
-rw-r--r--eclass/python-utils-r1.eclass10
-rwxr-xr-xeclass/tests/distutils-r1.sh2
-rwxr-xr-xeclass/tests/distutils-r1_single.sh2
6 files changed, 14 insertions, 21 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index 1b50dc4e74b4..7bd9baba8167 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: distutils-r1.eclass
@@ -405,7 +405,7 @@ distutils_enable_tests() {
test_pkg=">=dev-python/nose-1.3.7-r4"
;;
pytest)
- test_pkg=">=dev-python/pytest-4.5.0"
+ test_pkg=">=dev-python/pytest-6.2.5-r2"
;;
setup.py)
;;
diff --git a/eclass/python-r1.eclass b/eclass/python-r1.eclass
index dc624946cfc1..4b51cc18b959 100644
--- a/eclass/python-r1.eclass
+++ b/eclass/python-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: python-r1.eclass
@@ -125,7 +125,6 @@ fi
#
# Example value:
# @CODE
-# dev-lang/python-exec:=
# python_targets_python2_7? ( dev-lang/python:2.7[gdbm] )
# python_targets_pypy? ( dev-python/pypy[gdbm] )
# @CODE
@@ -207,12 +206,6 @@ _python_set_globals() {
local requse="|| ( ${flags[*]} )"
local usedep=${optflags// /,}
- # 1) well, python-exec would suffice as an RDEP
- # but no point in making this overcomplex, BDEP doesn't hurt anyone
- # 2) python-exec should be built with all targets forced anyway
- # but if new targets were added, we may need to force a rebuild
- deps+=">=dev-lang/python-exec-2:=[${usedep}]"
-
if [[ ${PYTHON_DEPS+1} ]]; then
# IUSE is magical, so we can't really check it
# (but we verify PYTHON_COMPAT already)
diff --git a/eclass/python-single-r1.eclass b/eclass/python-single-r1.eclass
index 228c66a77af6..5a4bcea55da4 100644
--- a/eclass/python-single-r1.eclass
+++ b/eclass/python-single-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: python-single-r1.eclass
@@ -136,7 +136,6 @@ EXPORT_FUNCTIONS pkg_setup
#
# Example value:
# @CODE
-# dev-lang/python-exec:=
# python_single_target_python2_7? ( dev-lang/python:2.7[gdbm] )
# python_single_target_pypy? ( dev-python/pypy[gdbm] )
# @CODE
@@ -219,13 +218,8 @@ _python_single_set_globals() {
local deps= i PYTHON_PKG_DEP
for i in "${_PYTHON_SUPPORTED_IMPLS[@]}"; do
_python_export "${i}" PYTHON_PKG_DEP
- # 1) well, python-exec would suffice as an RDEP
- # but no point in making this overcomplex, BDEP doesn't hurt anyone
- # 2) python-exec should be built with all targets forced anyway
- # but if new targets were added, we may need to force a rebuild
deps+="python_single_target_${i}? (
${PYTHON_PKG_DEP}
- >=dev-lang/python-exec-2:=[python_targets_${i}]
) "
done
diff --git a/eclass/python-utils-r1.eclass b/eclass/python-utils-r1.eclass
index 22e00c56815d..ff5b350cd469 100644
--- a/eclass/python-utils-r1.eclass
+++ b/eclass/python-utils-r1.eclass
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
# @ECLASS: python-utils-r1.eclass
@@ -416,12 +416,18 @@ _python_export() {
case ${impl} in
python2.7)
PYTHON_PKG_DEP='>=dev-lang/python-2.7.5-r2:2.7';;
+ python3.8)
+ PYTHON_PKG_DEP=">=dev-lang/python-3.8.12_p1-r1:3.8";;
+ python3.9)
+ PYTHON_PKG_DEP=">=dev-lang/python-3.9.9-r1:3.9";;
+ python3.10)
+ PYTHON_PKG_DEP=">=dev-lang/python-3.10.0_p1-r1:3.10";;
python*)
PYTHON_PKG_DEP="dev-lang/python:${impl#python}";;
pypy)
PYTHON_PKG_DEP='>=dev-python/pypy-7.3.0:0=';;
pypy3)
- PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.7:0=';;
+ PYTHON_PKG_DEP='>=dev-python/pypy3-7.3.7-r1:0=';;
*)
die "Invalid implementation: ${impl}"
esac
diff --git a/eclass/tests/distutils-r1.sh b/eclass/tests/distutils-r1.sh
index 1ccb1dfbc523..cd768066bf37 100755
--- a/eclass/tests/distutils-r1.sh
+++ b/eclass/tests/distutils-r1.sh
@@ -97,7 +97,7 @@ tend
einfo distutils_enable_tests
eindent
BASE_IUSE="python_targets_python3_8"
-BASE_DEPS="python_targets_python3_8? ( dev-lang/python:3.8 ) >=dev-lang/python-exec-2:=[python_targets_python3_8(-)?]"
+BASE_DEPS="python_targets_python3_8? ( >=dev-lang/python-3.8.12_p1-r1:3.8 )"
TEST_RESTRICT="!test? ( test )"
einfo "empty RDEPEND"
diff --git a/eclass/tests/distutils-r1_single.sh b/eclass/tests/distutils-r1_single.sh
index 56b62ca0e90f..fdeba2e2b9b2 100755
--- a/eclass/tests/distutils-r1_single.sh
+++ b/eclass/tests/distutils-r1_single.sh
@@ -77,7 +77,7 @@ inherit distutils-r1
einfo distutils_enable_tests
eindent
BASE_IUSE="+python_single_target_python3_8"
-BASE_DEPS="python_single_target_python3_8? ( dev-lang/python:3.8 >=dev-lang/python-exec-2:=[python_targets_python3_8] )"
+BASE_DEPS="python_single_target_python3_8? ( >=dev-lang/python-3.8.12_p1-r1:3.8 )"
TEST_RESTRICT="!test? ( test )"
einfo "empty RDEPEND"