summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-04-27 23:21:41 +0100
committerSam James <sam@gentoo.org>2024-04-27 23:22:12 +0100
commit95c9cb63290d8e22ba06ea12e016c28031911f48 (patch)
tree4a6d716616099cddafd8a9030c1a2eedbc9f1139 /dev-vcs
parentapp-editors/emacs: Stabilize 29.3-r2 arm, #930795 (diff)
downloadgentoo-95c9cb63290d8e22ba06ea12e016c28031911f48.tar.gz
gentoo-95c9cb63290d8e22ba06ea12e016c28031911f48.tar.bz2
gentoo-95c9cb63290d8e22ba06ea12e016c28031911f48.zip
dev-vcs/git-extras: fix test deps
I was clearly working too late last night. Fix obvious error in omission of python_check_deps and also the testpath dep. Closes: https://bugs.gentoo.org/930758 Closes: https://bugs.gentoo.org/930800 Fixes: 3cdee62a15218b82803a620b86b6b2cae1d8a8a9 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/git-extras/git-extras-7.2.0.ebuild7
1 files changed, 7 insertions, 0 deletions
diff --git a/dev-vcs/git-extras/git-extras-7.2.0.ebuild b/dev-vcs/git-extras/git-extras-7.2.0.ebuild
index 6c3441ad3f2f..514d3fd4d220 100644
--- a/dev-vcs/git-extras/git-extras-7.2.0.ebuild
+++ b/dev-vcs/git-extras/git-extras-7.2.0.ebuild
@@ -25,10 +25,17 @@ BDEPEND="
$(python_gen_any_dep '
>=dev-python/GitPython-3.1.40[${PYTHON_USEDEP}]
>=dev-python/pytest-7.2[${PYTHON_USEDEP}]
+ dev-python/testpath[${PYTHON_USEDEP}]
')
)
"
+python_check_deps() {
+ python_has_version ">=dev-python/GitPython-3.1.40[${PYTHON_USEDEP}]" &&
+ python_has_version ">=dev-python/pytest-7.2[${PYTHON_USEDEP}]" &&
+ python_has_version "dev-python/testpath[${PYTHON_USEDEP}]"
+}
+
pkg_setup() {
use test && python-any-r1_pkg_setup
}