summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Torokhov <torokhov-s-a@yandex.ru>2024-02-25 10:30:44 +0300
committerSam James <sam@gentoo.org>2024-04-14 01:42:10 +0100
commitae4038e370cd4fce4104b348df7d29d398a3050e (patch)
treebbedceff00fa5fa3c055d88a45dbf9212c0b11b6 /dev-vcs/tortoisehg
parentmedia-gfx/gimp: 2.99.18, 9999 enable py3.12 (diff)
downloadgentoo-ae4038e370cd4fce4104b348df7d29d398a3050e.tar.gz
gentoo-ae4038e370cd4fce4104b348df7d29d398a3050e.tar.bz2
gentoo-ae4038e370cd4fce4104b348df7d29d398a3050e.zip
dev-vcs/tortoisehg: 6.6.3 version bump; add 9999.ebuild py3.12 compat
Closes: https://bugs.gentoo.org/929565 Signed-off-by: Sergey Torokhov <torokhov-s-a@yandex.ru> Closes: https://github.com/gentoo/gentoo/pull/35519 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-vcs/tortoisehg')
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-6.6.3.ebuild81
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild6
3 files changed, 85 insertions, 3 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 895dc5450fdc..cd311607d1db 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -1 +1,2 @@
DIST tortoisehg-6.5.1.tar.gz 8854923 BLAKE2B 7536f5d7c2b0cda5bb812b2135dcb54ce9bf02a523648e4569bbca5772d3568a63cb09549b6e10c46d212e3c98791f3014b62386d68b488f78f57a235e0be36c SHA512 0e568937f25afa681e8c5f8b8ecc40ede046999318ff80bdd27516b523169c778c695a2a800876eac40480d6e009c83c6493dec3110673f5b79f284be1d4948b
+DIST tortoisehg-6.6.3.tar.gz 8857342 BLAKE2B 166d1305ed3ee54496b3e0b08fc92a34a56a9398aa618a0f2266e7413fafc371be3c308debc3260a15b59c147a00bbe0773df52a838c4a4f0028b29c1cb05090 SHA512 8de8a68a753e8554dcb9936f6ba237e0598df65e6039f7c608e692bc375258e64a443e27e63c337f361fc32c0076b79bd98a972c220089902ff4489ab3507928
diff --git a/dev-vcs/tortoisehg/tortoisehg-6.6.3.ebuild b/dev-vcs/tortoisehg/tortoisehg-6.6.3.ebuild
new file mode 100644
index 000000000000..51dfb4c89ae7
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-6.6.3.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit desktop distutils-r1 optfeature xdg-utils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-vcs/mercurial-6.3.2[${PYTHON_USEDEP}]' python3_11 )
+ <dev-vcs/mercurial-6.7[${PYTHON_USEDEP}]"
+ S="${WORKDIR}/thg-${PV}"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://foss.heptapod.net/mercurial/${PN}/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.11.6[qt5(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc/source
+
+python_prepare_all() {
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
+
+ sed -i -e 's:share/doc/tortoisehg:share/doc/'"${PF}"':' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} tests/run-tests.py -m 'not largefiles' --disable-pytest-warnings --doctest-modules tests || die "Tests failed with ${EPYTHON}"
+ ${EPYTHON} tests/run-tests.py -m largefiles --disable-pytest-warnings tests || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+
+ optfeature "the core git extension support" dev-python/pygit2
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 372918b6780f..51dfb4c89ae7 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_COMPAT=( python3_{10..12} )
DISTUTILS_USE_PEP517=setuptools
inherit desktop distutils-r1 optfeature xdg-utils
@@ -13,7 +13,7 @@ if [[ ${PV} != *9999* ]]; then
SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-vcs/mercurial-6.3.2[${PYTHON_USEDEP}]' python3_11 )
- <dev-vcs/mercurial-6.6[${PYTHON_USEDEP}]"
+ <dev-vcs/mercurial-6.7[${PYTHON_USEDEP}]"
S="${WORKDIR}/thg-${PV}"
else
inherit mercurial