summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-10-08 13:34:58 +0200
committerPacho Ramos <pacho@gentoo.org>2016-10-08 13:34:58 +0200
commitb1638ccb950f026b98e0787fbb88e67de8a28558 (patch)
treeb5c2b4f6e1a093a11fbcd45d1ca13c59c98bbb4e /dev-vcs/git-deps/git-deps-9999.ebuild
parentRemove some masked for removal eclasses (diff)
downloadgentoo-b1638ccb950f026b98e0787fbb88e67de8a28558.tar.gz
gentoo-b1638ccb950f026b98e0787fbb88e67de8a28558.tar.bz2
gentoo-b1638ccb950f026b98e0787fbb88e67de8a28558.zip
Remove masked for removal package
Diffstat (limited to 'dev-vcs/git-deps/git-deps-9999.ebuild')
-rw-r--r--dev-vcs/git-deps/git-deps-9999.ebuild48
1 files changed, 0 insertions, 48 deletions
diff --git a/dev-vcs/git-deps/git-deps-9999.ebuild b/dev-vcs/git-deps/git-deps-9999.ebuild
deleted file mode 100644
index 0e5eb8a78dfd..000000000000
--- a/dev-vcs/git-deps/git-deps-9999.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=6
-
-EGIT_REPO_URI="https://github.com/aspiers/git-deps"
-EGIT_BRANCH=master
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit eutils git-r3 python-single-r1
-
-DESCRIPTION="git commit dependency analysis tool"
-HOMEPAGE="https://github.com/aspiers/git-deps"
-
-LICENSE="GPL-2"
-SLOT="0"
-
-RDEPEND="
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/pygit2[${PYTHON_USEDEP}]
- net-libs/nodejs
- ${PYTHON_DEPS}
- "
-DEPEND="${RDEPEND}"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-HTML_DOCS="html/."
-
-pkg_setup() {
- python-single-r1_pkg_setup
-}
-
-src_install() {
- python_newscript git-deps.py git-deps
- einstalldocs
-}
-
-pkg_postinst() {
- elog "Notes regarding the '--serve' option:"
- elog "Please run 'npm install browserify' once"
- elog "Copy the html sources:"
- elog "rsync -av ${EROOT}/usr/share/${PN}/html ~/git-deps-html"
- elog "cd ~/git-deps-html"
- elog "npm install"
- elog "browserify -t coffeeify -d js/git-deps-graph.coffee -o js/bundle.js"
-}