summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2024-12-06 16:27:12 -0600
committerWilliam Hubbs <williamh@gentoo.org>2024-12-06 16:27:12 -0600
commit8d27dea25db8b86d741d4a3425799b89abbf0728 (patch)
treef06f1750588d6b76a1cb3cea658d687c704f002d /dev-util
parentdev-util/gitlab-runner: add 17.4.2 (diff)
downloadgentoo-8d27dea25db8b86d741d4a3425799b89abbf0728.tar.gz
gentoo-8d27dea25db8b86d741d4a3425799b89abbf0728.tar.bz2
gentoo-8d27dea25db8b86d741d4a3425799b89abbf0728.zip
dev-util/gitlab-runner: add 17.5.4
Signed-off-by: William Hubbs <williamh@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gitlab-runner/Manifest2
-rw-r--r--dev-util/gitlab-runner/gitlab-runner-17.5.4.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-util/gitlab-runner/Manifest b/dev-util/gitlab-runner/Manifest
index 7bdf07a09079..5697f1c7e8d2 100644
--- a/dev-util/gitlab-runner/Manifest
+++ b/dev-util/gitlab-runner/Manifest
@@ -10,3 +10,5 @@ DIST gitlab-runner-17.4.2-deps.tar.xz 104738856 BLAKE2B 4ee77d51927e0ba869b146b2
DIST gitlab-runner-17.4.2.tar.bz2 1407513 BLAKE2B 5a1aec519e7a23fe4480ba07a506622c1300459ea04c0d9f5dffbd51e9db78595d5b3bc3c9646cffa7408c973311fab54c541c99796e271ffb8cf451a897c671 SHA512 9b99f3e38afa0cda9a555b5353e1cb0b6dfedee69c4da4994d419096edd7c83a2c1811a95185d8b0f4ca5706144838737873f373564be4bc0d326d13a8071f95
DIST gitlab-runner-17.5.1-deps.tar.xz 108461592 BLAKE2B e78fc32c94f469267fb416f1f6d20341c7d06c46b21771ff35c6d46c5959d64d596c348df7f854a52c81bfae8c8ec3cedcecbf155be86ae832c66e3ce15abf45 SHA512 25d55ae1198415b1485a4209d19de034ad13cf25d300e50726cf67f69e27d8db3b02c664a631db3180a2ba192e9927dbba5fb5cdec7cfc35c7f5f56266f23836
DIST gitlab-runner-17.5.1.tar.bz2 1725228 BLAKE2B 7aceaa08ac654b0e197eeac81828b505e940a0c37c1d47cee375858b650651277c4ce257f60106e845341252dccd9748d1c79fca5cac2cc151e08b9c4736b18c SHA512 f534bb38dfc42dcaa40067956a76680788d926e957f3fbf6bf763547428d0d896a2eb3360ed297c47fe2861d8fa992cf42e77346b552f4ed50fef9bb50f8cf93
+DIST gitlab-runner-17.5.4-deps.tar.xz 108479468 BLAKE2B c060c4a4e17b9e9a2ba9bf0b8eb15f2cca8546118bfd3e94fc19862a5c1578d1c9e9414ede859406a5ae713cc487f44306b2230dc044262c323d8380ce79f0ca SHA512 226ced14c0e8513d11e120f0b8673d59d8d18db7f54602ecc273bbf9cb1b1d540d0e360a3f211bf7500c43ee8b9ead1ac96d7ce462dac2243e441a8232c8da41
+DIST gitlab-runner-17.5.4.tar.bz2 1726499 BLAKE2B 98f5ab8260853ac399b9872599ec0a4e34c53d5c99a32231848eeba89ee9e16caafd1c5b49f00e3ece1c3eb1a0ff215d72b5e26a8ff18aa77e3b78effa0c7d9f SHA512 bf9d1a0803c922898e873edabd576fcd3a801885e5cb27acfab48b2f3cf0d6dc6976cdd0c0154401758bdf45e9b6991b5b311183c233b69ae611b18db22a71a3
diff --git a/dev-util/gitlab-runner/gitlab-runner-17.5.4.ebuild b/dev-util/gitlab-runner/gitlab-runner-17.5.4.ebuild
new file mode 100644
index 000000000000..d7776438632d
--- /dev/null
+++ b/dev-util/gitlab-runner/gitlab-runner-17.5.4.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd tmpfiles
+
+# make sure this gets updated for every bump
+GIT_COMMIT=d8d88d9e
+
+DESCRIPTION="The official GitLab Runner, written in Go"
+HOMEPAGE="https://gitlab.com/gitlab-org/gitlab-runner"
+SRC_URI="https://gitlab.com/gitlab-org/gitlab-runner/-/archive/v${PV}/${PN}-v${PV}.tar.bz2 -> ${P}.tar.bz2"
+SRC_URI+=" https://dev.gentoo.org/~williamh/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~ppc64 ~riscv"
+
+COMMON_DEPEND="acct-group/gitlab-runner
+ acct-user/gitlab-runner"
+DEPEND="${COMMON_DEPEND}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="dev-go/gox"
+
+DOCS=( docs CHANGELOG.md README.md config.toml.example )
+
+S="${WORKDIR}/${PN}-v${PV}"
+
+src_compile() {
+ emake \
+ BUILT="$(date -u '+%Y-%m-%dT%H:%M:%S%:z')" \
+ GOX="${EPREFIX}/usr/bin/gox" \
+ REVISION=${GIT_COMMIT} \
+ VERSION=${PV} \
+ runner-bin-host
+}
+
+src_test() {
+ CI=0 ego test
+}
+
+src_install() {
+ dobin out/binaries/gitlab-runner
+ einstalldocs
+
+ newconfd "${FILESDIR}/${PN}.confd" "${PN}"
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+ systemd_dounit "${FILESDIR}/${PN}.service"
+ newtmpfiles "${FILESDIR}"/${PN}.tmpfile ${PN}.conf
+ keepdir /{etc,var/log}/${PN}
+ fperms 0700 /{etc,var/log}/gitlab-runner
+ fowners gitlab-runner:gitlab-runner /{etc,var/log}/${PN}
+}
+
+pkg_postinst() {
+ tmpfiles_process gitlab-runner.conf
+ [[ -f ${EROOT}/etc/gitlab-runner/config.toml ]] && return
+ elog
+ elog "To use the runner, you need to register it with this command:"
+ elog "# gitlab-runner register"
+ elog "This will also create the configuration file in /etc/gitlab-runner/config.toml"
+}