summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-06-30 11:25:33 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-06-30 13:19:23 -0500
commit1e2ade0e9fecfd14846864cf21067d9e03375cf2 (patch)
tree6ff33f4d0e830aea003e28d39776da126be6d4ba /dev-util
parentmedia-sound/quodlibet: version bump to 4.2.1 (diff)
downloadgentoo-1e2ade0e9fecfd14846864cf21067d9e03375cf2.tar.gz
gentoo-1e2ade0e9fecfd14846864cf21067d9e03375cf2.tar.bz2
gentoo-1e2ade0e9fecfd14846864cf21067d9e03375cf2.zip
dev-util/cppcheck: version bump to 1.88
- Cannot reproduce test failure with new version Closes: https://bugs.gentoo.org/688764 Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppcheck/Manifest1
-rw-r--r--dev-util/cppcheck/cppcheck-1.88.ebuild113
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.88-ldflags.patch17
-rw-r--r--dev-util/cppcheck/files/cppcheck-1.88-tinyxml2.patch101
4 files changed, 232 insertions, 0 deletions
diff --git a/dev-util/cppcheck/Manifest b/dev-util/cppcheck/Manifest
index 3c9ce707e0c6..2d4d3044aea6 100644
--- a/dev-util/cppcheck/Manifest
+++ b/dev-util/cppcheck/Manifest
@@ -1,2 +1,3 @@
DIST cppcheck-1.86.tar.gz 2184186 BLAKE2B 8b488ec72d0998d6b037de2b1204373c8b3de475ad165bf108bb331399356cb0d1e20a7bc6f368f1a038ec886ad7a84ad694172d0a96a203a6877f3838c21001 SHA512 59cec55b8408e8f2e2e7172bce69350c248bc3185a0938b523c44a58f98b344e11aef957ec1b7a7b2bc7a876660b2683e51f54b76f0b550f9549497c29453655
DIST cppcheck-1.87.tar.gz 2243258 BLAKE2B ffe42bfb2e896163678c5bb24e46ae2391ba8254cbe7c1c19c3c1b16cd38adf9c773de6aaefe70af08b9c1dca8b0b0b5e9939323368a2f81491fd6981ff18139 SHA512 b0149002b40260c1488904929296403722a66b84263b41d0097c3caed28265332766c114f0d1f378ea6c7e73ab973ea71ab89c6744f6cc818f22de08933e6766
+DIST cppcheck-1.88.tar.gz 2364053 BLAKE2B b688974ff83019422cc5b2ec575d9838bdff4ada17d71fb3d436f07eea50429490c222659163b845667d98c0ec186b3288464827894e379fd017dd0c3fea645f SHA512 fa4ede0665546341af0ba3dae09a00b6efae09ec7838c616c580be01ff6902594d61168a059539779be0c78e1708d2bd9c8e7987dd0bb67dc8fa332a10d1de6a
diff --git a/dev-util/cppcheck/cppcheck-1.88.ebuild b/dev-util/cppcheck/cppcheck-1.88.ebuild
new file mode 100644
index 000000000000..69aa5c7a1adf
--- /dev/null
+++ b/dev-util/cppcheck/cppcheck-1.88.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
+inherit distutils-r1 qmake-utils toolchain-funcs
+
+DESCRIPTION="Static analyzer of C/C++ code"
+HOMEPAGE="https://github.com/danmar/cppcheck"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="htmlreport pcre qt5"
+
+RDEPEND="
+ dev-libs/tinyxml2:=
+ htmlreport? ( dev-python/pygments[${PYTHON_USEDEP}] )
+ pcre? ( dev-libs/libpcre )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtprintsupport:5
+ )
+"
+DEPEND="${RDEPEND}
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.88-tinyxml2.patch
+ "${FILESDIR}"/${PN}-1.88-ldflags.patch
+)
+
+src_prepare() {
+ default
+
+ rm -r externals/tinyxml || die
+}
+
+src_configure() {
+ tc-export CXX PKG_CONFIG
+ export LIBS="$(${PKG_CONFIG} --libs tinyxml2)"
+
+ emake dmake
+ ./dmake || die
+
+ if use pcre ; then
+ sed -e '/HAVE_RULES=/s:=no:=yes:' \
+ -i Makefile || die
+ fi
+
+ if use qt5 ; then
+ pushd gui || die
+ eqmake5
+ popd || die
+ fi
+}
+
+src_compile() {
+ emake ${PN} man \
+ CFGDIR="${EROOT}/usr/share/${PN}/cfg" \
+ DB2MAN="${EROOT}/usr/share/sgml/docbook/xsl-stylesheets/manpages/docbook.xsl"
+
+ if use qt5 ; then
+ pushd gui || die
+ emake
+ popd || die
+ fi
+
+ if use htmlreport ; then
+ pushd htmlreport || die
+ distutils-r1_src_compile
+ popd || die
+ fi
+}
+
+src_test() {
+ # safe final version
+ mv -v ${PN}{,.final} || die
+ mv -v lib/library.o{,.final} || die
+ mv -v cli/cppcheckexecutor.o{,.final} || die
+ #trigger recompile with CFGDIR inside ${S}
+ emake check CFGDIR="${S}/cfg"
+ # restore
+ mv -v ${PN}{.final,} || die
+ mv -v lib/library.o{.final,} || die
+ mv -v cli/cppcheckexecutor.o{.final,} || die
+}
+
+src_install() {
+ # it's not autotools-based, so "${ED}" here, not "${D}", bug 531760
+ emake install DESTDIR="${ED}"
+
+ insinto "/usr/share/${PN}/cfg"
+ doins cfg/*.cfg
+ if use qt5 ; then
+ dobin gui/${PN}-gui
+ dodoc gui/{projectfile.txt,gui.${PN}}
+ fi
+ if use htmlreport ; then
+ pushd htmlreport || die
+ distutils-r1_src_install
+ popd || die
+ find "${D}" -name "*.egg-info" -delete
+ else
+ rm "${ED}/usr/bin/cppcheck-htmlreport" || die
+ fi
+ doman ${PN}.1
+ dodoc -r tools/triage
+}
diff --git a/dev-util/cppcheck/files/cppcheck-1.88-ldflags.patch b/dev-util/cppcheck/files/cppcheck-1.88-ldflags.patch
new file mode 100644
index 000000000000..ef7e01212a3f
--- /dev/null
+++ b/dev-util/cppcheck/files/cppcheck-1.88-ldflags.patch
@@ -0,0 +1,17 @@
+diff --git a/tools/dmake.cpp b/tools/dmake.cpp
+index c3afd26..5c3a0a6 100644
+--- a/tools/dmake.cpp
++++ b/tools/dmake.cpp
+@@ -370,10 +370,10 @@ int main(int argc, char **argv)
+ fout << ".PHONY: run-dmake tags\n\n";
+ fout << "\n###### Targets\n\n";
+ fout << "cppcheck: $(LIBOBJ) $(CLIOBJ) $(EXTOBJ)\n";
+- fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LIBS) $(LDFLAGS) $(RDYNAMIC)\n\n";
++ fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LDFLAGS) $(RDYNAMIC) $(LIBS)\n\n";
+ fout << "all:\tcppcheck testrunner\n\n";
+ fout << "testrunner: $(TESTOBJ) $(LIBOBJ) $(EXTOBJ) cli/threadexecutor.o cli/cmdlineparser.o cli/cppcheckexecutor.o cli/filelister.o\n";
+- fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LIBS) $(LDFLAGS) $(RDYNAMIC)\n\n";
++ fout << "\t$(CXX) $(CPPFLAGS) $(CXXFLAGS) -o $@ $^ $(LDFLAGS) $(RDYNAMIC) $(LIBS)\n\n";
+ fout << "test:\tall\n";
+ fout << "\t./testrunner\n\n";
+ fout << "check:\tall\n";
diff --git a/dev-util/cppcheck/files/cppcheck-1.88-tinyxml2.patch b/dev-util/cppcheck/files/cppcheck-1.88-tinyxml2.patch
new file mode 100644
index 000000000000..0ad79ebf4d0d
--- /dev/null
+++ b/dev-util/cppcheck/files/cppcheck-1.88-tinyxml2.patch
@@ -0,0 +1,101 @@
+diff --git a/gui/gui.pro b/gui/gui.pro
+index 0cbaebf..cb381dd 100644
+--- a/gui/gui.pro
++++ b/gui/gui.pro
+@@ -15,6 +15,7 @@ contains(LINKCORE, [yY][eE][sS]) {
+ DEFINES += CPPCHECKLIB_IMPORT
+ }
+ LIBS += -L$$PWD/../externals
++LIBS += $(shell $(PKG_CONFIG) --libs tinyxml2)
+
+ DESTDIR = .
+ RCC_DIR = temp
+diff --git a/tools/dmake.cpp b/tools/dmake.cpp
+index 298cb98..c3afd26 100644
+--- a/tools/dmake.cpp
++++ b/tools/dmake.cpp
+@@ -122,7 +122,6 @@ int main(int argc, char **argv)
+
+ std::vector<std::string> extfiles;
+ extfiles.push_back("externals/simplecpp/simplecpp.cpp");
+- extfiles.push_back("externals/tinyxml/tinyxml2.cpp");
+
+ std::vector<std::string> clifiles;
+ getCppFiles(clifiles, "cli/", false);
+@@ -171,7 +170,6 @@ int main(int argc, char **argv)
+ std::ofstream fout1("test/testfiles.pri");
+ if (fout1.is_open()) {
+ fout1 << "# no manual edits - this file is autogenerated by dmake\n\n";
+- fout1 << "INCLUDEPATH += ../externals/tinyxml\n";
+ fout1 << "\n\nSOURCES += ";
+ for (unsigned int i = 0; i < testfiles.size(); ++i) {
+ const std::string filename(testfiles[i].substr(5));
+@@ -341,9 +339,9 @@ int main(int argc, char **argv)
+ << "endif\n\n";
+
+ makeConditionalVariable(fout, "PREFIX", "/usr");
+- makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -isystem externals -isystem externals/simplecpp -isystem externals/tinyxml");
+- makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -isystem externals/simplecpp -isystem externals/tinyxml");
+- makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -isystem externals/simplecpp -isystem externals/tinyxml");
++ makeConditionalVariable(fout, "INCLUDE_FOR_LIB", "-Ilib -isystem externals -isystem externals/simplecpp");
++ makeConditionalVariable(fout, "INCLUDE_FOR_CLI", "-Ilib -isystem externals/simplecpp");
++ makeConditionalVariable(fout, "INCLUDE_FOR_TEST", "-Ilib -Icli -isystem externals/simplecpp");
+
+ fout << "BIN=$(DESTDIR)$(PREFIX)/bin\n\n";
+ fout << "# For 'make man': sudo apt-get install xsltproc docbook-xsl docbook-xml on Linux\n";
+diff --git a/oss-fuzz/Makefile b/oss-fuzz/Makefile
+index 81cf654..26f9da9 100644
+--- a/oss-fuzz/Makefile
++++ b/oss-fuzz/Makefile
+@@ -6,8 +6,8 @@
+ # make CXX=clang++-6.0 CXXFLAGS="-fsanitize=address" fuzz-client
+
+ CPPCHECK_DIR=..
+-INCLUDE_DIR=-I ${CPPCHECK_DIR}/lib -I ${CPPCHECK_DIR}/externals/simplecpp -I ${CPPCHECK_DIR}/externals/tinyxml -I ${CPPCHECK_DIR}/externals
+-SRC_FILES=main.cpp type2.cpp ${CPPCHECK_DIR}/externals/simplecpp/simplecpp.cpp ${CPPCHECK_DIR}/externals/tinyxml/tinyxml2.cpp ${CPPCHECK_DIR}/lib/*.cpp
++INCLUDE_DIR=-I ${CPPCHECK_DIR}/lib -I ${CPPCHECK_DIR}/externals/simplecpp -I ${CPPCHECK_DIR}/externals
++SRC_FILES=main.cpp type2.cpp ${CPPCHECK_DIR}/externals/simplecpp/simplecpp.cpp ${CPPCHECK_DIR}/lib/*.cpp
+
+ all: oss-fuzz-client translate
+
+diff --git a/Makefile b/Makefile
+index 372647e..9d65717 100644
+--- a/Makefile
++++ b/Makefile
+@@ -179,8 +179,7 @@ LIBOBJ = $(libcppdir)/analyzerinfo.o \
+ $(libcppdir)/tokenlist.o \
+ $(libcppdir)/valueflow.o
+
+-EXTOBJ = externals/simplecpp/simplecpp.o \
+- externals/tinyxml/tinyxml2.o
++EXTOBJ = externals/simplecpp/simplecpp.o
+
+ CLIOBJ = cli/cmdlineparser.o \
+ cli/cppcheckexecutor.o \
+@@ -689,9 +688,6 @@ test/testvarid.o: test/testvarid.cpp lib/platform.h lib/config.h lib/settings.h
+ externals/simplecpp/simplecpp.o: externals/simplecpp/simplecpp.cpp externals/simplecpp/simplecpp.h
+ $(CXX) $(CPPFLAGS) $(CFG) $(CXXFLAGS) -w $(UNDEF_STRICT_ANSI) -c -o externals/simplecpp/simplecpp.o externals/simplecpp/simplecpp.cpp
+
+-externals/tinyxml/tinyxml2.o: externals/tinyxml/tinyxml2.cpp externals/tinyxml/tinyxml2.h
+- $(CXX) $(CPPFLAGS) $(CFG) $(CXXFLAGS) -w $(UNDEF_STRICT_ANSI) -c -o externals/tinyxml/tinyxml2.o externals/tinyxml/tinyxml2.cpp
+-
+ tools/clang-ast.o: tools/clang-ast.cpp
+ $(CXX) ${INCLUDE_FOR_LIB} $(CPPFLAGS) $(CFG) $(CXXFLAGS) $(UNDEF_STRICT_ANSI) -c -o tools/clang-ast.o tools/clang-ast.cpp
+
+diff --git a/externals/externals.pri b/externals/externals.pri
+index 7f0be8d..b1e94e0 100644
+--- a/externals/externals.pri
++++ b/externals/externals.pri
+@@ -1,9 +1,6 @@
+ INCLUDEPATH += $${PWD} \
+- $${PWD}/simplecpp \
+- $${PWD}/tinyxml
++ $${PWD}/simplecpp
+
+-HEADERS += $${PWD}/simplecpp/simplecpp.h \
+- $${PWD}/tinyxml/tinyxml2.h
++HEADERS += $${PWD}/simplecpp/simplecpp.h
+
+-SOURCES += $${PWD}/simplecpp/simplecpp.cpp \
+- $${PWD}/tinyxml/tinyxml2.cpp
++SOURCES += $${PWD}/simplecpp/simplecpp.cpp