summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilfried Holzke <gentoo@holzke.net>2021-03-24 19:51:38 +0100
committerCraig Andrews <candrews@gentoo.org>2021-03-25 13:55:55 -0400
commit1de9bf0c32863100b3e5a2afc19253cf76a2ecfd (patch)
tree72677b9c6ca396cd83e3c6348f5e427a5f7dd19c /dev-util/rocm-cmake/rocm-cmake-4.1.0.ebuild
parentprofiles/arch/sparc/package.use.mask: drop dar[threads] mask (diff)
downloadgentoo-1de9bf0c32863100b3e5a2afc19253cf76a2ecfd.tar.gz
gentoo-1de9bf0c32863100b3e5a2afc19253cf76a2ecfd.tar.bz2
gentoo-1de9bf0c32863100b3e5a2afc19253cf76a2ecfd.zip
dev-util/rocm-cmake: Version bump to 4.1.0
Signed-off-by: Wilfried Holzke <gentoo@holzke.net> Package-Manager: Portage-3.0.13, Repoman-3.0.2 Closes: https://github.com/gentoo/gentoo/pull/20105 Signed-off-by: Craig Andrews <candrews@gentoo.org>
Diffstat (limited to 'dev-util/rocm-cmake/rocm-cmake-4.1.0.ebuild')
-rw-r--r--dev-util/rocm-cmake/rocm-cmake-4.1.0.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/rocm-cmake/rocm-cmake-4.1.0.ebuild b/dev-util/rocm-cmake/rocm-cmake-4.1.0.ebuild
new file mode 100644
index 000000000000..e23ea832ca54
--- /dev/null
+++ b/dev-util/rocm-cmake/rocm-cmake-4.1.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/RadeonOpenCompute/rocm-cmake/"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/RadeonOpenCompute/rocm-cmake/archive/rocm-${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/rocm-cmake-rocm-${PV}"
+fi
+
+DESCRIPTION="Radeon Open Compute CMake Modules"
+HOMEPAGE="https://github.com/RadeonOpenCompute/rocm-cmake"
+LICENSE="MIT"
+SLOT="0"
+RESTRICT="test"
+
+src_prepare() {
+ sed -e "s:set(ROCM_INSTALL_LIBDIR lib):set(ROCM_INSTALL_LIBDIR $(get_libdir)):" -i "${S}/share/rocm/cmake/ROCMInstallTargets.cmake" || die
+ cmake_src_prepare
+}