summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authororbea <orbea@riseup.net>2022-05-04 10:48:20 -0700
committerSam James <sam@gentoo.org>2022-05-05 05:05:48 +0100
commite155af013558a4a3164fb9867ef1d65d34c6ed3a (patch)
treecaac241c703a7fe0eddd5f593e8c785b046226c2 /dev-util/ragel/ragel-7.0.4-r2.ebuild
parentapp-text/zathura-cb: Stabilize 0.1.9 x86, #841620 (diff)
downloadgentoo-e155af013558a4a3164fb9867ef1d65d34c6ed3a.tar.gz
gentoo-e155af013558a4a3164fb9867ef1d65d34c6ed3a.tar.bz2
gentoo-e155af013558a4a3164fb9867ef1d65d34c6ed3a.zip
dev-util/ragel: Fix patch for slibtool
Upstream-PR: https://github.com/adrian-thurston/ragel/pull/85 Bug: https://bugs.gentoo.org/820260 Bug: https://bugs.gentoo.org/839048 Closes: https://bugs.gentoo.org/832391 Closes: https://github.com/gentoo/gentoo/pull/25322 Signed-off-by: orbea <orbea@riseup.net> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/ragel/ragel-7.0.4-r2.ebuild')
-rw-r--r--dev-util/ragel/ragel-7.0.4-r2.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/dev-util/ragel/ragel-7.0.4-r2.ebuild b/dev-util/ragel/ragel-7.0.4-r2.ebuild
new file mode 100644
index 000000000000..b83f4136930d
--- /dev/null
+++ b/dev-util/ragel/ragel-7.0.4-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Compiles finite state machines from regular languages into executable code"
+HOMEPAGE="https://www.colm.net/open-source/ragel/"
+SRC_URI="https://www.colm.net/files/ragel/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="doc"
+
+# Notes from bug #766090
+# dev-libs/libxml2's xmllint ends up being called by asciidoc here
+# app-text/dblatex too
+# app-text/ghostscript-gpl too
+BDEPEND="
+ doc? (
+ || ( app-text/asciidoc dev-ruby/asciidoctor )
+ app-text/dblatex
+ app-text/ghostscript-gpl
+ dev-libs/libxml2
+ dev-texlive/texlive-latex
+ dev-python/pygments
+ media-gfx/transfig
+ )
+"
+DEPEND=">=dev-util/colm-0.14.7-r1"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-7.0.4-drop-julia-check.patch
+ "${FILESDIR}"/${PN}-7.0.4-r2-link-colm-properly.patch
+)
+
+src_prepare() {
+ default
+
+ # Fix hardcoded search dir
+ sed -i -e "s:\$withval/lib:\$withval/$(get_libdir):" configure.ac || die
+
+ # Allow either asciidoctor or asciidoc
+ # bug #733426
+ sed -i -e 's/(\[ASCIIDOC\], \[asciidoc\], \[asciidoc\]/S([ASCIIDOC], [asciidoc asciidoctor]/' configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-colm="${EPREFIX}/usr" \
+ $(use_enable doc manual)
+}
+
+src_install() {
+ default
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins ragel.vim
+
+ find "${ED}" -name '*.la' -delete || die
+}