summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-01-21 06:00:34 -0500
committerAaron W. Swenson <titanofold@gentoo.org>2018-01-21 06:01:01 -0500
commit02a3f64089b68b7931ddbbdcb202adc1d7c4189b (patch)
tree934fe284511c7ba4346960129508dd30ed408431 /dev-util/premake/premake-5.0.0_alpha12.ebuild
parentmedia-gfx/graphicsmagick: Synced live ebuild. (diff)
downloadgentoo-02a3f64089b68b7931ddbbdcb202adc1d7c4189b.tar.gz
gentoo-02a3f64089b68b7931ddbbdcb202adc1d7c4189b.tar.bz2
gentoo-02a3f64089b68b7931ddbbdcb202adc1d7c4189b.zip
dev-util/premake: Bump to 4.4_beta5, 5.0.0_alpha12
Closes: https://bugs.gentoo.org/556906 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'dev-util/premake/premake-5.0.0_alpha12.ebuild')
-rw-r--r--dev-util/premake/premake-5.0.0_alpha12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/premake/premake-5.0.0_alpha12.ebuild b/dev-util/premake/premake-5.0.0_alpha12.ebuild
new file mode 100644
index 000000000000..77ea240109ba
--- /dev/null
+++ b/dev-util/premake/premake-5.0.0_alpha12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P=${P/_/-}
+MY_PV=${PV/_/-}
+inherit versionator
+
+DESCRIPTION="A makefile generation tool"
+HOMEPAGE="https://premake.github.io/"
+SRC_URI="https://github.com/${PN}/${PN}-core/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="BSD"
+
+SLOT=$(get_major_version)
+
+KEYWORDS="~amd64 ~ppc ~x86"
+
+S="${WORKDIR}/${PN}-core-${MY_PV}"
+
+src_compile() {
+ emake -f Bootstrap.mak linux
+}
+
+src_test() {
+ bin/release/premake${SLOT} test || die
+}
+
+src_install() {
+ dobin bin/release/premake${SLOT}
+
+ einstalldocs
+}