summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-03-05 18:41:16 -0500
committerSam James <sam@gentoo.org>2024-03-06 03:36:19 +0000
commitb3713507aa127da8d7a6b498fec2a7753b85f334 (patch)
tree2ea1839a00f42a06211d6f7df23a3e7072df36c5 /dev-util/plan9port
parentgames-fps/rott: mark as LTO-unsafe (diff)
downloadgentoo-b3713507aa127da8d7a6b498fec2a7753b85f334.tar.gz
gentoo-b3713507aa127da8d7a6b498fec2a7753b85f334.tar.bz2
gentoo-b3713507aa127da8d7a6b498fec2a7753b85f334.zip
dev-util/plan9port: mark as LTO-unsafe
Closes: https://bugs.gentoo.org/858452 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-util/plan9port')
-rw-r--r--dev-util/plan9port/plan9port-0_pre20230331-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-util/plan9port/plan9port-0_pre20230331-r1.ebuild b/dev-util/plan9port/plan9port-0_pre20230331-r1.ebuild
index 4373389cdfc5..2b558154c3ee 100644
--- a/dev-util/plan9port/plan9port-0_pre20230331-r1.ebuild
+++ b/dev-util/plan9port/plan9port-0_pre20230331-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit multiprocessing toolchain-funcs readme.gentoo-r1
+inherit flag-o-matic multiprocessing toolchain-funcs readme.gentoo-r1
MY_HASH="cc4571fec67407652b03d6603ada6580de2194dc"
MY_P="${PN}-${MY_HASH}"
@@ -88,6 +88,11 @@ src_prepare() {
}
src_configure() {
+ # -Werror=lto-type-mismatch
+ # https://bugs.gentoo.org/858452
+ # https://github.com/9fans/plan9port/issues/646
+ filter-lto
+
local -a myconf=(
CC9="$(tc-getCC)"
CC9FLAGS="'${CFLAGS} ${LDFLAGS}'"